summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/enchant/enchant2_2.2.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/enchant/enchant2_2.2.3.bb b/meta-oe/recipes-support/enchant/enchant2_2.2.3.bb
new file mode 100644
index 0000000000..42150c88f3
--- /dev/null
+++ b/meta-oe/recipes-support/enchant/enchant2_2.2.3.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Enchant Spell checker API Library v2"
2SECTION = "libs"
3HOMEPAGE = "https://abiword.github.io/enchant/"
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
6
7DEPENDS = "glib-2.0"
8
9inherit autotools pkgconfig
10
11SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
12SRC_URI[md5sum] = "4b8abb58e00e93363591b3f5ea4f52d5"
13SRC_URI[sha256sum] = "abd8e915675cff54c0d4da5029d95c528362266557c61c7149d53fa069b8076d"
14
15S = "${WORKDIR}/enchant-${PV}"
16
17EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
18
19PACKAGECONFIG ??= "hunspell"
20PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
21PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
22
23FILES_${PN} += " \
24 ${datadir}/enchant-2 \
25 ${libdir}/enchant-2 \
26"