diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-lz4/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb | 9 |
2 files changed, 2 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lz4/run-ptest b/meta-python/recipes-devtools/python/python3-lz4/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-lz4/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb b/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb index 746926da4e..7bbe59e8b7 100644 --- a/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb +++ b/meta-python/recipes-devtools/python/python3-lz4_4.3.3.bb | |||
@@ -9,24 +9,19 @@ DEPENDS += " \ | |||
9 | python3-pkgconfig-native \ | 9 | python3-pkgconfig-native \ |
10 | " | 10 | " |
11 | 11 | ||
12 | SRC_URI += "file://run-ptest" | ||
13 | |||
14 | SRC_URI[sha256sum] = "01fe674ef2889dbb9899d8a67361e0c4a2c833af5aeb37dd505727cf5d2a131e" | 12 | SRC_URI[sha256sum] = "01fe674ef2889dbb9899d8a67361e0c4a2c833af5aeb37dd505727cf5d2a131e" |
15 | 13 | ||
16 | inherit pkgconfig pypi python_setuptools_build_meta ptest | 14 | inherit pkgconfig pypi python_setuptools_build_meta ptest-python-pytest |
17 | 15 | ||
18 | RDEPENDS:${PN}-ptest += "\ | 16 | RDEPENDS:${PN}-ptest += "\ |
19 | python3-coverage \ | 17 | python3-coverage \ |
20 | python3-pytest \ | ||
21 | python3-pytest-cov \ | 18 | python3-pytest-cov \ |
22 | python3-pytest-runner \ | 19 | python3-pytest-runner \ |
23 | python3-multiprocessing \ | 20 | python3-multiprocessing \ |
24 | python3-psutil \ | 21 | python3-psutil \ |
25 | python3-unittest-automake-output \ | ||
26 | " | 22 | " |
27 | 23 | ||
28 | do_install_ptest() { | 24 | do_install_ptest:append () { |
29 | cp -rf ${S}/tests/ ${D}${PTEST_PATH}/ | ||
30 | # The stream API is experimental and not enabled yet, so don't ship the test suite | 25 | # The stream API is experimental and not enabled yet, so don't ship the test suite |
31 | rm -rf ${D}${PTEST_PATH}/tests/stream | 26 | rm -rf ${D}${PTEST_PATH}/tests/stream |
32 | } | 27 | } |