diff options
3 files changed, 0 insertions, 86 deletions
diff --git a/meta-gnome/recipes-gnome/bonobo/files/0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch b/meta-gnome/recipes-gnome/bonobo/files/0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch deleted file mode 100644 index e9aebb853e..0000000000 --- a/meta-gnome/recipes-gnome/bonobo/files/0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From b75879e8c3e24d338c0e5843d616bc9b02da4d04 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 26 Aug 2017 09:52:17 -0700 | ||
4 | Subject: [PATCH] bonobo-ui-node: qualify functions with G_GNUC_PRINTF | ||
5 | |||
6 | This helps compiler in doing format checking correctly | ||
7 | Fixes | ||
8 | bonobo-ui-node.c:864:38: error: format string is not a string literal [-Werror,-Wformat-nonliteral] | ||
9 | | g_logv ("XML", G_LOG_LEVEL_ERROR, msg, args); | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | bonobo/bonobo-ui-node.c | 6 +++--- | ||
14 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/bonobo/bonobo-ui-node.c b/bonobo/bonobo-ui-node.c | ||
17 | index 9bab5e5..6ec66e2 100644 | ||
18 | --- a/bonobo/bonobo-ui-node.c | ||
19 | +++ b/bonobo/bonobo-ui-node.c | ||
20 | @@ -835,7 +835,7 @@ uiCharacters (ParseState *ps, const xmlChar *chars, int len) | ||
21 | g_string_append_len (ps->content, chars, len); | ||
22 | } | ||
23 | |||
24 | -static void | ||
25 | +static G_GNUC_PRINTF(2, 3) void | ||
26 | uiWarning (ParseState *ps, const char *msg, ...) | ||
27 | { | ||
28 | va_list args; | ||
29 | @@ -845,7 +845,7 @@ uiWarning (ParseState *ps, const char *msg, ...) | ||
30 | va_end (args); | ||
31 | } | ||
32 | |||
33 | -static void | ||
34 | +static G_GNUC_PRINTF(2, 3) void | ||
35 | uiError (ParseState *ps, const char *msg, ...) | ||
36 | { | ||
37 | va_list args; | ||
38 | @@ -855,7 +855,7 @@ uiError (ParseState *ps, const char *msg, ...) | ||
39 | va_end (args); | ||
40 | } | ||
41 | |||
42 | -static void | ||
43 | +static G_GNUC_PRINTF(2, 3) void | ||
44 | uiFatalError (ParseState *ps, const char *msg, ...) | ||
45 | { | ||
46 | va_list args; | ||
47 | -- | ||
48 | 2.14.1 | ||
49 | |||
diff --git a/meta-gnome/recipes-gnome/bonobo/files/gcc5.patch b/meta-gnome/recipes-gnome/bonobo/files/gcc5.patch deleted file mode 100644 index f7528adad4..0000000000 --- a/meta-gnome/recipes-gnome/bonobo/files/gcc5.patch +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | Index: libbonoboui-2.24.5/tools/browser/Makefile.am | ||
2 | =================================================================== | ||
3 | --- libbonoboui-2.24.5.orig/tools/browser/Makefile.am | ||
4 | +++ libbonoboui-2.24.5/tools/browser/Makefile.am | ||
5 | @@ -2,7 +2,6 @@ INCLUDES = \ | ||
6 | -DBONOBO_BROWSER_DATADIR=\""$(datadir)"\" \ | ||
7 | -DBONOBO_SUPPORT_LOCALEDIR=\""$(datadir)/locale"\" \ | ||
8 | -I$(srcdir) -I$(top_srcdir) \ | ||
9 | - -I$(top_srcdir)/bonobo-browser \ | ||
10 | $(BONOBOUI_CFLAGS) \ | ||
11 | $(WARN_CFLAGS) | ||
12 | |||
diff --git a/meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb b/meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb deleted file mode 100644 index 8e3169e342..0000000000 --- a/meta-gnome/recipes-gnome/bonobo/libbonoboui_2.24.5.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | SECTION = "x11/gnome/libs" | ||
2 | LICENSE = "GPLv2 & LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
4 | file://COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34" | ||
5 | |||
6 | inherit distro_features_check gnomebase pkgconfig gtk-doc | ||
7 | |||
8 | REQUIRED_DISTRO_FEATURES = "x11" | ||
9 | |||
10 | SRC_URI += "file://gcc5.patch \ | ||
11 | file://0001-bonobo-ui-node-qualify-functions-with-G_GNUC_PRINTF.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[archive.md5sum] = "853be8e28aaa4ce48ba60be7d9046bf4" | ||
15 | SRC_URI[archive.sha256sum] = "fab5f2ac6c842d949861c07cb520afe5bee3dce55805151ce9cd01be0ec46fcd" | ||
16 | GNOME_COMPRESS_TYPE="bz2" | ||
17 | |||
18 | DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gconf libxml2 libglade gnome-common intltool-native" | ||
19 | |||
20 | FILES_${PN} += "${libdir}/libglade/2.0/*.so" | ||
21 | FILES_${PN}-dev += "${libdir}/libglade/2.0/*.la ${datadir}/gnome-2.0/ui \ | ||
22 | ${libdir}/bonobo-2.0/samples" | ||
23 | FILES_${PN}-staticdev += "${libdir}/libglade/2.0/*.a" | ||
24 | FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \ | ||
25 | ${libdir}/libglade/2.0/.debug" | ||