diff options
4 files changed, 8 insertions, 90 deletions
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq/0001-dnsmasq-fix-build-against-5.2-headers.patch b/meta-networking/recipes-support/dnsmasq/dnsmasq/0001-dnsmasq-fix-build-against-5.2-headers.patch deleted file mode 100644 index 844a709856..0000000000 --- a/meta-networking/recipes-support/dnsmasq/dnsmasq/0001-dnsmasq-fix-build-against-5.2-headers.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 52f4b58c14a2788ca08b7d8884d586724d86fc66 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Mon, 19 Aug 2019 14:46:02 +0000 | ||
4 | Subject: [PATCH] dnsmasq: fix build against 5.2 headers | ||
5 | |||
6 | Upstream linux y2038 work has moved some definitions SIOCGSTAMP is | ||
7 | defined in linux/sockios.h, not asm/sockios.h now. So we need to | ||
8 | add that include to fix the build. | ||
9 | |||
10 | Upstream-status: backport of http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=3052ce208acf602f0163166dcefb7330d537cedb | ||
11 | |||
12 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
13 | --- | ||
14 | a/src/dnsmasq.h | 1 + | ||
15 | 1 file changed, 1 insertion(+) | ||
16 | |||
17 | diff --git a/build/tmp/work/core2-64-poky-linux/dnsmasq/2.80-r0/dnsmasq-2.80/src/dnsmasq.h b/build/tmp/work/core2-64-poky-linux/dnsmasq/2.80-r0/dnsmasq-2.80/src/dnsmasq.h | ||
18 | index f53e9a5be6..d9225ea473 100644 | ||
19 | --- a/src/dnsmasq.h | ||
20 | +++ b/src/dnsmasq.h | ||
21 | @@ -138,6 +138,7 @@ typedef unsigned long long u64; | ||
22 | #endif | ||
23 | |||
24 | #if defined(HAVE_LINUX_NETWORK) | ||
25 | +#include <linux/sockios.h> | ||
26 | #include <linux/capability.h> | ||
27 | /* There doesn't seem to be a universally-available | ||
28 | userspace header for these. */ | ||
29 | -- | ||
30 | 2.19.1 | ||
31 | |||
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq/0001-dnsmasq-fix-memory-leak-in-helper-c.patch b/meta-networking/recipes-support/dnsmasq/dnsmasq/0001-dnsmasq-fix-memory-leak-in-helper-c.patch deleted file mode 100644 index ccd6f82ae8..0000000000 --- a/meta-networking/recipes-support/dnsmasq/dnsmasq/0001-dnsmasq-fix-memory-leak-in-helper-c.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 69bc94779c2f035a9fffdb5327a54c3aeca73ed5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Simon Kelley <simon@thekelleys.org.uk> | ||
3 | Date: Wed, 14 Aug 2019 20:44:50 +0100 | ||
4 | Subject: [PATCH] Fix memory leak in helper.c | ||
5 | |||
6 | Thanks to Xu Mingjie <xumingjie1995@outlook.com> for spotting this. | ||
7 | |||
8 | CVE: CVE-2019-14834 | ||
9 | Upstream-Status: Backport | ||
10 | Signed-off-by: Zhixiong Chi <zhixiong.chi@windriver.com> | ||
11 | --- | ||
12 | src/helper.c | 12 +++++++++--- | ||
13 | 1 file changed, 9 insertions(+), 3 deletions(-) | ||
14 | |||
15 | diff --git a/src/helper.c b/src/helper.c | ||
16 | index 33ba120..c392eec 100644 | ||
17 | --- a/src/helper.c | ||
18 | +++ b/src/helper.c | ||
19 | @@ -82,7 +82,8 @@ int create_helper(int event_fd, int err_fd, uid_t uid, gid_t gid, long max_fd) | ||
20 | pid_t pid; | ||
21 | int i, pipefd[2]; | ||
22 | struct sigaction sigact; | ||
23 | - | ||
24 | + unsigned char *alloc_buff = NULL; | ||
25 | + | ||
26 | /* create the pipe through which the main program sends us commands, | ||
27 | then fork our process. */ | ||
28 | if (pipe(pipefd) == -1 || !fix_fd(pipefd[1]) || (pid = fork()) == -1) | ||
29 | @@ -188,11 +189,16 @@ int create_helper(int event_fd, int err_fd, uid_t uid, gid_t gid, long max_fd) | ||
30 | struct script_data data; | ||
31 | char *p, *action_str, *hostname = NULL, *domain = NULL; | ||
32 | unsigned char *buf = (unsigned char *)daemon->namebuff; | ||
33 | - unsigned char *end, *extradata, *alloc_buff = NULL; | ||
34 | + unsigned char *end, *extradata; | ||
35 | int is6, err = 0; | ||
36 | int pipeout[2]; | ||
37 | |||
38 | - free(alloc_buff); | ||
39 | + /* Free rarely-allocated memory from previous iteration. */ | ||
40 | + if (alloc_buff) | ||
41 | + { | ||
42 | + free(alloc_buff); | ||
43 | + alloc_buff = NULL; | ||
44 | + } | ||
45 | |||
46 | /* we read zero bytes when pipe closed: this is our signal to exit */ | ||
47 | if (!read_write(pipefd[0], (unsigned char *)&data, sizeof(data), 1)) | ||
48 | -- | ||
49 | 1.7.10.4 | ||
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq_2.80.bb b/meta-networking/recipes-support/dnsmasq/dnsmasq_2.80.bb deleted file mode 100644 index 827565051d..0000000000 --- a/meta-networking/recipes-support/dnsmasq/dnsmasq_2.80.bb +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | require dnsmasq.inc | ||
2 | |||
3 | SRC_URI[dnsmasq-2.80.md5sum] = "1f071fd11454e1cffea73bdadcf70b21" | ||
4 | SRC_URI[dnsmasq-2.80.sha256sum] = "9e4a58f816ce0033ce383c549b7d4058ad9b823968d352d2b76614f83ea39adc" | ||
5 | SRC_URI += "\ | ||
6 | file://lua.patch \ | ||
7 | file://0001-dnsmasq-fix-build-against-5.2-headers.patch \ | ||
8 | file://0001-dnsmasq-fix-memory-leak-in-helper-c.patch \ | ||
9 | " | ||
10 | |||
diff --git a/meta-networking/recipes-support/dnsmasq/dnsmasq_2.81.bb b/meta-networking/recipes-support/dnsmasq/dnsmasq_2.81.bb new file mode 100644 index 0000000000..92415386c2 --- /dev/null +++ b/meta-networking/recipes-support/dnsmasq/dnsmasq_2.81.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | require dnsmasq.inc | ||
2 | |||
3 | SRC_URI[dnsmasq-2.81.md5sum] = "e43808177a773014b5892ccba238f7a8" | ||
4 | SRC_URI[dnsmasq-2.81.sha256sum] = "3c28c68c6c2967c3a96e9b432c0c046a5df17a426d3a43cffe9e693cf05804d0" | ||
5 | SRC_URI += "\ | ||
6 | file://lua.patch \ | ||
7 | " | ||
8 | |||