diff options
-rw-r--r-- | meta-networking/recipes-filter/libnftnl/libnftnl/0002-avoid-naming-local-function-as-one-of-printf-family.patch | 54 | ||||
-rw-r--r-- | meta-networking/recipes-filter/libnftnl/libnftnl_1.1.4.bb (renamed from meta-networking/recipes-filter/libnftnl/libnftnl_1.1.3.bb) | 2 |
2 files changed, 41 insertions, 15 deletions
diff --git a/meta-networking/recipes-filter/libnftnl/libnftnl/0002-avoid-naming-local-function-as-one-of-printf-family.patch b/meta-networking/recipes-filter/libnftnl/libnftnl/0002-avoid-naming-local-function-as-one-of-printf-family.patch index 561f0e5540..e64091b50b 100644 --- a/meta-networking/recipes-filter/libnftnl/libnftnl/0002-avoid-naming-local-function-as-one-of-printf-family.patch +++ b/meta-networking/recipes-filter/libnftnl/libnftnl/0002-avoid-naming-local-function-as-one-of-printf-family.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 9e2c810ebc3c917ea7483205178416e9eaf952fe Mon Sep 17 00:00:00 2001 | 1 | From 373e13e28e34b4d415fc096e1c7175f4ecfbf0da Mon Sep 17 00:00:00 2001 |
2 | From: Alex Kiernan <alex.kiernan@gmail.com> | 2 | From: Yuan Chao <yuanc.fnst@cn.fujitsu.com> |
3 | Date: Wed, 7 Nov 2018 19:41:54 +0000 | 3 | Date: Wed, 21 Aug 2019 11:18:56 +0900 |
4 | Subject: [PATCH] avoid naming local function as one of printf family | 4 | Subject: [PATCH] avoid naming local function as one of printf family |
5 | 5 | ||
6 | Fixes build issues with clang | 6 | Fixes build issues with clang |
@@ -8,6 +8,8 @@ error: no member named '__builtin___snprintf_chk' in 'struct expr_ops' | |||
8 | 8 | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
10 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | 10 | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> |
11 | |||
12 | Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> | ||
11 | --- | 13 | --- |
12 | include/expr_ops.h | 2 +- | 14 | include/expr_ops.h | 2 +- |
13 | include/obj.h | 2 +- | 15 | include/obj.h | 2 +- |
@@ -44,11 +46,13 @@ Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | |||
44 | src/expr/reject.c | 2 +- | 46 | src/expr/reject.c | 2 +- |
45 | src/expr/rt.c | 2 +- | 47 | src/expr/rt.c | 2 +- |
46 | src/expr/socket.c | 2 +- | 48 | src/expr/socket.c | 2 +- |
49 | src/expr/synproxy.c | 2 +- | ||
47 | src/expr/target.c | 2 +- | 50 | src/expr/target.c | 2 +- |
48 | src/expr/tproxy.c | 2 +- | 51 | src/expr/tproxy.c | 2 +- |
49 | src/expr/tunnel.c | 2 +- | 52 | src/expr/tunnel.c | 2 +- |
50 | src/expr/xfrm.c | 2 +- | 53 | src/expr/xfrm.c | 2 +- |
51 | src/obj/counter.c | 2 +- | 54 | src/obj/counter.c | 2 +- |
55 | src/obj/ct_expect.c | 2 +- | ||
52 | src/obj/ct_helper.c | 2 +- | 56 | src/obj/ct_helper.c | 2 +- |
53 | src/obj/ct_timeout.c | 2 +- | 57 | src/obj/ct_timeout.c | 2 +- |
54 | src/obj/limit.c | 2 +- | 58 | src/obj/limit.c | 2 +- |
@@ -56,7 +60,7 @@ Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> | |||
56 | src/obj/secmark.c | 2 +- | 60 | src/obj/secmark.c | 2 +- |
57 | src/obj/tunnel.c | 2 +- | 61 | src/obj/tunnel.c | 2 +- |
58 | src/object.c | 2 +- | 62 | src/object.c | 2 +- |
59 | 47 files changed, 48 insertions(+), 48 deletions(-) | 63 | 49 files changed, 50 insertions(+), 50 deletions(-) |
60 | 64 | ||
61 | diff --git a/include/expr_ops.h b/include/expr_ops.h | 65 | diff --git a/include/expr_ops.h b/include/expr_ops.h |
62 | index a7f1b9a..d2946de 100644 | 66 | index a7f1b9a..d2946de 100644 |
@@ -72,10 +76,10 @@ index a7f1b9a..d2946de 100644 | |||
72 | 76 | ||
73 | struct expr_ops *nftnl_expr_ops_lookup(const char *name); | 77 | struct expr_ops *nftnl_expr_ops_lookup(const char *name); |
74 | diff --git a/include/obj.h b/include/obj.h | 78 | diff --git a/include/obj.h b/include/obj.h |
75 | index 35b5c40..decd1ce 100644 | 79 | index 9394d79..08610d7 100644 |
76 | --- a/include/obj.h | 80 | --- a/include/obj.h |
77 | +++ b/include/obj.h | 81 | +++ b/include/obj.h |
78 | @@ -92,7 +92,7 @@ struct obj_ops { | 82 | @@ -99,7 +99,7 @@ struct obj_ops { |
79 | const void *(*get)(const struct nftnl_obj *e, uint16_t type, uint32_t *data_len); | 83 | const void *(*get)(const struct nftnl_obj *e, uint16_t type, uint32_t *data_len); |
80 | int (*parse)(struct nftnl_obj *e, struct nlattr *attr); | 84 | int (*parse)(struct nftnl_obj *e, struct nlattr *attr); |
81 | void (*build)(struct nlmsghdr *nlh, const struct nftnl_obj *e); | 85 | void (*build)(struct nlmsghdr *nlh, const struct nftnl_obj *e); |
@@ -157,10 +161,10 @@ index 89a602e..a32a69e 100644 | |||
157 | + .snprintf_ = nftnl_expr_counter_snprintf, | 161 | + .snprintf_ = nftnl_expr_counter_snprintf, |
158 | }; | 162 | }; |
159 | diff --git a/src/expr/ct.c b/src/expr/ct.c | 163 | diff --git a/src/expr/ct.c b/src/expr/ct.c |
160 | index b9ca2dc..6fbed1d 100644 | 164 | index 124de9d..7bde179 100644 |
161 | --- a/src/expr/ct.c | 165 | --- a/src/expr/ct.c |
162 | +++ b/src/expr/ct.c | 166 | +++ b/src/expr/ct.c |
163 | @@ -272,5 +272,5 @@ struct expr_ops expr_ops_ct = { | 167 | @@ -273,5 +273,5 @@ struct expr_ops expr_ops_ct = { |
164 | .get = nftnl_expr_ct_get, | 168 | .get = nftnl_expr_ct_get, |
165 | .parse = nftnl_expr_ct_parse, | 169 | .parse = nftnl_expr_ct_parse, |
166 | .build = nftnl_expr_ct_build, | 170 | .build = nftnl_expr_ct_build, |
@@ -190,10 +194,10 @@ index 68115ba..6e43bb4 100644 | |||
190 | + .snprintf_ = nftnl_expr_dynset_snprintf, | 194 | + .snprintf_ = nftnl_expr_dynset_snprintf, |
191 | }; | 195 | }; |
192 | diff --git a/src/expr/exthdr.c b/src/expr/exthdr.c | 196 | diff --git a/src/expr/exthdr.c b/src/expr/exthdr.c |
193 | index bef453e..f2696d6 100644 | 197 | index e5f714b..e68792b 100644 |
194 | --- a/src/expr/exthdr.c | 198 | --- a/src/expr/exthdr.c |
195 | +++ b/src/expr/exthdr.c | 199 | +++ b/src/expr/exthdr.c |
196 | @@ -271,5 +271,5 @@ struct expr_ops expr_ops_exthdr = { | 200 | @@ -276,5 +276,5 @@ struct expr_ops expr_ops_exthdr = { |
197 | .get = nftnl_expr_exthdr_get, | 201 | .get = nftnl_expr_exthdr_get, |
198 | .parse = nftnl_expr_exthdr_parse, | 202 | .parse = nftnl_expr_exthdr_parse, |
199 | .build = nftnl_expr_exthdr_build, | 203 | .build = nftnl_expr_exthdr_build, |
@@ -311,10 +315,10 @@ index 4fa74b2..249c6b5 100644 | |||
311 | + .snprintf_ = nftnl_expr_match_snprintf, | 315 | + .snprintf_ = nftnl_expr_match_snprintf, |
312 | }; | 316 | }; |
313 | diff --git a/src/expr/meta.c b/src/expr/meta.c | 317 | diff --git a/src/expr/meta.c b/src/expr/meta.c |
314 | index ffcc896..5eaeb68 100644 | 318 | index 73f6efa..35d5ec5 100644 |
315 | --- a/src/expr/meta.c | 319 | --- a/src/expr/meta.c |
316 | +++ b/src/expr/meta.c | 320 | +++ b/src/expr/meta.c |
317 | @@ -222,5 +222,5 @@ struct expr_ops expr_ops_meta = { | 321 | @@ -226,5 +226,5 @@ struct expr_ops expr_ops_meta = { |
318 | .get = nftnl_expr_meta_get, | 322 | .get = nftnl_expr_meta_get, |
319 | .parse = nftnl_expr_meta_parse, | 323 | .parse = nftnl_expr_meta_parse, |
320 | .build = nftnl_expr_meta_build, | 324 | .build = nftnl_expr_meta_build, |
@@ -453,6 +457,17 @@ index 96550d5..2394dbf 100644 | |||
453 | - .snprintf = nftnl_expr_socket_snprintf, | 457 | - .snprintf = nftnl_expr_socket_snprintf, |
454 | + .snprintf_ = nftnl_expr_socket_snprintf, | 458 | + .snprintf_ = nftnl_expr_socket_snprintf, |
455 | }; | 459 | }; |
460 | diff --git a/src/expr/synproxy.c b/src/expr/synproxy.c | ||
461 | index 245f4fb..9721029 100644 | ||
462 | --- a/src/expr/synproxy.c | ||
463 | +++ b/src/expr/synproxy.c | ||
464 | @@ -166,5 +166,5 @@ struct expr_ops expr_ops_synproxy = { | ||
465 | .get = nftnl_expr_synproxy_get, | ||
466 | .parse = nftnl_expr_synproxy_parse, | ||
467 | .build = nftnl_expr_synproxy_build, | ||
468 | - .snprintf = nftnl_expr_synproxy_snprintf, | ||
469 | + .snprintf_ = nftnl_expr_synproxy_snprintf, | ||
470 | }; | ||
456 | diff --git a/src/expr/target.c b/src/expr/target.c | 471 | diff --git a/src/expr/target.c b/src/expr/target.c |
457 | index 9100038..7180085 100644 | 472 | index 9100038..7180085 100644 |
458 | --- a/src/expr/target.c | 473 | --- a/src/expr/target.c |
@@ -508,6 +523,17 @@ index 1baba4e..3710bce 100644 | |||
508 | - .snprintf = nftnl_obj_counter_snprintf, | 523 | - .snprintf = nftnl_obj_counter_snprintf, |
509 | + .snprintf_ = nftnl_obj_counter_snprintf, | 524 | + .snprintf_ = nftnl_obj_counter_snprintf, |
510 | }; | 525 | }; |
526 | diff --git a/src/obj/ct_expect.c b/src/obj/ct_expect.c | ||
527 | index c0bb5ba..953c08c 100644 | ||
528 | --- a/src/obj/ct_expect.c | ||
529 | +++ b/src/obj/ct_expect.c | ||
530 | @@ -209,5 +209,5 @@ struct obj_ops obj_ops_ct_expect = { | ||
531 | .get = nftnl_obj_ct_expect_get, | ||
532 | .parse = nftnl_obj_ct_expect_parse, | ||
533 | .build = nftnl_obj_ct_expect_build, | ||
534 | - .snprintf = nftnl_obj_ct_expect_snprintf, | ||
535 | + .snprintf_ = nftnl_obj_ct_expect_snprintf, | ||
536 | }; | ||
511 | diff --git a/src/obj/ct_helper.c b/src/obj/ct_helper.c | 537 | diff --git a/src/obj/ct_helper.c b/src/obj/ct_helper.c |
512 | index d91f636..2037461 100644 | 538 | index d91f636..2037461 100644 |
513 | --- a/src/obj/ct_helper.c | 539 | --- a/src/obj/ct_helper.c |
@@ -575,10 +601,10 @@ index 7ffade8..800eb3e 100644 | |||
575 | + .snprintf_ = nftnl_obj_tunnel_snprintf, | 601 | + .snprintf_ = nftnl_obj_tunnel_snprintf, |
576 | }; | 602 | }; |
577 | diff --git a/src/object.c b/src/object.c | 603 | diff --git a/src/object.c b/src/object.c |
578 | index 5c8d183..d489cdd 100644 | 604 | index d8c87ee..5307d7e 100644 |
579 | --- a/src/object.c | 605 | --- a/src/object.c |
580 | +++ b/src/object.c | 606 | +++ b/src/object.c |
581 | @@ -369,7 +369,7 @@ static int nftnl_obj_snprintf_dflt(char *buf, size_t size, | 607 | @@ -370,7 +370,7 @@ static int nftnl_obj_snprintf_dflt(char *buf, size_t size, |
582 | SNPRINTF_BUFFER_SIZE(ret, remain, offset); | 608 | SNPRINTF_BUFFER_SIZE(ret, remain, offset); |
583 | 609 | ||
584 | if (obj->ops) { | 610 | if (obj->ops) { |
diff --git a/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.3.bb b/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.4.bb index 00bf88daba..705b6a6c34 100644 --- a/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.3.bb +++ b/meta-networking/recipes-filter/libnftnl/libnftnl_1.1.4.bb | |||
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=79808397c3355f163c012616125c9e26" | |||
4 | SECTION = "libs" | 4 | SECTION = "libs" |
5 | DEPENDS = "libmnl" | 5 | DEPENDS = "libmnl" |
6 | 6 | ||
7 | SRCREV = "d819a832e0214a3bec3679345f542644596a2850" | 7 | SRCREV = "7c19dc01a88dbcf9a45fa791cd27a51b563bcf29" |
8 | SRC_URI = "git://git.netfilter.org/libnftnl \ | 8 | SRC_URI = "git://git.netfilter.org/libnftnl \ |
9 | file://0001-Move-exports-before-symbol-definition.patch \ | 9 | file://0001-Move-exports-before-symbol-definition.patch \ |
10 | file://0002-avoid-naming-local-function-as-one-of-printf-family.patch \ | 10 | file://0002-avoid-naming-local-function-as-one-of-printf-family.patch \ |