diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-soupsieve/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-soupsieve_2.6.bb | 12 |
2 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve/run-ptest b/meta-python/recipes-devtools/python/python3-soupsieve/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-soupsieve/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve_2.6.bb b/meta-python/recipes-devtools/python/python3-soupsieve_2.6.bb index dc317ea6c0..dfcd9f4842 100644 --- a/meta-python/recipes-devtools/python/python3-soupsieve_2.6.bb +++ b/meta-python/recipes-devtools/python/python3-soupsieve_2.6.bb | |||
@@ -6,11 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1bdfa4c8e8b6830bcf8e78cba1669e4d" | |||
6 | 6 | ||
7 | SRC_URI[sha256sum] = "e2e68417777af359ec65daac1057404a3c8a5455bb8abc36f1a9866ab1a51abb" | 7 | SRC_URI[sha256sum] = "e2e68417777af359ec65daac1057404a3c8a5455bb8abc36f1a9866ab1a51abb" |
8 | 8 | ||
9 | inherit pypi python_hatchling python_setuptools_build_meta ptest | 9 | inherit pypi python_hatchling python_setuptools_build_meta ptest-python-pytest |
10 | 10 | ||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | RDEPENDS:${PN} += " \ | 11 | RDEPENDS:${PN} += " \ |
15 | python3-core \ | 12 | python3-core \ |
16 | python3-datetime \ | 13 | python3-datetime \ |
@@ -21,13 +18,6 @@ RDEPENDS:${PN}:append:class-target = " \ | |||
21 | 18 | ||
22 | RDEPENDS:${PN}-ptest += " \ | 19 | RDEPENDS:${PN}-ptest += " \ |
23 | python3-beautifulsoup4 \ | 20 | python3-beautifulsoup4 \ |
24 | python3-pytest \ | ||
25 | python3-unittest-automake-output \ | ||
26 | " | 21 | " |
27 | 22 | ||
28 | do_install_ptest() { | ||
29 | install -d ${D}${PTEST_PATH}/tests | ||
30 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
31 | } | ||
32 | |||
33 | BBCLASSEXTEND = "native nativesdk" | 23 | BBCLASSEXTEND = "native nativesdk" |