diff options
-rw-r--r-- | meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-support/nss/nss_3.56.bb (renamed from meta-oe/recipes-support/nss/nss_3.54.bb) | 3 |
2 files changed, 12 insertions, 24 deletions
diff --git a/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch b/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch index 1a87a0577f..bfc375e83a 100644 --- a/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch +++ b/meta-oe/recipes-support/nss/nss/0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch | |||
@@ -14,21 +14,18 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> | |||
14 | nss/lib/freebl/gcm.c | 2 ++ | 14 | nss/lib/freebl/gcm.c | 2 ++ |
15 | 2 files changed, 6 insertions(+) | 15 | 2 files changed, 6 insertions(+) |
16 | 16 | ||
17 | diff --git a/nss/lib/freebl/Makefile b/nss/lib/freebl/Makefile | ||
18 | index f99f769..b0ec81b 100644 | ||
19 | --- a/nss/lib/freebl/Makefile | 17 | --- a/nss/lib/freebl/Makefile |
20 | +++ b/nss/lib/freebl/Makefile | 18 | +++ b/nss/lib/freebl/Makefile |
21 | @@ -125,6 +125,9 @@ else | 19 | @@ -126,6 +126,8 @@ else |
22 | DEFINES += -DNSS_X86 | ||
23 | endif | 20 | endif |
24 | endif | 21 | endif |
25 | + | 22 | ifdef NS_USE_GCC |
26 | +ifdef NSS_USE_ARM_HW_CRYPTO | 23 | +ifdef NSS_USE_ARM_HW_CRYPTO |
27 | + DEFINES += -DNSS_USE_ARM_HW_CRYPTO | 24 | + DEFINES += -DNSS_USE_ARM_HW_CRYPTO |
28 | ifeq ($(CPU_ARCH),aarch64) | 25 | ifeq ($(CPU_ARCH),aarch64) |
29 | DEFINES += -DUSE_HW_AES -DUSE_HW_SHA2 | 26 | DEFINES += -DUSE_HW_AES -DUSE_HW_SHA1 -DUSE_HW_SHA2 |
30 | EXTRA_SRCS += aes-armv8.c gcm-aarch64.c sha256-armv8.c | 27 | EXTRA_SRCS += aes-armv8.c gcm-aarch64.c sha1-armv8.c sha256-armv8.c |
31 | @@ -148,6 +151,7 @@ endif | 28 | @@ -150,6 +152,7 @@ endif |
32 | endif | 29 | endif |
33 | endif | 30 | endif |
34 | endif | 31 | endif |
@@ -36,23 +33,15 @@ index f99f769..b0ec81b 100644 | |||
36 | 33 | ||
37 | ifeq ($(OS_TARGET),OSF1) | 34 | ifeq ($(OS_TARGET),OSF1) |
38 | DEFINES += -DMP_ASSEMBLY_MULTIPLY -DMP_NO_MP_WORD | 35 | DEFINES += -DMP_ASSEMBLY_MULTIPLY -DMP_NO_MP_WORD |
39 | diff --git a/nss/lib/freebl/gcm.c b/nss/lib/freebl/gcm.c | ||
40 | index c2cc18d..b77f573 100644 | ||
41 | --- a/nss/lib/freebl/gcm.c | 36 | --- a/nss/lib/freebl/gcm.c |
42 | +++ b/nss/lib/freebl/gcm.c | 37 | +++ b/nss/lib/freebl/gcm.c |
43 | @@ -18,6 +18,7 @@ | 38 | @@ -21,7 +21,9 @@ |
44 | |||
45 | #include <limits.h> | ||
46 | |||
47 | +#ifdef NSS_USE_ARM_HW_CRYPTO | ||
48 | /* old gcc doesn't support some poly64x2_t intrinsic */ | 39 | /* old gcc doesn't support some poly64x2_t intrinsic */ |
49 | #if defined(__aarch64__) && defined(IS_LITTLE_ENDIAN) && \ | 40 | #if defined(__aarch64__) && defined(IS_LITTLE_ENDIAN) && \ |
50 | (defined(__clang__) || defined(__GNUC__) && __GNUC__ > 6) | 41 | (defined(__clang__) || defined(__GNUC__) && __GNUC__ > 6) |
51 | @@ -27,6 +28,7 @@ | 42 | +# ifdef NSS_USE_ARM_HW_CRYPTO |
52 | /* We don't test on big endian platform, so disable this on big endian. */ | ||
53 | #define USE_ARM_GCM | 43 | #define USE_ARM_GCM |
54 | #endif | 44 | +# endif |
55 | +#endif | 45 | #elif defined(__arm__) && defined(IS_LITTLE_ENDIAN) && \ |
56 | 46 | !defined(NSS_DISABLE_ARM32_NEON) | |
57 | /* Forward declarations */ | 47 | /* We don't test on big endian platform, so disable this on big endian. */ |
58 | SECStatus gcm_HashInit_hw(gcmHashContext *ghash); | ||
diff --git a/meta-oe/recipes-support/nss/nss_3.54.bb b/meta-oe/recipes-support/nss/nss_3.56.bb index 1cc94735bb..4aa5d29ec2 100644 --- a/meta-oe/recipes-support/nss/nss_3.54.bb +++ b/meta-oe/recipes-support/nss/nss_3.56.bb | |||
@@ -34,8 +34,7 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/${VERSIO | |||
34 | file://0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch \ | 34 | file://0001-freebl-add-a-configure-option-to-disable-ARM-HW-cryp.patch \ |
35 | file://0001-pkix-Do-not-use-NULL-where-0-is-needed.patch \ | 35 | file://0001-pkix-Do-not-use-NULL-where-0-is-needed.patch \ |
36 | " | 36 | " |
37 | 37 | SRC_URI[sha256sum] = "f875e0e8ed3b5ce92d675be4a55aa25a8c1199789a4a01f69b5f2327e2048e9c" | |
38 | SRC_URI[sha256sum] = "dab18bbfcf5e347934cda664df75ce9fd912a5772686c40d3c805e53c08d6e43" | ||
39 | 38 | ||
40 | UPSTREAM_CHECK_URI = "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_Releases" | 39 | UPSTREAM_CHECK_URI = "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_Releases" |
41 | UPSTREAM_CHECK_REGEX = "NSS_(?P<pver>.+)_release_notes" | 40 | UPSTREAM_CHECK_REGEX = "NSS_(?P<pver>.+)_release_notes" |