diff options
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch | 22 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Fix-error.patch | 12 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Modify-cmakelist.patch | 41 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-fix-the-build-error-when-python-3.0.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-no-ruby-perl.patch | 14 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-sblim-sigsegv.patch | 18 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.9.5-python-lib-dir.patch | 17 | ||||
-rw-r--r-- | meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_1.0.4.bb (renamed from meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_1.0.1.bb) | 22 |
8 files changed, 30 insertions, 149 deletions
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch deleted file mode 100644 index fa029da2b8..0000000000 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch +++ /dev/null | |||
@@ -1,22 +0,0 @@ | |||
1 | From a701ed30ac1bc2f77d063c237d6ae040a2d53f6b Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex.kanavin@gmail.com> | ||
3 | Date: Mon, 16 May 2016 16:52:24 +0300 | ||
4 | Subject: [PATCH] Add 'm' suffix to the python library name. | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe-core specific] | ||
7 | Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> | ||
8 | --- | ||
9 | swig/python/CMakeLists.txt | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | --- a/swig/python/CMakeLists.txt | ||
13 | +++ b/swig/python/CMakeLists.txt | ||
14 | @@ -49,7 +49,7 @@ ADD_DEFINITIONS(-DCMPI_PLATFORM_LINUX_GE | ||
15 | SET( NAME pyCmpiProvider ) | ||
16 | ADD_LIBRARY( ${NAME} SHARED ${SWIG_OUTPUT}) | ||
17 | #TARGET_LINK_LIBRARIES( ${NAME} ${PYTHON_LIBRARIES} ) | ||
18 | -TARGET_LINK_LIBRARIES( ${NAME} python${PYTHON_MAJOR_VERSION}.${PYTHON_MINOR_VERSION} ) | ||
19 | +TARGET_LINK_LIBRARIES( ${NAME} python${PYTHON_MAJOR_VERSION}.${PYTHON_MINOR_VERSION}${PYTHON_ABI} ) | ||
20 | TARGET_LINK_LIBRARIES( ${NAME} pthread ) | ||
21 | TARGET_LINK_LIBRARIES( ${NAME} dl ) | ||
22 | TARGET_LINK_LIBRARIES( ${NAME} util ) | ||
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Fix-error.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Fix-error.patch index 1d8013be6f..1f147d52f6 100644 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Fix-error.patch +++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Fix-error.patch | |||
@@ -1,20 +1,19 @@ | |||
1 | From b8e791ce93a467081fb1594b91841e2f57c634a0 Mon Sep 17 00:00:00 2001 | 1 | From 3ab3ac2876cbf4a34a94f0d3256a5be9d1202370 Mon Sep 17 00:00:00 2001 |
2 | From: Qian Lei <qianl.fnst@cn.fujitsu.com> | 2 | From: Qian Lei <qianl.fnst@cn.fujitsu.com> |
3 | Date: Fri, 16 Jan 2015 18:37:26 +0800 | 3 | Date: Fri, 16 Jan 2015 18:37:26 +0800 |
4 | Subject: [PATCH] Fix error | 4 | Subject: [PATCH] Fix error |
5 | 5 | ||
6 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> | 6 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> |
7 | --- | ||
8 | Upstream-Status: Pending | 7 | Upstream-Status: Pending |
9 | 8 | --- | |
10 | swig/python/CMakeLists.txt | 2 +- | 9 | swig/python/CMakeLists.txt | 2 +- |
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | 10 | 1 file changed, 1 insertion(+), 1 deletion(-) |
12 | 11 | ||
13 | diff --git a/swig/python/CMakeLists.txt b/swig/python/CMakeLists.txt | 12 | diff --git a/swig/python/CMakeLists.txt b/swig/python/CMakeLists.txt |
14 | index 3976296..8073fc8 100644 | 13 | index 93b4755..a7268f0 100644 |
15 | --- a/swig/python/CMakeLists.txt | 14 | --- a/swig/python/CMakeLists.txt |
16 | +++ b/swig/python/CMakeLists.txt | 15 | +++ b/swig/python/CMakeLists.txt |
17 | @@ -27,7 +27,7 @@ SET( SWIG_INPUT "${CMAKE_CURRENT_SOURCE_DIR}/../cmpi.i" ) | 16 | @@ -26,7 +26,7 @@ SET( SWIG_INPUT "${CMAKE_CURRENT_SOURCE_DIR}/../cmpi.i" ) |
18 | ADD_CUSTOM_COMMAND ( | 17 | ADD_CUSTOM_COMMAND ( |
19 | OUTPUT ${SWIG_OUTPUT} | 18 | OUTPUT ${SWIG_OUTPUT} |
20 | COMMAND ${CMAKE_COMMAND} -E echo_append "Creating wrapper code for Python ..." | 19 | COMMAND ${CMAKE_COMMAND} -E echo_append "Creating wrapper code for Python ..." |
@@ -23,6 +22,3 @@ index 3976296..8073fc8 100644 | |||
23 | COMMAND ${CMAKE_COMMAND} -E echo "Done." | 22 | COMMAND ${CMAKE_COMMAND} -E echo "Done." |
24 | WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} | 23 | WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} |
25 | DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../*.i | 24 | DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/../*.i |
26 | -- | ||
27 | 1.8.3.1 | ||
28 | |||
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Modify-cmakelist.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Modify-cmakelist.patch deleted file mode 100644 index 92e5e5662e..0000000000 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-Modify-cmakelist.patch +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | From 070822507befe7c1b8bb1be2d36cb12141d03b8f Mon Sep 17 00:00:00 2001 | ||
2 | From: Qian Lei <qianl.fnst@cn.fujitsu.com> | ||
3 | Date: Tue, 6 Jan 2015 18:38:32 +0800 | ||
4 | Subject: [PATCH] Change the install path in cmakelist | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> | ||
8 | --- | ||
9 | swig/python/CMakeLists.txt | 8 ++++---- | ||
10 | 1 file changed, 4 insertions(+), 4 deletions(-) | ||
11 | |||
12 | diff --git a/swig/python/CMakeLists.txt b/swig/python/CMakeLists.txt | ||
13 | index 3976296..93c87c1 100644 | ||
14 | --- a/swig/python/CMakeLists.txt | ||
15 | +++ b/swig/python/CMakeLists.txt | ||
16 | @@ -56,18 +56,18 @@ TARGET_LINK_LIBRARIES( ${NAME} util ) | ||
17 | |||
18 | INSTALL(TARGETS ${NAME} LIBRARY DESTINATION ${CMPI_LIBRARY_DIR}) | ||
19 | # .py: swig generated | ||
20 | -INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/cmpi.py DESTINATION ${PYTHON_SITE_DIR} ) | ||
21 | +INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/cmpi.py DESTINATION $ENV{ENV_INSTALL_PATH} ) | ||
22 | |||
23 | |||
24 | # | ||
25 | # cmpi_pywbem_bindings.py: provider implementation | ||
26 | # | ||
27 | -INSTALL(FILES cmpi_pywbem_bindings.py DESTINATION ${PYTHON_SITE_DIR} ) | ||
28 | +INSTALL(FILES cmpi_pywbem_bindings.py DESTINATION $ENV{ENV_INSTALL_PATH} ) | ||
29 | #INSTALL(FILES Py_UnixProcessProvider.py DESTINATION /usr/lib/pycim ) | ||
30 | |||
31 | -INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c \"from py_compile import compile; compile('\$ENV{DESTDIR}${PYTHON_SITE_DIR}/cmpi.py', dfile='${PYTHON_SITE_DIR}/cmpi.py')\")") | ||
32 | +INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c \"from py_compile import compile; compile('\$ENV{DESTDIR}$ENV{ENV_INSTALL_PATH}/cmpi.py', dfile='\$ENV{ENV_INSTALL_PATH}/cmpi.py')\")") | ||
33 | |||
34 | -INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c \"from py_compile import compile; compile('\$ENV{DESTDIR}${PYTHON_SITE_DIR}/cmpi_pywbem_bindings.py', dfile='${PYTHON_SITE_DIR}/cmpi_pywbem_bindings.py')\")") | ||
35 | +INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c \"from py_compile import compile; compile('\$ENV{DESTDIR}$ENV{ENV_INSTALL_PATH}/cmpi_pywbem_bindings.py', dfile='$ENV{ENV_INSTALL_PATH}/cmpi_pywbem_bindings.py')\")") | ||
36 | |||
37 | |||
38 | |||
39 | -- | ||
40 | 1.8.3.1 | ||
41 | |||
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-fix-the-build-error-when-python-3.0.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-fix-the-build-error-when-python-3.0.patch deleted file mode 100644 index 5d5652a5f2..0000000000 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/0001-fix-the-build-error-when-python-3.0.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | From 323ced03a66e6cd963d8277b66cfcc7dce740be7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
3 | Date: Fri, 17 Jul 2015 01:33:43 -0700 | ||
4 | Subject: [PATCH] fix Xthe build error when python>3.0 | ||
5 | |||
6 | Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> | ||
7 | --- | ||
8 | Upstream-Status: Pending | ||
9 | |||
10 | src/target_python.c | 7 ++++++- | ||
11 | 1 file changed, 6 insertions(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/target_python.c b/src/target_python.c | ||
14 | index 90b43a1..2b76c9e 100644 | ||
15 | --- a/src/target_python.c | ||
16 | +++ b/src/target_python.c | ||
17 | @@ -167,7 +167,12 @@ PyGlobalInitialize(const CMPIBroker* broker, CMPIStatus* st) | ||
18 | |||
19 | Py_SetProgramName("cmpi_swig"); | ||
20 | Py_Initialize(); | ||
21 | - SWIGEXPORT void SWIG_init(void); | ||
22 | +#if PY_VERSION_HEX >= 0x03000000 | ||
23 | +SWIGEXPORT PyObject* | ||
24 | +#else | ||
25 | + SWIGEXPORT void | ||
26 | +#endif | ||
27 | + SWIG_init(void); | ||
28 | SWIG_init(); | ||
29 | cmpiMainPyThreadState = PyGILState_GetThisThreadState(); | ||
30 | PyEval_ReleaseThread(cmpiMainPyThreadState); | ||
31 | -- | ||
32 | 2.1.0 | ||
33 | |||
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-no-ruby-perl.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-no-ruby-perl.patch index 2072da72b5..1f9e2394c3 100644 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-no-ruby-perl.patch +++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-no-ruby-perl.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 7dd01e33f9dac75f177113de9a8ff458d4263a11 Mon Sep 17 00:00:00 2001 | 1 | From 0871fb048a48a02ec598c941e577f13d8d24f574 Mon Sep 17 00:00:00 2001 |
2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> | 2 | From: Lei Maohui <leimaohui@cn.fujitsu.com> |
3 | Date: Mon, 24 Aug 2015 11:00:13 +0900 | 3 | Date: Mon, 24 Aug 2015 11:00:13 +0900 |
4 | Subject: [PATCH] cmpi-bindings-0.4.17 no ruby perl | 4 | Subject: [PATCH] cmpi-bindings-0.4.17 no ruby perl |
@@ -7,17 +7,18 @@ Port from Fedora20 | |||
7 | 7 | ||
8 | Upstream-Status: Pending | 8 | Upstream-Status: Pending |
9 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> | 9 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> |
10 | |||
10 | --- | 11 | --- |
11 | swig/CMakeLists.txt | 22 +++++++++++----------- | 12 | swig/CMakeLists.txt | 22 +++++++++++----------- |
12 | 1 file changed, 11 insertions(+), 11 deletions(-) | 13 | 1 file changed, 11 insertions(+), 11 deletions(-) |
13 | 14 | ||
14 | diff --git a/swig/CMakeLists.txt b/swig/CMakeLists.txt | 15 | diff --git a/swig/CMakeLists.txt b/swig/CMakeLists.txt |
15 | index 8b5555c..c2655b9 100644 | 16 | index 00bf40c..d3cab38 100644 |
16 | --- a/swig/CMakeLists.txt | 17 | --- a/swig/CMakeLists.txt |
17 | +++ b/swig/CMakeLists.txt | 18 | +++ b/swig/CMakeLists.txt |
18 | @@ -15,15 +15,15 @@ IF (PYTHON_LIBRARY) | 19 | @@ -49,15 +49,15 @@ ELSE (BUILD_PYTHON2) |
19 | ENDIF (PYTHON_LINK_LIBS) | 20 | MESSAGE(STATUS "*****") |
20 | ENDIF (PYTHON_LIBRARY) | 21 | ENDIF (BUILD_PYTHON3) |
21 | 22 | ||
22 | -FIND_PACKAGE(Perl) | 23 | -FIND_PACKAGE(Perl) |
23 | -IF (PERL_EXECUTABLE) | 24 | -IF (PERL_EXECUTABLE) |
@@ -42,6 +43,3 @@ index 8b5555c..c2655b9 100644 | |||
42 | +# ADD_SUBDIRECTORY(ruby) | 43 | +# ADD_SUBDIRECTORY(ruby) |
43 | +# OPTION( BUILD_RUBY_GEM "Build Ruby GEM" YES ) | 44 | +# OPTION( BUILD_RUBY_GEM "Build Ruby GEM" YES ) |
44 | +#ENDIF (RUBY_LIBRARY AND RUBY_INCLUDE_PATH) | 45 | +#ENDIF (RUBY_LIBRARY AND RUBY_INCLUDE_PATH) |
45 | -- | ||
46 | 1.8.4.2 | ||
47 | |||
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-sblim-sigsegv.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-sblim-sigsegv.patch index b99337204d..04abd5e4b9 100644 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-sblim-sigsegv.patch +++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.4.17-sblim-sigsegv.patch | |||
@@ -1,12 +1,20 @@ | |||
1 | Port from Fedora20 | 1 | From bc32342fa63b8359f985fe1e187e811455c96a50 Mon Sep 17 00:00:00 2001 |
2 | From: Qian Lei <qianl.fnst@cn.fujitsu.com> | ||
3 | Date: Tue, 25 Aug 2015 13:19:51 +0800 | ||
4 | Subject: [PATCH] Port from Fedora20 | ||
2 | 5 | ||
3 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
4 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> | 7 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> |
5 | 8 | ||
6 | diff -up cmpi-bindings-0.4.17/swig/python/cmpi_pywbem_bindings.py.orig cmpi-bindings-0.4.17/swig/python/cmpi_pywbem_bindings.py | 9 | --- |
7 | --- cmpi-bindings-0.4.17/swig/python/cmpi_pywbem_bindings.py.orig 2012-03-01 17:05:31.878367281 +0100 | 10 | swig/python/cmpi_pywbem_bindings.py | 6 +++--- |
8 | +++ cmpi-bindings-0.4.17/swig/python/cmpi_pywbem_bindings.py 2012-03-01 17:06:34.718110137 +0100 | 11 | 1 file changed, 3 insertions(+), 3 deletions(-) |
9 | @@ -350,10 +350,10 @@ class BrokerCIMOMHandle(object): | 12 | |
13 | diff --git a/swig/python/cmpi_pywbem_bindings.py b/swig/python/cmpi_pywbem_bindings.py | ||
14 | index d643990..7f0cc77 100644 | ||
15 | --- a/swig/python/cmpi_pywbem_bindings.py | ||
16 | +++ b/swig/python/cmpi_pywbem_bindings.py | ||
17 | @@ -361,10 +361,10 @@ class BrokerCIMOMHandle(object): | ||
10 | allow_null_ns = False | 18 | allow_null_ns = False |
11 | else: | 19 | else: |
12 | allow_null_ns = True | 20 | allow_null_ns = True |
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.9.5-python-lib-dir.patch b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.9.5-python-lib-dir.patch deleted file mode 100644 index b6a51ec0d2..0000000000 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings/cmpi-bindings-0.9.5-python-lib-dir.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | Port from Fedora20 | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Qian Lei <qianl.fnst@cn.fujitsu.com> | ||
5 | |||
6 | diff -up cmpi-bindings-0.9.5/swig/python/CMakeLists.txt.old cmpi-bindings-0.9.5/swig/python/CMakeLists.txt | ||
7 | --- cmpi-bindings-0.9.5/swig/python/CMakeLists.txt.old 2013-08-06 15:57:03.576285764 +0200 | ||
8 | +++ cmpi-bindings-0.9.5/swig/python/CMakeLists.txt 2013-08-06 15:57:14.891345941 +0200 | ||
9 | @@ -9,7 +9,7 @@ SET (BUILD_SHARED_LIBS ON) | ||
10 | |||
11 | FIND_PACKAGE(PythonInterp REQUIRED) | ||
12 | |||
13 | -EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib())" OUTPUT_VARIABLE PYTHON_LIB_DIR) | ||
14 | +EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(1))" OUTPUT_VARIABLE PYTHON_LIB_DIR) | ||
15 | |||
16 | IF (NOT PYTHON_SITE_DIR) | ||
17 | SET (PYTHON_SITE_DIR ${PYTHON_LIB_DIR}) | ||
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_1.0.1.bb b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_1.0.4.bb index 3b7453536b..781dc83da9 100644 --- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_1.0.1.bb +++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_1.0.4.bb | |||
@@ -4,39 +4,31 @@ HOMEPAGE = "http://github.com/kkaempf/cmpi-bindings" | |||
4 | LICENSE = "BSD-3-Clause" | 4 | LICENSE = "BSD-3-Clause" |
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b19ee058d2d5f69af45da98051d91064" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b19ee058d2d5f69af45da98051d91064" |
6 | SECTION = "Development/Libraries" | 6 | SECTION = "Development/Libraries" |
7 | DEPENDS = "swig-native python3 sblim-cmpi-devel" | 7 | DEPENDS = "swig-native sblim-cmpi-devel python3-setuptools-native" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=https;branch=master \ | 9 | SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=https;branch=master \ |
10 | file://cmpi-bindings-0.4.17-no-ruby-perl.patch \ | 10 | file://cmpi-bindings-0.4.17-no-ruby-perl.patch \ |
11 | file://cmpi-bindings-0.4.17-sblim-sigsegv.patch \ | 11 | file://cmpi-bindings-0.4.17-sblim-sigsegv.patch \ |
12 | file://cmpi-bindings-0.9.5-python-lib-dir.patch \ | ||
13 | file://0001-Modify-cmakelist.patch \ | ||
14 | file://0001-Fix-error.patch \ | 12 | file://0001-Fix-error.patch \ |
15 | file://0001-fix-the-build-error-when-python-3.0.patch \ | 13 | " |
16 | file://0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch \ | ||
17 | " | ||
18 | 14 | ||
19 | SRCREV = "62f60e065aa1b901f826e4f530c0573ae32d065e" | 15 | SRCREV = "69077ee4d249816ed428155fc933dca424167e77" |
20 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
21 | 17 | ||
22 | inherit cmake python3native | 18 | inherit cmake python3targetconfig |
23 | 19 | ||
24 | EXTRA_OECMAKE = "-DLIB='${baselib}' \ | 20 | EXTRA_OECMAKE = "-DLIB='${baselib}' \ |
25 | -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ | 21 | -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ |
26 | -DPYTHON_ABI=${PYTHON_ABI} \ | 22 | -DPYTHON_ABI=${PYTHON_ABI} \ |
23 | -DBUILD_PYTHON3=YES \ | ||
24 | -DPython3_SITE_DIR=${PYTHON_SITEPACKAGES_DIR} \ | ||
27 | " | 25 | " |
28 | 26 | ||
29 | # With Ninja it fails with: | 27 | # With Ninja it fails with: |
30 | # ninja: error: build.ninja:282: bad $-escape (literal $ must be written as $$) | 28 | # ninja: error: build.ninja:282: bad $-escape (literal $ must be written as $$) |
31 | OECMAKE_GENERATOR = "Unix Makefiles" | 29 | OECMAKE_GENERATOR = "Unix Makefiles" |
32 | 30 | ||
33 | do_configure:prepend() { | 31 | FILES:${PN} =+"${libdir}/cmpi/libpy3CmpiProvider.so ${PYTHON_SITEPACKAGES_DIR}/*" |
34 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
35 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
36 | export ENV_INSTALL_PATH=${PYTHON_SITEPACKAGES_DIR} | ||
37 | } | ||
38 | |||
39 | FILES:${PN} =+"${libdir}/cmpi/libpyCmpiProvider.so ${PYTHON_SITEPACKAGES_DIR}/*" | ||
40 | FILES:${PN}-dbg =+ "${libdir}/cmpi/.debug/libpyCmpiProvider.so" | 32 | FILES:${PN}-dbg =+ "${libdir}/cmpi/.debug/libpyCmpiProvider.so" |
41 | 33 | ||
42 | BBCLASSEXTEND = "native" | 34 | BBCLASSEXTEND = "native" |