diff options
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort/disable-run-test-program-while-cross-compiling.patch | 4 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort/snort.init | 53 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/snort/snort_2.9.13.bb (renamed from meta-networking/recipes-connectivity/snort/snort_2.9.11.1.bb) | 5 |
3 files changed, 32 insertions, 30 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort/disable-run-test-program-while-cross-compiling.patch b/meta-networking/recipes-connectivity/snort/snort/disable-run-test-program-while-cross-compiling.patch index 037962fb6b..30ec174395 100644 --- a/meta-networking/recipes-connectivity/snort/snort/disable-run-test-program-while-cross-compiling.patch +++ b/meta-networking/recipes-connectivity/snort/snort/disable-run-test-program-while-cross-compiling.patch | |||
@@ -226,7 +226,7 @@ index 4b3a5db..a6c5498 100644 | |||
226 | -]])], | 226 | -]])], |
227 | -[have_daq_packet_trace="yes"], | 227 | -[have_daq_packet_trace="yes"], |
228 | -[have_daq_packet_trace="no"]) | 228 | -[have_daq_packet_trace="no"]) |
229 | +have_daq_packet_trace="yes" | 229 | +have_daq_packet_trace="no" |
230 | AC_MSG_RESULT($have_daq_packet_trace) | 230 | AC_MSG_RESULT($have_daq_packet_trace) |
231 | if test "x$have_daq_packet_trace" = "xyes"; then | 231 | if test "x$have_daq_packet_trace" = "xyes"; then |
232 | AC_DEFINE([HAVE_DAQ_PKT_TRACE],[1], | 232 | AC_DEFINE([HAVE_DAQ_PKT_TRACE],[1], |
@@ -245,7 +245,7 @@ index 4b3a5db..a6c5498 100644 | |||
245 | -]])], | 245 | -]])], |
246 | -[have_daq_verdict_reason="yes"], | 246 | -[have_daq_verdict_reason="yes"], |
247 | -[have_daq_verdict_reason="no"]) | 247 | -[have_daq_verdict_reason="no"]) |
248 | +have_daq_verdict_reason="yes" | 248 | +have_daq_verdict_reason="no" |
249 | AC_MSG_RESULT($have_daq_verdict_reason) | 249 | AC_MSG_RESULT($have_daq_verdict_reason) |
250 | if test "x$have_daq_verdict_reason" = "xyes"; then | 250 | if test "x$have_daq_verdict_reason" = "xyes"; then |
251 | AC_DEFINE([HAVE_DAQ_VERDICT_REASON],[1], | 251 | AC_DEFINE([HAVE_DAQ_VERDICT_REASON],[1], |
diff --git a/meta-networking/recipes-connectivity/snort/snort/snort.init b/meta-networking/recipes-connectivity/snort/snort/snort.init index d8a00c43fc..0d90c9af03 100644 --- a/meta-networking/recipes-connectivity/snort/snort/snort.init +++ b/meta-networking/recipes-connectivity/snort/snort/snort.init | |||
@@ -1,6 +1,6 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | # | 2 | # |
3 | # Snort Startup Script modified for OpenEmbedded | 3 | # Snort Startup Script modified for OpenEmbedded |
4 | # | 4 | # |
5 | 5 | ||
6 | # Script variables | 6 | # Script variables |
@@ -30,16 +30,16 @@ fi | |||
30 | 30 | ||
31 | start() | 31 | start() |
32 | { | 32 | { |
33 | |||
34 | [ -n "$LAN_INTERFACE" ] || return 0 | 33 | [ -n "$LAN_INTERFACE" ] || return 0 |
35 | # Check if log diratory is present. Otherwise, create it. | 34 | # Check if log diratory is present. Otherwise, create it. |
36 | if [ ! -d $LOGDIR/$DATE ]; then | 35 | if [ ! -d $LOGDIR/$DATE ]; then |
37 | mkdir -d $LOGDIR/$DATE | 36 | mkdir -p $LOGDIR/$DATE |
38 | /bin/chown -R $USER:$USER $LOGDIR/$DATE | 37 | /bin/chown -R $USER:$USER $LOGDIR/$DATE |
39 | /bin/chmod -R 700 $LOGDIR/$DATE | 38 | /bin/chmod -R 700 $LOGDIR/$DATE |
40 | fi | 39 | fi |
41 | 40 | ||
42 | /bin/echo "Starting $PROG: " | 41 | /bin/echo "Starting $PROG: " |
42 | |||
43 | # Snort parameters | 43 | # Snort parameters |
44 | # -D Run Snort in background (daemon) mode | 44 | # -D Run Snort in background (daemon) mode |
45 | # -i <if> Listen on interface <if> | 45 | # -i <if> Listen on interface <if> |
@@ -64,7 +64,7 @@ stop() | |||
64 | RETURN_VAL=$? | 64 | RETURN_VAL=$? |
65 | /bin/echo "$PROG shutdown complete." | 65 | /bin/echo "$PROG shutdown complete." |
66 | [ -e $DEL_PID ] && rm -f $DEL_PID | 66 | [ -e $DEL_PID ] && rm -f $DEL_PID |
67 | [ -e $DEL_PID.lck ] && rm -f $DEL_PID.lck | 67 | [ -e $DEL_PID.lck ] && rm -f $DEL_PID.lck |
68 | else | 68 | else |
69 | /bin/echo "ERROR: PID in $PID file not found." | 69 | /bin/echo "ERROR: PID in $PID file not found." |
70 | RETURN_VAL=1 | 70 | RETURN_VAL=1 |
@@ -72,12 +72,13 @@ stop() | |||
72 | return $RETURN_VAL | 72 | return $RETURN_VAL |
73 | } | 73 | } |
74 | 74 | ||
75 | status() { | 75 | status() |
76 | if [ -s $PID ]; then | 76 | { |
77 | echo "$PROG is running as pid `cat $PID`:" | 77 | if [ -s $PID ]; then |
78 | else | 78 | echo "$PROG is running as pid `cat $PID`:" |
79 | echo "$PROG is not running." | 79 | else |
80 | fi | 80 | echo "$PROG is not running." |
81 | fi | ||
81 | } | 82 | } |
82 | 83 | ||
83 | restart() | 84 | restart() |
@@ -89,21 +90,21 @@ restart() | |||
89 | } | 90 | } |
90 | 91 | ||
91 | case "$1" in | 92 | case "$1" in |
92 | start) | 93 | start) |
93 | start | 94 | start |
94 | ;; | 95 | ;; |
95 | stop) | 96 | stop) |
96 | stop | 97 | stop |
97 | ;; | 98 | ;; |
98 | status) | 99 | status) |
99 | status | 100 | status |
100 | ;; | 101 | ;; |
101 | restart|reload) | 102 | restart|reload) |
102 | restart | 103 | restart |
103 | ;; | 104 | ;; |
104 | *) | 105 | *) |
105 | /bin/echo "Usage: $0 {start|stop|status|restart|reload}" | 106 | /bin/echo "Usage: $0 {start|stop|status|restart|reload}" |
106 | RETURN_VAL=1 | 107 | RETURN_VAL=1 |
107 | esac | 108 | esac |
108 | 109 | ||
109 | exit $RETURN_VAL | 110 | exit $RETURN_VAL |
diff --git a/meta-networking/recipes-connectivity/snort/snort_2.9.11.1.bb b/meta-networking/recipes-connectivity/snort/snort_2.9.13.bb index c2eb95fe73..1b10dbde1d 100644 --- a/meta-networking/recipes-connectivity/snort/snort_2.9.11.1.bb +++ b/meta-networking/recipes-connectivity/snort/snort_2.9.13.bb | |||
@@ -13,8 +13,8 @@ SRC_URI = "https://www.snort.org/downloads/archive/snort/${BP}.tar.gz \ | |||
13 | file://disable-run-test-program-while-cross-compiling.patch \ | 13 | file://disable-run-test-program-while-cross-compiling.patch \ |
14 | " | 14 | " |
15 | 15 | ||
16 | SRC_URI[md5sum] = "378e3938b2b5c8e358f942d0ffce18cc" | 16 | SRC_URI[md5sum] = "b61ae846af022018b05511076baad60c" |
17 | SRC_URI[sha256sum] = "9f6b3aeac5a109f55504bd370564ac431cb1773507929dc461626898f33f46cd" | 17 | SRC_URI[sha256sum] = "31447393d15286b848810dd78ab2cb3ad231fcd1f1663f959587690eeea75413" |
18 | 18 | ||
19 | UPSTREAM_CHECK_URI = "https://www.snort.org/downloads" | 19 | UPSTREAM_CHECK_URI = "https://www.snort.org/downloads" |
20 | UPSTREAM_CHECK_REGEX = "snort-(?P<pver>\d+(\.\d+)+)\.tar" | 20 | UPSTREAM_CHECK_REGEX = "snort-(?P<pver>\d+(\.\d+)+)\.tar" |
@@ -45,6 +45,7 @@ EXTRA_OECONF = " \ | |||
45 | PACKAGECONFIG ?= "openssl lzma" | 45 | PACKAGECONFIG ?= "openssl lzma" |
46 | PACKAGECONFIG[openssl] = "--with-openssl-includes=${STAGING_INCDIR} --with-openssl-libraries=${STAGING_LIBDIR}, --without-openssl-includes --without-openssl-libraries, openssl," | 46 | PACKAGECONFIG[openssl] = "--with-openssl-includes=${STAGING_INCDIR} --with-openssl-libraries=${STAGING_LIBDIR}, --without-openssl-includes --without-openssl-libraries, openssl," |
47 | PACKAGECONFIG[lzma] = "--with-lzma-includes=${STAGING_INCDIR} --with-lzma-libraries=${STAGING_LIBDIR}, --without-lzma-includes --without-lzma-libraries, xz," | 47 | PACKAGECONFIG[lzma] = "--with-lzma-includes=${STAGING_INCDIR} --with-lzma-libraries=${STAGING_LIBDIR}, --without-lzma-includes --without-lzma-libraries, xz," |
48 | PACKAGECONFIG[appid] = "--enable-open-appid, --disable-open-appid, luajit, bash" | ||
48 | 49 | ||
49 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" | 50 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
50 | LDFLAGS += " -ltirpc" | 51 | LDFLAGS += " -ltirpc" |