summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-tzdata/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-tzdata_2024.1.bb14
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 56a5cf2f09..aa918aa89c 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -74,6 +74,7 @@ PTESTS_FAST_META_PYTHON = "\
74 python3-tomlkit \ 74 python3-tomlkit \
75 python3-trustme \ 75 python3-trustme \
76 python3-typeguard \ 76 python3-typeguard \
77 python3-tzdata \
77 python3-ujson \ 78 python3-ujson \
78 python3-u-msgpack-python \ 79 python3-u-msgpack-python \
79 python3-unidiff \ 80 python3-unidiff \
diff --git a/meta-python/recipes-devtools/python/python3-tzdata/run-ptest b/meta-python/recipes-devtools/python/python3-tzdata/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tzdata/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-tzdata_2024.1.bb b/meta-python/recipes-devtools/python/python3-tzdata_2024.1.bb
index d73b27a4f6..f4454f6dff 100644
--- a/meta-python/recipes-devtools/python/python3-tzdata_2024.1.bb
+++ b/meta-python/recipes-devtools/python/python3-tzdata_2024.1.bb
@@ -8,3 +8,17 @@ SRC_URI[sha256sum] = "2674120f8d891909751c38abcdfd386ac0a5a1127954fbc332af6b5cea
8 8
9inherit pypi python_setuptools_build_meta 9inherit pypi python_setuptools_build_meta
10 10
11inherit ptest
12
13SRC_URI += "file://run-ptest"
14
15RDEPENDS:${PN}-ptest += "\
16 python3-pytest \
17 python3-pytest-subtests \
18 python3-unittest-automake-output \
19"
20
21do_install_ptest() {
22 cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
23 install ${S}/VERSION ${D}${PTEST_PATH}/
24}