diff options
-rw-r--r-- | meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch | 25 | ||||
-rw-r--r-- | meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb | 1 |
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch b/meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch new file mode 100644 index 0000000000..3ae9b1bd9a --- /dev/null +++ b/meta-networking/recipes-support/pgpool2/pgpool2/define_SIGNAL_ARGS.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | Define SIGNAL_ARGS if its not defined, this is flagged with | ||
2 | newer C compilers e.g. clang18, where if it is not defined | ||
3 | then it ends up with compiler errors | ||
4 | |||
5 | /usr/include/postgresql/server/port.h:488:28: error: a parameter l | ||
6 | ist without types is only allowed in a function definition | ||
7 | | 488 | typedef void (*pqsigfunc) (SIGNAL_ARGS); | ||
8 | | | ^ | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | |||
13 | --- a/src/include/pool_type.h | ||
14 | +++ b/src/include/pool_type.h | ||
15 | @@ -125,7 +125,9 @@ extern void ExceptionalCondition(const c | ||
16 | #define LONGALIGN(LEN) TYPEALIGN(ALIGNOF_LONG, (LEN)) | ||
17 | #define DOUBLEALIGN(LEN) TYPEALIGN(ALIGNOF_DOUBLE, (LEN)) | ||
18 | #define MAXALIGN(LEN) TYPEALIGN(MAXIMUM_ALIGNOF, (LEN)) | ||
19 | - | ||
20 | +#ifndef SIGNAL_ARGS | ||
21 | +#define SIGNAL_ARGS int postgres_signal_arg | ||
22 | +#endif | ||
23 | /* | ||
24 | * It seems that sockaddr_storage is now commonly used in place of sockaddr. | ||
25 | * So, define it if it is not define yet, and create new SockAddr structure | ||
diff --git a/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb b/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb index b127d69625..ffb879952c 100644 --- a/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb +++ b/meta-networking/recipes-support/pgpool2/pgpool2_4.5.1.bb | |||
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=e4b38de086d73e0521de0bbdbaa4a1a9" | |||
12 | 12 | ||
13 | SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz \ | 13 | SRC_URI = "http://www.pgpool.net/mediawiki/images/pgpool-II-${PV}.tar.gz \ |
14 | file://0001-Fix-build-error-when-build-this-file.patch \ | 14 | file://0001-Fix-build-error-when-build-this-file.patch \ |
15 | file://define_SIGNAL_ARGS.patch \ | ||
15 | file://pgpool.sysconfig \ | 16 | file://pgpool.sysconfig \ |
16 | file://pgpool.service \ | 17 | file://pgpool.service \ |
17 | " | 18 | " |