summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch41
-rw-r--r--meta-oe/recipes-core/mm-common/mm-common_1.0.0.bb5
2 files changed, 44 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch b/meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch
new file mode 100644
index 0000000000..6031eaa782
--- /dev/null
+++ b/meta-oe/recipes-core/mm-common/mm-common/0001-meson.build-do-not-ask-for-python-installation-versi.patch
@@ -0,0 +1,41 @@
1From af4069263487399be82ee53d48b1edda7f8e594e Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Mon, 4 Nov 2019 19:19:47 +0100
4Subject: [PATCH] meson.build: do not ask for python installation / version
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Even by adding python3-setuptools-native the following error is not fixed so
10just ask for python3 executable.
11
12| meson.build:9:0: ERROR: <ExternalProgram 'python3' -> ['<...>/recipe-sysroot-native/usr/bin/python3-native/python3']> is not a valid python or it is missing setuptools
13
14Upstream-Status: Inappropriate [OE specific]
15
16Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
17---
18 meson.build | 7 +------
19 1 file changed, 1 insertion(+), 6 deletions(-)
20
21diff --git a/meson.build b/meson.build
22index 3255328..7a6094c 100644
23--- a/meson.build
24+++ b/meson.build
25@@ -6,12 +6,7 @@ project('mm-common',
26 license: 'GPLv2+'
27 )
28
29-python3 = import('python').find_installation('python3')
30-python_version = python3.language_version()
31-python_version_req = '>= 3.5'
32-if not python_version.version_compare(python_version_req)
33- error('Requires Python @0@, found @1@.'.format(python_version_req, python_version))
34-endif
35+python3 = import('python3').find_python()
36
37 # Use these instead of meson.source_root() and meson.build_root().
38 # source_root() and build_root() are not useful, if this is a subproject.
39--
402.21.0
41
diff --git a/meta-oe/recipes-core/mm-common/mm-common_1.0.0.bb b/meta-oe/recipes-core/mm-common/mm-common_1.0.0.bb
index 0b9e58917d..c7d1f2b73c 100644
--- a/meta-oe/recipes-core/mm-common/mm-common_1.0.0.bb
+++ b/meta-oe/recipes-core/mm-common/mm-common_1.0.0.bb
@@ -2,11 +2,12 @@ SUMMARY = "Common GNOME build files for C++ bindings"
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4 4
5GNOMEBASEBUILDCLASS = "meson"
6
5inherit gnomebase 7inherit gnomebase
6 8
7SRC_URI[archive.md5sum] = "9087b8612d75cbc1fad0c99e15c2a718" 9SRC_URI[archive.md5sum] = "9087b8612d75cbc1fad0c99e15c2a718"
8SRC_URI[archive.sha256sum] = "b97d9b041e5952486cab620b44ab09f6013a478f43b6699ae899b8a4da189cd4" 10SRC_URI[archive.sha256sum] = "b97d9b041e5952486cab620b44ab09f6013a478f43b6699ae899b8a4da189cd4"
9 11SRC_URI += "file://0001-meson.build-do-not-ask-for-python-installation-versi.patch"
10GNOMEBASEBUILDCLASS = "meson"
11 12
12BBCLASSEXTEND = "native" 13BBCLASSEXTEND = "native"