summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch37
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb3
2 files changed, 39 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch b/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch
new file mode 100644
index 0000000000..bfe2412b5d
--- /dev/null
+++ b/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch
@@ -0,0 +1,37 @@
1From e74bb5a7ef87e697571181280e6108b89104c02d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 25 Jan 2023 20:40:56 -0800
4Subject: [PATCH] include <cstdint>
5
6gcc 13 libstdc++ moved some includes around and as a result <cstdint>
7is no longer transitively included [1]. Explicitly include it for uintXX_t.
8
9Fixes
10
11../git/src/sw/redis++/utils.h:187:1: error: 'uint16_t' does not name a type
12 187 | uint16_t crc16(const char *buf, int len);
13 | ^~~~~~~~
14
15[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
16
17Upstream-Status: Submitted [https://github.com/sewenew/redis-plus-plus/pull/449]
18Signed-off-by: Khem Raj <raj.khem@gmail.com>
19---
20 src/sw/redis++/utils.h | 1 +
21 1 file changed, 1 insertion(+)
22
23diff --git a/src/sw/redis++/utils.h b/src/sw/redis++/utils.h
24index f77f796..ff38f2d 100644
25--- a/src/sw/redis++/utils.h
26+++ b/src/sw/redis++/utils.h
27@@ -17,6 +17,7 @@
28 #ifndef SEWENEW_REDISPLUSPLUS_UTILS_H
29 #define SEWENEW_REDISPLUSPLUS_UTILS_H
30
31+#include <cstdint>
32 #include <cstring>
33 #include <string>
34 #include <type_traits>
35--
362.39.1
37
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
index 21783b30d5..b127025a73 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
@@ -4,7 +4,8 @@ SECTION = "libs"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
6 6
7SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https" 7SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
8 file://0001-include-cstdint.patch"
8SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262" 9SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262"
9 10
10S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"