diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-multidict/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb | 13 |
2 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict/run-ptest b/meta-python/recipes-devtools/python/python3-multidict/run-ptest deleted file mode 100644 index d74acaf564..0000000000 --- a/meta-python/recipes-devtools/python/python3-multidict/run-ptest +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb b/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb index 1132e9ba5d..ed49b8ff02 100644 --- a/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb +++ b/meta-python/recipes-devtools/python/python3-multidict_6.1.0.bb | |||
@@ -4,7 +4,7 @@ HOMEPAGE = "https://github.com/aio-libs/multidict/" | |||
4 | LICENSE = "Apache-2.0" | 4 | LICENSE = "Apache-2.0" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b4fef6e4b0828c2401fb983363985b39" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b4fef6e4b0828c2401fb983363985b39" |
6 | 6 | ||
7 | inherit pypi python_setuptools_build_meta ptest | 7 | inherit pypi python_setuptools_build_meta ptest-python-pytest |
8 | 8 | ||
9 | PV .= "+git" | 9 | PV .= "+git" |
10 | 10 | ||
@@ -12,19 +12,8 @@ SRCREV = "4140e63780dc6dd600a1837cb9b4c5198c3dcd68" | |||
12 | PYPI_SRC_URI = "git://github.com/aio-libs/multidict;branch=master;protocol=https" | 12 | PYPI_SRC_URI = "git://github.com/aio-libs/multidict;branch=master;protocol=https" |
13 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
14 | 14 | ||
15 | SRC_URI += " \ | ||
16 | file://run-ptest \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS:${PN}-ptest += " \ | 15 | RDEPENDS:${PN}-ptest += " \ |
20 | python3-pytest \ | ||
21 | python3-pytest-cov \ | 16 | python3-pytest-cov \ |
22 | python3-unittest-automake-output \ | ||
23 | " | 17 | " |
24 | 18 | ||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/tests | ||
27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
28 | } | ||
29 | |||
30 | BBCLASSEXTEND = "native nativesdk" | 19 | BBCLASSEXTEND = "native nativesdk" |