summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch28
-rw-r--r--meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch9
-rw-r--r--meta-gnome/recipes-gnome/sysprof/sysprof/0003-libsysprof-Check-for-unw_set_caching_policy-before-u.patch (renamed from meta-gnome/recipes-gnome/sysprof/sysprof/0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch)25
-rw-r--r--meta-gnome/recipes-gnome/sysprof/sysprof_47.1.bb (renamed from meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb)39
4 files changed, 51 insertions, 50 deletions
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch
index ea9bdb2eb5..0dc7cb35a6 100644
--- a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch
+++ b/meta-gnome/recipes-gnome/sysprof/sysprof/0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch
@@ -1,30 +1,32 @@
1From 19188367bee87b0084ab34869455155da5cb1731 Mon Sep 17 00:00:00 2001 1From 779bbfebcd414a2cb4ab73ff1c4eb987cfdab456 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Pablo Saavedra <psaavedra@igalia.com>
3Date: Wed, 13 Apr 2022 08:47:39 -0700 3Date: Mon, 11 Nov 2024 13:05:15 +0100
4Subject: [PATCH] meson: Check for libunwind instead of libunwind-generic 4Subject: [PATCH] meson: Check for libunwind instead of libunwind-generic
5 5
6This helps it to use llvm unwinder since libunwind-generic is specific 6This helps it to use llvm unwinder since libunwind-generic is specific
7to nongnu libunwind. 7to nongnu libunwind.
8 8
9Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/sysprof/-/merge_requests/95] 9Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/sysprof/-/merge_requests/95]
10
11Original-by: Khem Raj <raj.khem@gmail.com>
12Modified-by: Pablo Saavedra <psaavedra@igalia.com>
13
10Signed-off-by: Khem Raj <raj.khem@gmail.com> 14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15Signed-off-by: Pablo Saavedra <psaavedra@igalia.com>
11--- 16---
12 meson.build | 2 +- 17 meson.build | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-) 18 1 file changed, 1 insertion(+), 1 deletion(-)
14 19
15diff --git a/meson.build b/meson.build 20diff --git a/meson.build b/meson.build
16index 3d3d8b5..4a1963d 100644 21index 96c1d09..86b9df4 100644
17--- a/meson.build 22--- a/meson.build
18+++ b/meson.build 23+++ b/meson.build
19@@ -96,7 +96,7 @@ config_h.set10('HAVE_POLKIT', polkit_dep.found()) 24@@ -107,7 +107,7 @@ polkit_dep = dependency('polkit-gobject-1', version: polkit_req_version, require
20 if get_option('libunwind') 25 config_h.set10('HAVE_POLKIT', polkit_dep.found())
21 # Force libunwind usage if it's specified to avoid back compiles 26
22 # and backtrace() showing up in builds 27 if need_libsysprof
23- libunwind_dep = dependency('libunwind-generic', required: true) 28- libunwind_dep = dependency('libunwind-generic', required: true)
24+ libunwind_dep = dependency('libunwind', required: true) 29+ libunwind_dep = dependency('libunwind', required: true)
25 config_h.set('ENABLE_LIBUNWIND', libunwind_dep.found()) 30 config_h.set('ENABLE_LIBUNWIND', libunwind_dep.found())
26 config_h.set('HAVE_UNW_SET_CACHE_SIZE', libunwind_dep.found() and cc.has_header_symbol('libunwind.h', 'unw_set_cache_size', dependencies: [libunwind_dep])) 31 config_h.set('HAVE_UNW_SET_CACHE_SIZE',
27 endif 32 cc.has_header_symbol('libunwind.h',
28--
292.35.2
30
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch b/meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch
index 998c20c657..77374ffc56 100644
--- a/meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch
+++ b/meta-gnome/recipes-gnome/sysprof/sysprof/0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch
@@ -1,4 +1,4 @@
1From 9ad120283f4b61b97da67f18a95bb3b4f1e8a3b9 Mon Sep 17 00:00:00 2001 1From cc0c0b518d46bf82ad34eeea8d40496c9ad971dd Mon Sep 17 00:00:00 2001
2From: Carlos Alberto Lopez Perez <clopez@igalia.com> 2From: Carlos Alberto Lopez Perez <clopez@igalia.com>
3Date: Wed, 24 Jul 2024 15:51:05 +0100 3Date: Wed, 24 Jul 2024 15:51:05 +0100
4Subject: [PATCH] meson: Do not invoke the commands to update the icon caches 4Subject: [PATCH] meson: Do not invoke the commands to update the icon caches
@@ -15,10 +15,10 @@ Signed-off-by: Carlos Alberto Lopez Perez <clopez@igalia.com>
15 1 file changed, 1 insertion(+), 1 deletion(-) 15 1 file changed, 1 insertion(+), 1 deletion(-)
16 16
17diff --git a/meson.build b/meson.build 17diff --git a/meson.build b/meson.build
18index 3d3d8b5..da622f1 100644 18index 86b9df4..fe75ef9 100644
19--- a/meson.build 19--- a/meson.build
20+++ b/meson.build 20+++ b/meson.build
21@@ -250,7 +250,7 @@ configure_file( 21@@ -269,7 +269,7 @@ configure_file(
22 configuration: config_h 22 configuration: config_h
23 ) 23 )
24 24
@@ -27,6 +27,3 @@ index 3d3d8b5..da622f1 100644
27 gnome.post_install( 27 gnome.post_install(
28 gtk_update_icon_cache: true, 28 gtk_update_icon_cache: true,
29 update_desktop_database: true 29 update_desktop_database: true
30--
312.39.2
32
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch b/meta-gnome/recipes-gnome/sysprof/sysprof/0003-libsysprof-Check-for-unw_set_caching_policy-before-u.patch
index 2dca95dac5..303e78a866 100644
--- a/meta-gnome/recipes-gnome/sysprof/sysprof/0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch
+++ b/meta-gnome/recipes-gnome/sysprof/sysprof/0003-libsysprof-Check-for-unw_set_caching_policy-before-u.patch
@@ -1,4 +1,4 @@
1From a3316e607db2a64e030df8551455c5700b5ddfcf Mon Sep 17 00:00:00 2001 1From 68425b541e88f9f03a418cfda052b46b2a185e4e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 25 Jul 2024 20:18:17 -0700 3Date: Thu, 25 Jul 2024 20:18:17 -0700
4Subject: [PATCH] libsysprof: Check for unw_set_caching_policy before using 4Subject: [PATCH] libsysprof: Check for unw_set_caching_policy before using
@@ -6,22 +6,27 @@ Subject: [PATCH] libsysprof: Check for unw_set_caching_policy before using
6llvm libunwind does not implement unw_cache_* functions yet 6llvm libunwind does not implement unw_cache_* functions yet
7 7
8Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/sysprof/-/merge_requests/95] 8Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/sysprof/-/merge_requests/95]
9
10Original-by: Khem Raj <raj.khem@gmail.com>
11Modified-by: Pablo Saavedra <psaavedra@igalia.com>
12
9Signed-off-by: Khem Raj <raj.khem@gmail.com> 13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14Signed-off-by: Pablo Saavedra <psaavedra@igalia.com>
10--- 15---
11 src/libsysprof/preload/backtrace-helper.h | 2 ++ 16 src/preload/backtrace-helper.h | 2 ++
12 1 file changed, 2 insertions(+) 17 1 file changed, 2 insertions(+)
13 18
14diff --git a/src/libsysprof/preload/backtrace-helper.h b/src/libsysprof/preload/backtrace-helper.h 19diff --git a/src/preload/backtrace-helper.h b/src/preload/backtrace-helper.h
15index 88dc194..5c23ad3 100644 20index ac4f8e9..e60032d 100644
16--- a/src/libsysprof/preload/backtrace-helper.h 21--- a/src/preload/backtrace-helper.h
17+++ b/src/libsysprof/preload/backtrace-helper.h 22+++ b/src/preload/backtrace-helper.h
18@@ -32,7 +32,9 @@ static void 23@@ -26,7 +26,9 @@
24 static void
19 backtrace_init (void) 25 backtrace_init (void)
20 { 26 {
21 #ifdef ENABLE_LIBUNWIND
22+# ifdef UNW_CACHE_PER_THREAD 27+# ifdef UNW_CACHE_PER_THREAD
23 unw_set_caching_policy (unw_local_addr_space, UNW_CACHE_PER_THREAD); 28 unw_set_caching_policy (unw_local_addr_space, UNW_CACHE_PER_THREAD);
24+# endif 29+#endif
25 # ifdef HAVE_UNW_SET_CACHE_SIZE 30 #ifdef HAVE_UNW_SET_CACHE_SIZE
26 unw_set_cache_size (unw_local_addr_space, 1024, 0); 31 unw_set_cache_size (unw_local_addr_space, 1024, 0);
27 #endif 32 #endif
diff --git a/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb b/meta-gnome/recipes-gnome/sysprof/sysprof_47.1.bb
index a02bd0c91a..e1b7be5180 100644
--- a/meta-gnome/recipes-gnome/sysprof/sysprof_3.48.0.bb
+++ b/meta-gnome/recipes-gnome/sysprof/sysprof_47.1.bb
@@ -4,50 +4,47 @@ LICENSE = "GPL-3.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ 4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://src/sysprof/sysprof-application.c;endline=17;md5=a3de8df3b0f8876dd01e1388d2d4b607" 5 file://src/sysprof/sysprof-application.c;endline=17;md5=a3de8df3b0f8876dd01e1388d2d4b607"
6 6
7inherit gnomebase gnome-help gettext systemd upstream-version-is-even gsettings mime mime-xdg features_check 7inherit gnomebase gnome-help gettext systemd gsettings gtk-icon-cache mime mime-xdg features_check
8 8
9DEPENDS += " \ 9DEPENDS += " \
10 glib-2.0-native \ 10 desktop-file-utils-native \
11 yelp-tools-native \
12 libxml2-native \
13 glib-2.0 \ 11 glib-2.0 \
12 glib-2.0-native \
14 json-glib \ 13 json-glib \
14 libdex \
15 libunwind \
16 libxml2-native \
17 yelp-tools-native \
15" 18"
16 19
17SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch \ 20SRC_URI += "file://0001-meson-Check-for-libunwind-instead-of-libunwind-gener.patch \
18 file://0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch \ 21 file://0002-meson-Do-not-invoke-the-commands-to-update-the-icon-.patch \
19 file://0001-libsysprof-Check-for-unw_set_caching_policy-before-u.patch \ 22 file://0003-libsysprof-Check-for-unw_set_caching_policy-before-u.patch \
20 " 23 "
21SRC_URI[archive.sha256sum] = "07d9081a66cf2fb52753f48ff2b85ada75c60ff1bc1af1bd14d8aeb627972168" 24SRC_URI[archive.sha256sum] = "d3baba814be0cdaef28704c8004ff3110e99525422060f2a993a22a47b9334eb"
22 25
23# reason: gtk4 requires opengl distro feature 26# reason: gtk4 requires opengl distro feature
24REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'gtk', 'opengl', '', d)}" 27REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'gtk', 'opengl', '', d)}"
25 28
26PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd', '', d)} \ 29PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'sysprofd libsysprof', '', d)} \
27 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \ 30 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)} \
28 agent \ 31 "
29 libsysprof \ 32
30 libunwind \ 33PACKAGECONFIG[gtk] = "-Dgtk=true,-Dgtk=false,gtk4 libpanel"
31 "
32# nongnu libunwind needs porting to RV32
33PACKAGECONFIG:remove:riscv32 = "libunwind"
34
35PACKAGECONFIG[gtk] = "-Dgtk=true,-Dgtk=false,gtk4 libadwaita"
36PACKAGECONFIG[sysprofd] = "-Dsysprofd=bundled,-Dsysprofd=none,polkit" 34PACKAGECONFIG[sysprofd] = "-Dsysprofd=bundled,-Dsysprofd=none,polkit"
37PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,json-glib" 35PACKAGECONFIG[libsysprof] = "-Dlibsysprof=true,-Dlibsysprof=false,polkit"
38PACKAGECONFIG[libunwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
39PACKAGECONFIG[agent] = "-Dagent=true,-Dagent=false,"
40 36
41EXTRA_OEMESON += "-Dsystemdunitdir=${systemd_unitdir}/system" 37EXTRA_OEMESON += "-Dsystemdunitdir=${systemd_unitdir}/system"
42 38
43SOLIBS = ".so" 39SOLIBS = ".so"
44FILES_SOLIBSDEV = "" 40FILES_SOLIBSDEV = "${libdir}/libsysprof-6.so"
45 41
46SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'sysprofd', 'sysprof2.service sysprof3.service', '', d)}" 42SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'sysprofd', 'sysprof3.service', '', d)}"
47 43
48FILES:${PN} += " \ 44FILES:${PN} += " \
49 ${datadir}/dbus-1/system-services \ 45 ${datadir}/dbus-1/system-services \
50 ${datadir}/dbus-1/system.d \ 46 ${datadir}/dbus-1/system.d \
51 ${datadir}/dbus-1/interfaces \ 47 ${datadir}/dbus-1/interfaces \
52 ${datadir}/metainfo \ 48 ${datadir}/metainfo \
49 ${libdir}/libsysprof-6*.so.* \
53" 50"