diff options
-rw-r--r-- | meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-support/bcu/bcu_1.1.115.bb (renamed from meta-oe/recipes-support/bcu/bcu_1.1.100.bb) | 2 |
2 files changed, 19 insertions, 12 deletions
diff --git a/meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch b/meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch index f4c0be19b6..bab1d1f301 100644 --- a/meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch +++ b/meta-oe/recipes-support/bcu/bcu/0001-CMakeLists-do-not-use-vendored-libcurl.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From ef1aaeee984ab13dab5d46c73e9b207cbdf62c55 Mon Sep 17 00:00:00 2001 | 1 | From 678c32f867931fd9f410b6e46ea8d101714c7ed5 Mon Sep 17 00:00:00 2001 |
2 | From: =?UTF-8?q?Leonard=20G=C3=B6hrs?= <l.goehrs@pengutronix.de> | 2 | From: =?UTF-8?q?Leonard=20G=C3=B6hrs?= <l.goehrs@pengutronix.de> |
3 | Date: Wed, 20 Dec 2023 14:37:20 +0100 | 3 | Date: Tue, 6 May 2025 07:45:36 +0200 |
4 | Subject: [PATCH] CMakeLists: do not use vendored libcurl | 4 | Subject: [PATCH] CMakeLists: do not use vendored libcurl |
5 | MIME-Version: 1.0 | 5 | MIME-Version: 1.0 |
6 | Content-Type: text/plain; charset=UTF-8 | 6 | Content-Type: text/plain; charset=UTF-8 |
@@ -10,14 +10,14 @@ Upstream-Status: Inappropriate [upstream ticket https://github.com/nxp-imx/bcu/i | |||
10 | 10 | ||
11 | Signed-off-by: Leonard Göhrs <l.goehrs@pengutronix.de> | 11 | Signed-off-by: Leonard Göhrs <l.goehrs@pengutronix.de> |
12 | --- | 12 | --- |
13 | CMakeLists.txt | 5 +++-- | 13 | CMakeLists.txt | 10 +++++----- |
14 | 1 file changed, 3 insertions(+), 2 deletions(-) | 14 | 1 file changed, 5 insertions(+), 5 deletions(-) |
15 | 15 | ||
16 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 16 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
17 | index 3475179..bfecdb0 100644 | 17 | index 42158a2..ac840fc 100644 |
18 | --- a/CMakeLists.txt | 18 | --- a/CMakeLists.txt |
19 | +++ b/CMakeLists.txt | 19 | +++ b/CMakeLists.txt |
20 | @@ -17,15 +17,16 @@ pkg_check_modules(LIBFTDI REQUIRED libftdi1) | 20 | @@ -17,17 +17,17 @@ pkg_check_modules(LIBFTDI REQUIRED libftdi1) |
21 | pkg_check_modules(LIBYAML REQUIRED yaml-0.1) | 21 | pkg_check_modules(LIBYAML REQUIRED yaml-0.1) |
22 | pkg_check_modules(LIBOPENSSL REQUIRED openssl) | 22 | pkg_check_modules(LIBOPENSSL REQUIRED openssl) |
23 | pkg_check_modules(LIBUSB REQUIRED libusb-1.0) | 23 | pkg_check_modules(LIBUSB REQUIRED libusb-1.0) |
@@ -30,9 +30,16 @@ index 3475179..bfecdb0 100644 | |||
30 | message("operation system is ${CMAKE_SYSTEM}") | 30 | message("operation system is ${CMAKE_SYSTEM}") |
31 | if (LINUX) | 31 | if (LINUX) |
32 | add_executable(bcu bcu.c port.c chip.c board.c bcu_parser.c bcu_yaml.c bcu_https.c bcu_ftdi_eeprom.c) | 32 | add_executable(bcu bcu.c port.c chip.c board.c bcu_parser.c bcu_yaml.c bcu_https.c bcu_ftdi_eeprom.c) |
33 | link_directories(${LIBUSB_LIBRARY_DIRS} ${LIBFTDI_LIBRARY_DIRS} ${LIBYAML_LIBRARY_DIRS}) | 33 | - link_directories(${LIBUSB_LIBRARY_DIRS} ${LIBFTDI_LIBRARY_DIRS} ${LIBYAML_LIBRARY_DIRS}) |
34 | - target_link_libraries (bcu ${LIBUSB_LIBRARIES} ${LIBFTDI_LIBRARIES} ${LIBYAML_LIBRARIES} ${PROJECT_SOURCE_DIR}/libcurl/build.bcu/lib/libcurl.a -lpthread -lssl -lcrypto -lm) | 34 | - target_link_libraries (bcu ${LIBUSB_LIBRARIES} ${LIBFTDI_LIBRARIES} ${LIBYAML_LIBRARIES} ${PROJECT_SOURCE_DIR}/libcurl/build.bcu/lib/libcurl.a -lpthread -lssl -lcrypto -lm -ldl) |
35 | + target_link_libraries (bcu ${LIBUSB_LIBRARIES} ${LIBFTDI_LIBRARIES} ${LIBYAML_LIBRARIES} -lcurl -lpthread -lssl -lcrypto -lm) | 35 | - execute_process( COMMAND ${PROJECT_SOURCE_DIR}/create_version_h.sh ${PROJECT_SOURCE_DIR} |
36 | execute_process( COMMAND ${PROJECT_SOURCE_DIR}/create_version_h.sh ${PROJECT_SOURCE_DIR} | 36 | - COMMAND ${PROJECT_SOURCE_DIR}/build_libs.sh ${PROJECT_SOURCE_DIR}) |
37 | COMMAND ${PROJECT_SOURCE_DIR}/build_libs.sh ${PROJECT_SOURCE_DIR}) | 37 | + link_directories(${LIBUSB_LIBRARY_DIRS} ${LIBFTDI_LIBRARY_DIRS} ${LIBYAML_LIBRARY_DIRS} ${LIBCURL_LIBRARY_DIRS}) |
38 | + target_link_libraries (bcu ${LIBUSB_LIBRARIES} ${LIBFTDI_LIBRARIES} ${LIBYAML_LIBRARIES} ${LIBCURL_LIBRARIES} -lpthread -lssl -lcrypto -lm -ldl) | ||
39 | + execute_process( COMMAND ${PROJECT_SOURCE_DIR}/create_version_h.sh ${PROJECT_SOURCE_DIR}) | ||
38 | install(TARGETS bcu DESTINATION bin) | 40 | install(TARGETS bcu DESTINATION bin) |
41 | elseif (MACOS) | ||
42 | add_executable(bcu_mac bcu.c port.c chip.c board.c bcu_parser.c bcu_yaml.c bcu_https.c bcu_ftdi_eeprom.c) | ||
43 | -- | ||
44 | 2.39.5 | ||
45 | |||
diff --git a/meta-oe/recipes-support/bcu/bcu_1.1.100.bb b/meta-oe/recipes-support/bcu/bcu_1.1.115.bb index bf6e4f4b69..897e7031ca 100644 --- a/meta-oe/recipes-support/bcu/bcu_1.1.100.bb +++ b/meta-oe/recipes-support/bcu/bcu_1.1.115.bb | |||
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=884d48c2aa7b82e1ad4a33909fab24b6" | |||
12 | SRC_URI = "git://github.com/nxp-imx/bcu;protocol=https;branch=master \ | 12 | SRC_URI = "git://github.com/nxp-imx/bcu;protocol=https;branch=master \ |
13 | file://0001-CMakeLists-do-not-use-vendored-libcurl.patch \ | 13 | file://0001-CMakeLists-do-not-use-vendored-libcurl.patch \ |
14 | " | 14 | " |
15 | SRCREV = "c34d89b29f3d0d12793cd78b194d2f1d11728baf" | 15 | SRCREV = "f081c69c26e330cf03ec790051c415c4716509d9" |
16 | 16 | ||
17 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
18 | 18 | ||