diff options
-rw-r--r-- | meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch | 57 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/boost-url/boost-url_git.bb | 13 |
2 files changed, 7 insertions, 63 deletions
diff --git a/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch b/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch deleted file mode 100644 index 4c996656c0..0000000000 --- a/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | From 329e27c8ad30e76ab50c7949cc95ba8eb0efabd2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Anton Blanchard <anton@ozlabs.org> | ||
3 | Date: Tue, 17 Aug 2021 09:53:41 +1000 | ||
4 | Subject: [PATCH] Use GNUInstallDirs instead of hard wiring install directories | ||
5 | |||
6 | On a multilib setup cmake files should go into lib64. | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/CPPAlliance/url/pull/38] | ||
9 | --- | ||
10 | CMakeLists.txt | 10 ++++++---- | ||
11 | 1 file changed, 6 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
14 | index 5b53f31..ebb7346 100644 | ||
15 | --- a/CMakeLists.txt | ||
16 | +++ b/CMakeLists.txt | ||
17 | @@ -109,20 +109,22 @@ else() | ||
18 | endif() | ||
19 | |||
20 | if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR AND NOT BOOST_URL_IN_BOOST_TREE) | ||
21 | + include(GNUInstallDirs) | ||
22 | + | ||
23 | set_target_properties(boost_url PROPERTIES EXPORT_NAME url) | ||
24 | install(TARGETS boost_url EXPORT boost_url_targets) | ||
25 | |||
26 | install(EXPORT boost_url_targets | ||
27 | FILE boost_url-targets.cmake | ||
28 | NAMESPACE Boost:: | ||
29 | - DESTINATION lib/cmake/boost_url | ||
30 | + DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url | ||
31 | ) | ||
32 | |||
33 | include(CMakePackageConfigHelpers) | ||
34 | |||
35 | configure_package_config_file(cmake/config.cmake.in | ||
36 | ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config.cmake | ||
37 | - INSTALL_DESTINATION lib/cmake/boost_url | ||
38 | + INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url | ||
39 | ) | ||
40 | |||
41 | write_basic_package_version_file(${CMAKE_CURRENT_BINARY_DIR}/boost_url-config-version.cmake | ||
42 | @@ -132,10 +134,10 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR AND NOT BOOST_URL_IN_BOOST | ||
43 | install(FILES | ||
44 | ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config.cmake | ||
45 | ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config-version.cmake | ||
46 | - DESTINATION lib/cmake/boost_url | ||
47 | + DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url | ||
48 | ) | ||
49 | |||
50 | - install(DIRECTORY include/ DESTINATION include) | ||
51 | + install(DIRECTORY include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}) | ||
52 | endif() | ||
53 | |||
54 | if(BOOST_URL_BUILD_TESTS) | ||
55 | -- | ||
56 | 2.31.1 | ||
57 | |||
diff --git a/meta-oe/recipes-devtools/boost-url/boost-url_git.bb b/meta-oe/recipes-devtools/boost-url/boost-url_git.bb index cb3664fe30..9f759100b8 100644 --- a/meta-oe/recipes-devtools/boost-url/boost-url_git.bb +++ b/meta-oe/recipes-devtools/boost-url/boost-url_git.bb | |||
@@ -4,16 +4,17 @@ SECTION = "libs" | |||
4 | LICENSE = "BSL-1.0" | 4 | LICENSE = "BSL-1.0" |
5 | LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c" | 5 | LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
6 | 6 | ||
7 | SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop \ | 7 | SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop" |
8 | file://0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch \ | ||
9 | " | ||
10 | 8 | ||
11 | SRCREV = "2c867fbe284ae532f1329b87a86ad3f8cd382867" | 9 | SRCREV = "4f712ed69a04a344957d22efa5dc111b415b3aff" |
12 | 10 | ||
13 | S = "${WORKDIR}/git" | 11 | S = "${WORKDIR}/git" |
14 | 12 | ||
15 | inherit cmake | ||
16 | |||
17 | DEPENDS = "boost" | 13 | DEPENDS = "boost" |
18 | 14 | ||
19 | BBCLASSEXTEND = "native nativesdk" | 15 | BBCLASSEXTEND = "native nativesdk" |
16 | |||
17 | do_install() { | ||
18 | mkdir -p ${D}/${includedir} | ||
19 | cp -r ${S}/include/** ${D}/${includedir}/ | ||
20 | } | ||