summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch11
-rw-r--r--meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb (renamed from meta-python/recipes-devtools/python/python3-prctl_1.7.bb)8
2 files changed, 10 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch b/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch
index 775ae1b2e2..98d250c74c 100644
--- a/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch
+++ b/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch
@@ -1,4 +1,4 @@
1From 9a16800738547d117284354bbcad7dd77d9d0344 Mon Sep 17 00:00:00 2001 1From 5f3911737c63a098caf73f1365320fe1b3a7638b Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 21 Apr 2016 03:05:57 -0400 3Date: Thu, 21 Apr 2016 03:05:57 -0400
4Subject: [PATCH] support cross-complication 4Subject: [PATCH] support cross-complication
@@ -6,12 +6,13 @@ Subject: [PATCH] support cross-complication
6Upstream-Status: Inappropriate [oe specific] 6Upstream-Status: Inappropriate [oe specific]
7 7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
9--- 10---
10 setup.py | 35 ----------------------------------- 11 setup.py | 35 -----------------------------------
11 1 file changed, 35 deletions(-) 12 1 file changed, 35 deletions(-)
12 13
13diff --git a/setup.py b/setup.py 14diff --git a/setup.py b/setup.py
14index 658d1a5..e8be7eb 100755 15index eb83cfe..3f9567b 100755
15--- a/setup.py 16--- a/setup.py
16+++ b/setup.py 17+++ b/setup.py
17@@ -13,41 +13,6 @@ import sys 18@@ -13,41 +13,6 @@ import sys
@@ -38,13 +39,13 @@ index 658d1a5..e8be7eb 100755
38- sys.stderr.write("You need to install gcc to build this module\n") 39- sys.stderr.write("You need to install gcc to build this module\n")
39- sys.exit(1) 40- sys.exit(1)
40- 41-
41-sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE) 42-sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, env=os.environ)
42-sp.communicate('#include <sys/prctl.h>\n'.encode()) 43-sp.communicate('#include <sys/prctl.h>\n'.encode())
43-if sp.returncode: 44-if sp.returncode:
44- sys.stderr.write("You need to install libc development headers to build this module\n") 45- sys.stderr.write("You need to install libc development headers to build this module\n")
45- exit = True 46- exit = True
46- 47-
47-sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE) 48-sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, env=os.environ)
48-sp.communicate('#include <sys/capability.h>\n'.encode()) 49-sp.communicate('#include <sys/capability.h>\n'.encode())
49-if sp.returncode: 50-if sp.returncode:
50- sys.stderr.write("You need to install libcap development headers to build this module\n") 51- sys.stderr.write("You need to install libcap development headers to build this module\n")
@@ -57,5 +58,5 @@ index 658d1a5..e8be7eb 100755
57 sources = ['_prctlmodule.c'], 58 sources = ['_prctlmodule.c'],
58 depends = ['securebits.h'], 59 depends = ['securebits.h'],
59-- 60--
602.8.1 612.17.1
61 62
diff --git a/meta-python/recipes-devtools/python/python3-prctl_1.7.bb b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
index 54620a0661..b87a470b40 100644
--- a/meta-python/recipes-devtools/python/python3-prctl_1.7.bb
+++ b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
@@ -5,15 +5,15 @@ limitations in C and linux. This module provides a nice non-messy python(ic) \
5interface." 5interface."
6SECTION = "devel/python" 6SECTION = "devel/python"
7LICENSE = "GPLv3" 7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=23ff9f50449d4bd0e513df16e4d9755f" 8LIC_FILES_CHKSUM = "file://COPYING;md5=1475481f9ec754d758859bd2c75f6f6f"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11B = "${S}" 11B = "${S}"
12 12
13SRCREV = "57cd0a7cad76e8f8792eea22ee5b5d17bae0a90f" 13SRCREV = "5e12e398eb5c4e30d7b29b02458c76d2cc780700"
14PV = "1.7+git${SRCPV}" 14PV = "1.8.1+git${SRCPV}"
15 15
16SRC_URI = "git://github.com/seveas/python-prctl;branch=master \ 16SRC_URI = "git://github.com/seveas/python-prctl;branch=main\
17 file://0001-support-cross-complication.patch \ 17 file://0001-support-cross-complication.patch \
18" 18"
19inherit setuptools3 python3native 19inherit setuptools3 python3native