diff options
7 files changed, 239 insertions, 98 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch new file mode 100644 index 0000000000..6d4bdc2ab6 --- /dev/null +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-Use-override-consistently.patch | |||
@@ -0,0 +1,147 @@ | |||
1 | From 0acfb67f99fd8d6af323311fee8c08116295b148 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 5 Sep 2018 18:21:19 -0700 | ||
4 | Subject: [PATCH 1/2] Use override consistently | ||
5 | |||
6 | Make clang++ happy | ||
7 | error: 'setApplicationTitle' overrides a member function but is not marked 'override' [-Werror,-Winconsistent-missing-over ride] | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/69] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | src/NCApplication.h | 46 ++++++++++++++++++++++----------------------- | ||
13 | 1 file changed, 23 insertions(+), 23 deletions(-) | ||
14 | |||
15 | diff --git a/src/NCApplication.h b/src/NCApplication.h | ||
16 | index e24c3eb..09e4708 100644 | ||
17 | --- a/src/NCApplication.h | ||
18 | +++ b/src/NCApplication.h | ||
19 | @@ -60,7 +60,7 @@ public: | ||
20 | * Reimplemented from YApplication. | ||
21 | **/ | ||
22 | virtual void setLanguage( const std::string & language, | ||
23 | - const std::string & encoding = std::string() ); | ||
24 | + const std::string & encoding = std::string() ) override; | ||
25 | |||
26 | /** | ||
27 | * Open a directory selection box and prompt the user for an existing | ||
28 | @@ -77,7 +77,7 @@ public: | ||
29 | * Implemented from YApplication. | ||
30 | **/ | ||
31 | virtual std::string askForExistingDirectory( const std::string & startDir, | ||
32 | - const std::string & headline ); | ||
33 | + const std::string & headline ) override; | ||
34 | |||
35 | /** | ||
36 | * Open a file selection box and prompt the user for an existing file. | ||
37 | @@ -97,7 +97,7 @@ public: | ||
38 | **/ | ||
39 | virtual std::string askForExistingFile( const std::string & startWith, | ||
40 | const std::string & filter, | ||
41 | - const std::string & headline ); | ||
42 | + const std::string & headline ) override; | ||
43 | |||
44 | /** | ||
45 | * Open a file selection box and prompt the user for a file to save data | ||
46 | @@ -119,28 +119,28 @@ public: | ||
47 | **/ | ||
48 | virtual std::string askForSaveFileName( const std::string & startWith, | ||
49 | const std::string & filter, | ||
50 | - const std::string & headline ); | ||
51 | + const std::string & headline ) override; | ||
52 | |||
53 | /** | ||
54 | * Beep. | ||
55 | * | ||
56 | * Reimplemented from YApplication. | ||
57 | **/ | ||
58 | - virtual void beep(); | ||
59 | + virtual void beep() override; | ||
60 | |||
61 | /** | ||
62 | * Redraw the screen. | ||
63 | * | ||
64 | * Reimplemented from YApplication. | ||
65 | **/ | ||
66 | - virtual void redrawScreen(); | ||
67 | + virtual void redrawScreen() override; | ||
68 | |||
69 | /** | ||
70 | * Initialize the (text) console keyboard. | ||
71 | * | ||
72 | * Reimplemented from YApplication. | ||
73 | **/ | ||
74 | - virtual void initConsoleKeyboard(); | ||
75 | + virtual void initConsoleKeyboard() override; | ||
76 | |||
77 | /** | ||
78 | * Set the (text) console font according to the current encoding etc. | ||
79 | @@ -152,7 +152,7 @@ public: | ||
80 | const std::string & font, | ||
81 | const std::string & screen_map, | ||
82 | const std::string & unicode_map, | ||
83 | - const std::string & language ); | ||
84 | + const std::string & language ) override; | ||
85 | |||
86 | /** | ||
87 | * Run a shell command (typically an interactive program using NCurses) | ||
88 | @@ -165,7 +165,7 @@ public: | ||
89 | * | ||
90 | * Reimplemented from YApplication. | ||
91 | **/ | ||
92 | - virtual int runInTerminal( const std::string & command ); | ||
93 | + virtual int runInTerminal( const std::string & command ) override; | ||
94 | |||
95 | |||
96 | /// @{ | ||
97 | @@ -183,33 +183,33 @@ public: | ||
98 | // | ||
99 | // All implemented from YApplication. | ||
100 | |||
101 | - virtual int displayWidth(); | ||
102 | - virtual int displayHeight(); | ||
103 | - virtual int displayDepth(); | ||
104 | - virtual long displayColors(); | ||
105 | + virtual int displayWidth() override; | ||
106 | + virtual int displayHeight() override; | ||
107 | + virtual int displayDepth() override; | ||
108 | + virtual long displayColors() override; | ||
109 | |||
110 | - virtual int defaultWidth(); | ||
111 | - virtual int defaultHeight(); | ||
112 | + virtual int defaultWidth() override; | ||
113 | + virtual int defaultHeight() override; | ||
114 | |||
115 | - virtual bool isTextMode() { return true; } | ||
116 | + virtual bool isTextMode() override { return true; } | ||
117 | |||
118 | - virtual bool hasImageSupport() { return false; } | ||
119 | + virtual bool hasImageSupport() override { return false; } | ||
120 | |||
121 | - virtual bool hasIconSupport() { return false; } | ||
122 | + virtual bool hasIconSupport() override { return false; } | ||
123 | |||
124 | - virtual bool hasAnimationSupport() { return false; } | ||
125 | + virtual bool hasAnimationSupport() override { return false; } | ||
126 | |||
127 | - virtual bool hasFullUtf8Support(); | ||
128 | - virtual bool richTextSupportsTable() { return false; } | ||
129 | + virtual bool hasFullUtf8Support() override; | ||
130 | + virtual bool richTextSupportsTable() override { return false; } | ||
131 | |||
132 | - virtual bool leftHandedMouse() { return false; } | ||
133 | + virtual bool leftHandedMouse() override { return false; } | ||
134 | |||
135 | /** | ||
136 | * Set the application title | ||
137 | * | ||
138 | * Reimplemented from YApplication. | ||
139 | **/ | ||
140 | - virtual void setApplicationTitle(const std::string& title); | ||
141 | + virtual void setApplicationTitle(const std::string& title) override; | ||
142 | }; | ||
143 | |||
144 | |||
145 | -- | ||
146 | 2.18.0 | ||
147 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch deleted file mode 100644 index 8e3774c1ae..0000000000 --- a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0001-use-_nl_msg_cat_cntr-only-with-glibc.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From 4b84f243a70a8c07f6a38dad3c9411fa707f25c9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 4 Mar 2018 17:08:43 -0800 | ||
4 | Subject: [PATCH] use _nl_msg_cat_cntr only with glibc | ||
5 | |||
6 | The musl libc provides libintl (similar to glibc) | ||
7 | but does not use the same internals, | ||
8 | so even though we are using the GNU gettext | ||
9 | the libintl included with the libc does not define | ||
10 | _nl_msg_cat_cntr and it does not need to. | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | Upstream-Status: Pending | ||
15 | |||
16 | src/NCi18n.h | 3 ++- | ||
17 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/src/NCi18n.h b/src/NCi18n.h | ||
20 | index 165b0e7..bfc4ed7 100644 | ||
21 | --- a/src/NCi18n.h | ||
22 | +++ b/src/NCi18n.h | ||
23 | @@ -59,12 +59,13 @@ inline void setTextdomain( const char * domain ) | ||
24 | bindtextdomain( domain, YSettings::localeDir().c_str() ); | ||
25 | bind_textdomain_codeset( domain, "UTF-8" ); | ||
26 | textdomain( domain ); | ||
27 | - | ||
28 | +#if defined(__GLIBC__) | ||
29 | // Make change known | ||
30 | { | ||
31 | extern int _nl_msg_cat_cntr; | ||
32 | ++_nl_msg_cat_cntr; | ||
33 | } | ||
34 | +#endif | ||
35 | } | ||
36 | |||
37 | |||
38 | -- | ||
39 | 2.16.2 | ||
40 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch new file mode 100644 index 0000000000..f65cbe6679 --- /dev/null +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses/0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From 162a0899f1dacd83007c4e82b9034f55610d8c20 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 5 Sep 2018 19:01:51 -0700 | ||
4 | Subject: [PATCH 2/2] Define own resize in NCPad and fix param type of | ||
5 | SetLabel() | ||
6 | |||
7 | Explicitly override resize() to avoid conflicts from NCursesWindow | ||
8 | definition since there is another resize definition as well | ||
9 | |||
10 | Fixes | ||
11 | src/NCPad.h:164:18: error: 'NCPad::resize' hides overloaded virtual function [-Werror,-Woverloaded-virtual] | ||
12 | |||
13 | NCTablePad.h:132:18: error: 'NCTableTag::SetLabel' hides overloaded virtual function [-Werror,-Woverloaded-virtual] | ||
14 | |||
15 | Upstream-Status: Submitted [https://github.com/libyui/libyui-ncurses/pull/69] | ||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | src/NCPad.h | 1 + | ||
19 | src/NCTablePad.h | 2 +- | ||
20 | 2 files changed, 2 insertions(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/src/NCPad.h b/src/NCPad.h | ||
23 | index 328c4aa..d8fb324 100644 | ||
24 | --- a/src/NCPad.h | ||
25 | +++ b/src/NCPad.h | ||
26 | @@ -162,6 +162,7 @@ public: | ||
27 | virtual void Destwin( NCursesWindow * dwin ); | ||
28 | |||
29 | virtual void resize( wsze nsze ); | ||
30 | + virtual int resize( int lines, int columns ) { return NCursesWindow::resize(lines, columns );} | ||
31 | virtual void wRecoded(); | ||
32 | virtual void setDirty() { dirty = true; } | ||
33 | |||
34 | diff --git a/src/NCTablePad.h b/src/NCTablePad.h | ||
35 | index c450529..3756796 100644 | ||
36 | --- a/src/NCTablePad.h | ||
37 | +++ b/src/NCTablePad.h | ||
38 | @@ -129,7 +129,7 @@ public: | ||
39 | |||
40 | virtual ~NCTableTag() {} | ||
41 | |||
42 | - virtual void SetLabel( const NCstring & ) { /*NOOP*/; } | ||
43 | + virtual void SetLabel( const NClabel & ) { /*NOOP*/; } | ||
44 | |||
45 | virtual void DrawAt( NCursesWindow & w, const wrect at, | ||
46 | NCTableStyle & tableStyle, | ||
47 | -- | ||
48 | 2.18.0 | ||
49 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb index 578c713012..4fafce1662 100644 --- a/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb +++ b/meta-oe/recipes-graphics/libyui/libyui-ncurses_git.bb | |||
@@ -5,13 +5,14 @@ LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \ | |||
5 | " | 5 | " |
6 | 6 | ||
7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ | 7 | SRC_URI = "git://github.com/libyui/libyui-ncurses.git \ |
8 | file://0001-use-_nl_msg_cat_cntr-only-with-glibc.patch \ | 8 | file://0001-Use-override-consistently.patch \ |
9 | file://0002-Define-own-resize-in-NCPad-and-fix-param-type-of-Set.patch \ | ||
9 | " | 10 | " |
10 | 11 | ||
11 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" | 12 | SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch" |
12 | 13 | ||
13 | PV = "2.48.3+git${SRCPV}" | 14 | PV = "2.48.3+git${SRCPV}" |
14 | SRCREV = "79b804b45ffc6a0d92e28e793ff389a20b63b54b" | 15 | SRCREV = "c941b32246e8b2952fce4fd5743f8e318222ab98" |
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
17 | 18 | ||
@@ -29,8 +30,8 @@ do_configure_prepend () { | |||
29 | mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ | 30 | mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
30 | cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ | 31 | cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/ |
31 | cd - | 32 | cd - |
32 | sed -i "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt | 33 | sed -i -e "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt |
33 | sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake | 34 | sed -i -e "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake |
34 | } | 35 | } |
35 | 36 | ||
36 | do_install_append () { | 37 | do_install_append () { |
diff --git a/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch b/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch deleted file mode 100644 index c1ba42eeed..0000000000 --- a/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | From 1e6d40fec16a94d1a4bd40634405267200b7e969 Mon Sep 17 00:00:00 2001 | ||
2 | From: marxin <mliska@suse.cz> | ||
3 | Date: Tue, 10 Apr 2018 15:21:40 +0200 | ||
4 | Subject: [PATCH] Fix GCC 8 warning: | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | /home/marxin/Programming/libyui/src/YDialog.cc: In static member function ‘static void YDialog::showText(const string&, bool)’: | ||
10 | /home/marxin/Programming/libyui/src/YDialog.cc:690:26: error: catching polymorphic type ‘class YUIException’ by value [-Werror=catch-value=] | ||
11 | catch ( YUIException exception ) | ||
12 | ^~~~~~~~~ | ||
13 | /home/marxin/Programming/libyui/src/YDialog.cc: In static member function ‘static bool YDialog::showRelNotesText()’: | ||
14 | /home/marxin/Programming/libyui/src/YDialog.cc:814:26: error: catching polymorphic type ‘class YUIException’ by value [-Werror=catch-value=] | ||
15 | catch ( YUIException exception ) | ||
16 | ^~~~~~~~~ | ||
17 | --- | ||
18 | Upstream-Status: Submitted [https://github.com/libyui/libyui/pull/122] | ||
19 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
20 | |||
21 | src/YDialog.cc | 4 ++-- | ||
22 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
23 | |||
24 | diff --git a/src/YDialog.cc b/src/YDialog.cc | ||
25 | index 92e5031..8ecff90 100644 | ||
26 | --- a/src/YDialog.cc | ||
27 | +++ b/src/YDialog.cc | ||
28 | @@ -687,7 +687,7 @@ YDialog::showText( const std::string & text, bool useRichText ) | ||
29 | dialog->waitForEvent(); | ||
30 | dialog->destroy(); | ||
31 | } | ||
32 | - catch ( YUIException exception ) | ||
33 | + catch ( YUIException &exception ) | ||
34 | { | ||
35 | // Don't let the application die just because help couldn't be displayed. | ||
36 | |||
37 | @@ -811,7 +811,7 @@ YDialog::showRelNotesText() | ||
38 | } | ||
39 | dialog->destroy(); | ||
40 | } | ||
41 | - catch ( YUIException exception ) | ||
42 | + catch ( YUIException &exception ) | ||
43 | { | ||
44 | // Don't let the application die just because RN couldn't be displayed. | ||
45 | |||
46 | -- | ||
47 | 2.17.0 | ||
48 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui/0001-Use-curly-braces-for-MAKE-variable.patch b/meta-oe/recipes-graphics/libyui/libyui/0001-Use-curly-braces-for-MAKE-variable.patch new file mode 100644 index 0000000000..dbe241709a --- /dev/null +++ b/meta-oe/recipes-graphics/libyui/libyui/0001-Use-curly-braces-for-MAKE-variable.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 4eed37b1a61458fc8e5251f7cb7c6d64e8e9da8d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 5 Sep 2018 17:48:09 -0700 | ||
4 | Subject: [PATCH] Use curly braces for MAKE variable | ||
5 | |||
6 | Fixes errors with ninja | ||
7 | | ninja: error: build.ninja:142: bad $-escape (literal $ must be written as $$) | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/libyui/libyui/pull/137] | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | buildtools/LibyuiCommon.cmake | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/buildtools/LibyuiCommon.cmake b/buildtools/LibyuiCommon.cmake | ||
16 | index cb93307..e6fbefd 100644 | ||
17 | --- a/buildtools/LibyuiCommon.cmake | ||
18 | +++ b/buildtools/LibyuiCommon.cmake | ||
19 | @@ -122,8 +122,8 @@ MACRO( SET_BUILD_FLAGS ) # setup compiler-flags depending on CMAKE_BUILD_TYPE | ||
20 | ENABLE_TESTING() | ||
21 | # add a wrapper "tests" target, the builtin "test" cannot be extended :-( | ||
22 | ADD_CUSTOM_TARGET(tests | ||
23 | - $(MAKE) | ||
24 | - COMMAND $(MAKE) test | ||
25 | + ${MAKE} | ||
26 | + COMMAND ${MAKE} test | ||
27 | ) | ||
28 | ENDIF ( ENABLE_TESTS OR ENABLE_CODE_COVERAGE) | ||
29 | |||
30 | -- | ||
31 | 2.18.0 | ||
32 | |||
diff --git a/meta-oe/recipes-graphics/libyui/libyui_git.bb b/meta-oe/recipes-graphics/libyui/libyui_git.bb index 42945288c4..2826652cb7 100644 --- a/meta-oe/recipes-graphics/libyui/libyui_git.bb +++ b/meta-oe/recipes-graphics/libyui/libyui_git.bb | |||
@@ -6,13 +6,13 @@ LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \ | |||
6 | " | 6 | " |
7 | 7 | ||
8 | SRC_URI = "git://github.com/libyui/libyui.git \ | 8 | SRC_URI = "git://github.com/libyui/libyui.git \ |
9 | file://0001-Fix-GCC-8-warning.patch \ | ||
10 | file://0001-Fix-build-with-clang.patch \ | 9 | file://0001-Fix-build-with-clang.patch \ |
10 | file://0001-Use-curly-braces-for-MAKE-variable.patch \ | ||
11 | " | 11 | " |
12 | 12 | ||
13 | PV = "3.3.3+git" | 13 | PV = "3.3.3+git" |
14 | SRCREV = "2b634cb7821e2e79dd4b7a73caf8e67c50189376" | 14 | SRCREV = "50672da835ec9d52766320a44a2677e08a24c99c" |
15 | 15 | SRCREV_FORMAT = "default" | |
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | 17 | ||
18 | inherit cmake gettext pkgconfig | 18 | inherit cmake gettext pkgconfig |
@@ -22,9 +22,9 @@ DEPENDS += "boost" | |||
22 | BBCLASSEXTEND = "native nativesdk" | 22 | BBCLASSEXTEND = "native nativesdk" |
23 | 23 | ||
24 | do_configure_prepend () { | 24 | do_configure_prepend () { |
25 | cd ${S} | 25 | (cd ${S} && |
26 | ./bootstrap.sh | 26 | ./bootstrap.sh && |
27 | cd - | 27 | cd -) |
28 | } | 28 | } |
29 | 29 | ||
30 | do_install_append () { | 30 | do_install_append () { |