summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/upm/upm/0001-include-missing-cstdint.patch43
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/upm/upm/0001-include-missing-cstdint.patch b/meta-oe/recipes-extended/upm/upm/0001-include-missing-cstdint.patch
new file mode 100644
index 0000000000..59f81bf3a2
--- /dev/null
+++ b/meta-oe/recipes-extended/upm/upm/0001-include-missing-cstdint.patch
@@ -0,0 +1,43 @@
1From 64f75806c04c2ee819cf2f92cb564ad316354823 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 29 Jan 2023 00:27:47 -0800
4Subject: [PATCH] include missing <cstdint>
5
6gcc 13 moved some includes around and as a result <cstdint> is no longer transitively included [1]. Explicitly include it for uint{32,64}_t.
7
8[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
9
10Upstream-Status: Submitted [https://github.com/eclipse/upm/pull/704]
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/mcp9808/mcp9808.hpp | 1 +
14 src/micsv89/micsv89.hpp | 1 +
15 2 files changed, 2 insertions(+)
16
17diff --git a/src/mcp9808/mcp9808.hpp b/src/mcp9808/mcp9808.hpp
18index b9e138d7..2509cd30 100644
19--- a/src/mcp9808/mcp9808.hpp
20+++ b/src/mcp9808/mcp9808.hpp
21@@ -13,6 +13,7 @@
22
23 #pragma once
24
25+#include <cstdint>
26 #include <iostream>
27 #include <string>
28 #include <interfaces/iTemperature.hpp>
29diff --git a/src/micsv89/micsv89.hpp b/src/micsv89/micsv89.hpp
30index 2f97dbce..c6e22ad8 100644
31--- a/src/micsv89/micsv89.hpp
32+++ b/src/micsv89/micsv89.hpp
33@@ -11,6 +11,7 @@
34
35 #pragma once
36
37+#include <cstdint>
38 #include <iostream>
39 #include <string>
40
41--
422.39.1
43
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
index 61e2e38b05..0ae7760bd2 100644
--- a/meta-oe/recipes-extended/upm/upm_git.bb
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -16,6 +16,7 @@ SRC_URI = "git://github.com/eclipse/${BPN}.git;protocol=http;branch=master;proto
16 file://0001-initialize-local-variables-before-use.patch \ 16 file://0001-initialize-local-variables-before-use.patch \
17 file://0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch \ 17 file://0001-cmake-Disable-Wno-misleading-indentation-with-clang-.patch \
18 file://0001-cmake-Disable-using-Wno-maybe-uninitialized.patch \ 18 file://0001-cmake-Disable-using-Wno-maybe-uninitialized.patch \
19 file://0001-include-missing-cstdint.patch \
19 " 20 "
20 21
21SRC_URI:append:toolchain-clang:x86 = " file://0001-nmea_gps-Link-with-latomic.patch " 22SRC_URI:append:toolchain-clang:x86 = " file://0001-nmea_gps-Link-with-latomic.patch "