diff options
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui/0001-Fix-build-with-clang.patch | 96 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/libyui/libyui_3.6.0.bb | 2 |
2 files changed, 3 insertions, 95 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-build-with-clang.patch b/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-build-with-clang.patch index 4269018192..b03723ac04 100644 --- a/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-build-with-clang.patch +++ b/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-build-with-clang.patch | |||
@@ -65,8 +65,6 @@ Upstream-Status: Submitted [https://github.com/libyui/libyui/pull/123] | |||
65 | src/YWizard.h | 2 +- | 65 | src/YWizard.h | 2 +- |
66 | 47 files changed, 48 insertions(+), 48 deletions(-) | 66 | 47 files changed, 48 insertions(+), 48 deletions(-) |
67 | 67 | ||
68 | diff --git a/src/YAlignment.h b/src/YAlignment.h | ||
69 | index d716c77..7276944 100644 | ||
70 | --- a/src/YAlignment.h | 68 | --- a/src/YAlignment.h |
71 | +++ b/src/YAlignment.h | 69 | +++ b/src/YAlignment.h |
72 | @@ -28,7 +28,7 @@ | 70 | @@ -28,7 +28,7 @@ |
@@ -78,8 +76,6 @@ index d716c77..7276944 100644 | |||
78 | 76 | ||
79 | /** | 77 | /** |
80 | * Implementation of all the alignment widgets: | 78 | * Implementation of all the alignment widgets: |
81 | diff --git a/src/YBarGraph.h b/src/YBarGraph.h | ||
82 | index 29f7f26..d7eaad2 100644 | ||
83 | --- a/src/YBarGraph.h | 79 | --- a/src/YBarGraph.h |
84 | +++ b/src/YBarGraph.h | 80 | +++ b/src/YBarGraph.h |
85 | @@ -29,7 +29,7 @@ | 81 | @@ -29,7 +29,7 @@ |
@@ -91,8 +87,6 @@ index 29f7f26..d7eaad2 100644 | |||
91 | class YBarGraphSegment; | 87 | class YBarGraphSegment; |
92 | 88 | ||
93 | /** | 89 | /** |
94 | diff --git a/src/YBusyIndicator.h b/src/YBusyIndicator.h | ||
95 | index 9530fa5..75297d8 100644 | ||
96 | --- a/src/YBusyIndicator.h | 90 | --- a/src/YBusyIndicator.h |
97 | +++ b/src/YBusyIndicator.h | 91 | +++ b/src/YBusyIndicator.h |
98 | @@ -27,7 +27,7 @@ | 92 | @@ -27,7 +27,7 @@ |
@@ -104,8 +98,6 @@ index 9530fa5..75297d8 100644 | |||
104 | 98 | ||
105 | 99 | ||
106 | /** | 100 | /** |
107 | diff --git a/src/YButtonBox.h b/src/YButtonBox.h | ||
108 | index 84f8dbb..ca51f57 100644 | ||
109 | --- a/src/YButtonBox.h | 101 | --- a/src/YButtonBox.h |
110 | +++ b/src/YButtonBox.h | 102 | +++ b/src/YButtonBox.h |
111 | @@ -30,7 +30,7 @@ | 103 | @@ -30,7 +30,7 @@ |
@@ -126,8 +118,6 @@ index 84f8dbb..ca51f57 100644 | |||
126 | 118 | ||
127 | protected: | 119 | protected: |
128 | /** | 120 | /** |
129 | diff --git a/src/YCheckBox.h b/src/YCheckBox.h | ||
130 | index 793cc77..03f3faa 100644 | ||
131 | --- a/src/YCheckBox.h | 121 | --- a/src/YCheckBox.h |
132 | +++ b/src/YCheckBox.h | 122 | +++ b/src/YCheckBox.h |
133 | @@ -30,7 +30,7 @@ | 123 | @@ -30,7 +30,7 @@ |
@@ -139,8 +129,6 @@ index 793cc77..03f3faa 100644 | |||
139 | 129 | ||
140 | enum YCheckBoxState | 130 | enum YCheckBoxState |
141 | { | 131 | { |
142 | diff --git a/src/YCheckBoxFrame.h b/src/YCheckBoxFrame.h | ||
143 | index 243f1a0..7017110 100644 | ||
144 | --- a/src/YCheckBoxFrame.h | 132 | --- a/src/YCheckBoxFrame.h |
145 | +++ b/src/YCheckBoxFrame.h | 133 | +++ b/src/YCheckBoxFrame.h |
146 | @@ -29,7 +29,7 @@ | 134 | @@ -29,7 +29,7 @@ |
@@ -152,8 +140,6 @@ index 243f1a0..7017110 100644 | |||
152 | 140 | ||
153 | 141 | ||
154 | /** | 142 | /** |
155 | diff --git a/src/YComboBox.h b/src/YComboBox.h | ||
156 | index 416359a..ad0e550 100644 | ||
157 | --- a/src/YComboBox.h | 143 | --- a/src/YComboBox.h |
158 | +++ b/src/YComboBox.h | 144 | +++ b/src/YComboBox.h |
159 | @@ -27,7 +27,7 @@ | 145 | @@ -27,7 +27,7 @@ |
@@ -165,8 +151,6 @@ index 416359a..ad0e550 100644 | |||
165 | 151 | ||
166 | 152 | ||
167 | /** | 153 | /** |
168 | diff --git a/src/YCommandLine.h b/src/YCommandLine.h | ||
169 | index 70cb4fe..f344a3b 100644 | ||
170 | --- a/src/YCommandLine.h | 154 | --- a/src/YCommandLine.h |
171 | +++ b/src/YCommandLine.h | 155 | +++ b/src/YCommandLine.h |
172 | @@ -28,7 +28,7 @@ | 156 | @@ -28,7 +28,7 @@ |
@@ -178,8 +162,6 @@ index 70cb4fe..f344a3b 100644 | |||
178 | 162 | ||
179 | 163 | ||
180 | /** | 164 | /** |
181 | diff --git a/src/YContextMenu.h b/src/YContextMenu.h | ||
182 | index a4acb1c..1253002 100644 | ||
183 | --- a/src/YContextMenu.h | 165 | --- a/src/YContextMenu.h |
184 | +++ b/src/YContextMenu.h | 166 | +++ b/src/YContextMenu.h |
185 | @@ -29,7 +29,7 @@ | 167 | @@ -29,7 +29,7 @@ |
@@ -191,8 +173,6 @@ index a4acb1c..1253002 100644 | |||
191 | 173 | ||
192 | 174 | ||
193 | /** | 175 | /** |
194 | diff --git a/src/YDateField.h b/src/YDateField.h | ||
195 | index e5a468d..6164fba 100644 | ||
196 | --- a/src/YDateField.h | 176 | --- a/src/YDateField.h |
197 | +++ b/src/YDateField.h | 177 | +++ b/src/YDateField.h |
198 | @@ -27,7 +27,7 @@ | 178 | @@ -27,7 +27,7 @@ |
@@ -204,8 +184,6 @@ index e5a468d..6164fba 100644 | |||
204 | 184 | ||
205 | /** | 185 | /** |
206 | * Input field for entering a date. | 186 | * Input field for entering a date. |
207 | diff --git a/src/YDialog.h b/src/YDialog.h | ||
208 | index 66c25c0..371209b 100644 | ||
209 | --- a/src/YDialog.h | 187 | --- a/src/YDialog.h |
210 | +++ b/src/YDialog.h | 188 | +++ b/src/YDialog.h |
211 | @@ -32,7 +32,7 @@ | 189 | @@ -32,7 +32,7 @@ |
@@ -217,8 +195,6 @@ index 66c25c0..371209b 100644 | |||
217 | class YEvent; | 195 | class YEvent; |
218 | class YEventFilter; | 196 | class YEventFilter; |
219 | 197 | ||
220 | diff --git a/src/YDownloadProgress.h b/src/YDownloadProgress.h | ||
221 | index c47ec4f..fe09a9d 100644 | ||
222 | --- a/src/YDownloadProgress.h | 198 | --- a/src/YDownloadProgress.h |
223 | +++ b/src/YDownloadProgress.h | 199 | +++ b/src/YDownloadProgress.h |
224 | @@ -28,7 +28,7 @@ | 200 | @@ -28,7 +28,7 @@ |
@@ -230,8 +206,6 @@ index c47ec4f..fe09a9d 100644 | |||
230 | 206 | ||
231 | /** | 207 | /** |
232 | * DownloadProgress: A progress bar that monitors downloading a file by | 208 | * DownloadProgress: A progress bar that monitors downloading a file by |
233 | diff --git a/src/YDumbTab.h b/src/YDumbTab.h | ||
234 | index aec17a3..f8fb250 100644 | ||
235 | --- a/src/YDumbTab.h | 209 | --- a/src/YDumbTab.h |
236 | +++ b/src/YDumbTab.h | 210 | +++ b/src/YDumbTab.h |
237 | @@ -27,7 +27,7 @@ | 211 | @@ -27,7 +27,7 @@ |
@@ -243,8 +217,6 @@ index aec17a3..f8fb250 100644 | |||
243 | 217 | ||
244 | /** | 218 | /** |
245 | * DumbTab: A very simple tab widget that can display and switch between a | 219 | * DumbTab: A very simple tab widget that can display and switch between a |
246 | diff --git a/src/YEmpty.h b/src/YEmpty.h | ||
247 | index 9a3cb36..9b88fbc 100644 | ||
248 | --- a/src/YEmpty.h | 220 | --- a/src/YEmpty.h |
249 | +++ b/src/YEmpty.h | 221 | +++ b/src/YEmpty.h |
250 | @@ -29,7 +29,7 @@ | 222 | @@ -29,7 +29,7 @@ |
@@ -256,8 +228,6 @@ index 9a3cb36..9b88fbc 100644 | |||
256 | 228 | ||
257 | /** | 229 | /** |
258 | * A widget with zero size, useful as a placeholder. | 230 | * A widget with zero size, useful as a placeholder. |
259 | diff --git a/src/YEventFilter.h b/src/YEventFilter.h | ||
260 | index 3dc1803..74aa62d 100644 | ||
261 | --- a/src/YEventFilter.h | 231 | --- a/src/YEventFilter.h |
262 | +++ b/src/YEventFilter.h | 232 | +++ b/src/YEventFilter.h |
263 | @@ -32,7 +32,7 @@ | 233 | @@ -32,7 +32,7 @@ |
@@ -269,8 +239,6 @@ index 3dc1803..74aa62d 100644 | |||
269 | 239 | ||
270 | 240 | ||
271 | /** | 241 | /** |
272 | diff --git a/src/YFrame.h b/src/YFrame.h | ||
273 | index 111e8ec..4f8c61e 100644 | ||
274 | --- a/src/YFrame.h | 242 | --- a/src/YFrame.h |
275 | +++ b/src/YFrame.h | 243 | +++ b/src/YFrame.h |
276 | @@ -29,7 +29,7 @@ | 244 | @@ -29,7 +29,7 @@ |
@@ -282,8 +250,6 @@ index 111e8ec..4f8c61e 100644 | |||
282 | 250 | ||
283 | 251 | ||
284 | /** | 252 | /** |
285 | diff --git a/src/YGraph.h b/src/YGraph.h | ||
286 | index d90d1ae..287d800 100644 | ||
287 | --- a/src/YGraph.h | 253 | --- a/src/YGraph.h |
288 | +++ b/src/YGraph.h | 254 | +++ b/src/YGraph.h |
289 | @@ -37,7 +37,7 @@ | 255 | @@ -37,7 +37,7 @@ |
@@ -295,8 +261,6 @@ index d90d1ae..287d800 100644 | |||
295 | 261 | ||
296 | /** | 262 | /** |
297 | * A graph with nodes and edges, rendered with Graphviz. | 263 | * A graph with nodes and edges, rendered with Graphviz. |
298 | diff --git a/src/YImage.h b/src/YImage.h | ||
299 | index 17bea21..84eb674 100644 | ||
300 | --- a/src/YImage.h | 264 | --- a/src/YImage.h |
301 | +++ b/src/YImage.h | 265 | +++ b/src/YImage.h |
302 | @@ -29,7 +29,7 @@ | 266 | @@ -29,7 +29,7 @@ |
@@ -308,8 +272,6 @@ index 17bea21..84eb674 100644 | |||
308 | 272 | ||
309 | /** | 273 | /** |
310 | * A picture, possibly animated, loaded from a file. | 274 | * A picture, possibly animated, loaded from a file. |
311 | diff --git a/src/YInputField.h b/src/YInputField.h | ||
312 | index 70641ce..fa29b42 100644 | ||
313 | --- a/src/YInputField.h | 275 | --- a/src/YInputField.h |
314 | +++ b/src/YInputField.h | 276 | +++ b/src/YInputField.h |
315 | @@ -28,7 +28,7 @@ | 277 | @@ -28,7 +28,7 @@ |
@@ -321,8 +283,6 @@ index 70641ce..fa29b42 100644 | |||
321 | 283 | ||
322 | 284 | ||
323 | 285 | ||
324 | diff --git a/src/YIntField.h b/src/YIntField.h | ||
325 | index 9da0537..8ad2949 100644 | ||
326 | --- a/src/YIntField.h | 286 | --- a/src/YIntField.h |
327 | +++ b/src/YIntField.h | 287 | +++ b/src/YIntField.h |
328 | @@ -27,7 +27,7 @@ | 288 | @@ -27,7 +27,7 @@ |
@@ -334,8 +294,6 @@ index 9da0537..8ad2949 100644 | |||
334 | 294 | ||
335 | 295 | ||
336 | 296 | ||
337 | diff --git a/src/YLabel.h b/src/YLabel.h | ||
338 | index d2fff61..bf06d8b 100644 | ||
339 | --- a/src/YLabel.h | 297 | --- a/src/YLabel.h |
340 | +++ b/src/YLabel.h | 298 | +++ b/src/YLabel.h |
341 | @@ -30,7 +30,7 @@ | 299 | @@ -30,7 +30,7 @@ |
@@ -347,8 +305,6 @@ index d2fff61..bf06d8b 100644 | |||
347 | 305 | ||
348 | /** | 306 | /** |
349 | * Implementation of the Label, Heading and OutputField widgets | 307 | * Implementation of the Label, Heading and OutputField widgets |
350 | diff --git a/src/YLayoutBox.h b/src/YLayoutBox.h | ||
351 | index e652a45..070eaff 100644 | ||
352 | --- a/src/YLayoutBox.h | 308 | --- a/src/YLayoutBox.h |
353 | +++ b/src/YLayoutBox.h | 309 | +++ b/src/YLayoutBox.h |
354 | @@ -29,7 +29,7 @@ | 310 | @@ -29,7 +29,7 @@ |
@@ -360,8 +316,6 @@ index e652a45..070eaff 100644 | |||
360 | 316 | ||
361 | /** | 317 | /** |
362 | * A vertical or horizontal stacking of widgets, implementing HBox and VBox. | 318 | * A vertical or horizontal stacking of widgets, implementing HBox and VBox. |
363 | diff --git a/src/YLogView.h b/src/YLogView.h | ||
364 | index 53fb9ee..5b44229 100644 | ||
365 | --- a/src/YLogView.h | 319 | --- a/src/YLogView.h |
366 | +++ b/src/YLogView.h | 320 | +++ b/src/YLogView.h |
367 | @@ -27,7 +27,7 @@ | 321 | @@ -27,7 +27,7 @@ |
@@ -373,8 +327,6 @@ index 53fb9ee..5b44229 100644 | |||
373 | 327 | ||
374 | 328 | ||
375 | /** | 329 | /** |
376 | diff --git a/src/YMenuButton.h b/src/YMenuButton.h | ||
377 | index 205e730..5df7efb 100644 | ||
378 | --- a/src/YMenuButton.h | 330 | --- a/src/YMenuButton.h |
379 | +++ b/src/YMenuButton.h | 331 | +++ b/src/YMenuButton.h |
380 | @@ -29,7 +29,7 @@ | 332 | @@ -29,7 +29,7 @@ |
@@ -386,8 +338,6 @@ index 205e730..5df7efb 100644 | |||
386 | 338 | ||
387 | 339 | ||
388 | /** | 340 | /** |
389 | diff --git a/src/YMultiLineEdit.h b/src/YMultiLineEdit.h | ||
390 | index c52a6ae..1f792f8 100644 | ||
391 | --- a/src/YMultiLineEdit.h | 341 | --- a/src/YMultiLineEdit.h |
392 | +++ b/src/YMultiLineEdit.h | 342 | +++ b/src/YMultiLineEdit.h |
393 | @@ -27,7 +27,7 @@ | 343 | @@ -27,7 +27,7 @@ |
@@ -399,8 +349,6 @@ index c52a6ae..1f792f8 100644 | |||
399 | 349 | ||
400 | /** | 350 | /** |
401 | * A multi-line plain-text area | 351 | * A multi-line plain-text area |
402 | diff --git a/src/YMultiProgressMeter.h b/src/YMultiProgressMeter.h | ||
403 | index 57c758d..f6bec91 100644 | ||
404 | --- a/src/YMultiProgressMeter.h | 352 | --- a/src/YMultiProgressMeter.h |
405 | +++ b/src/YMultiProgressMeter.h | 353 | +++ b/src/YMultiProgressMeter.h |
406 | @@ -28,7 +28,7 @@ | 354 | @@ -28,7 +28,7 @@ |
@@ -412,8 +360,6 @@ index 57c758d..f6bec91 100644 | |||
412 | 360 | ||
413 | 361 | ||
414 | /** | 362 | /** |
415 | diff --git a/src/YMultiSelectionBox.h b/src/YMultiSelectionBox.h | ||
416 | index bbe5a20..f3a2947 100644 | ||
417 | --- a/src/YMultiSelectionBox.h | 363 | --- a/src/YMultiSelectionBox.h |
418 | +++ b/src/YMultiSelectionBox.h | 364 | +++ b/src/YMultiSelectionBox.h |
419 | @@ -27,7 +27,7 @@ | 365 | @@ -27,7 +27,7 @@ |
@@ -425,8 +371,6 @@ index bbe5a20..f3a2947 100644 | |||
425 | 371 | ||
426 | 372 | ||
427 | /** | 373 | /** |
428 | diff --git a/src/YPartitionSplitter.h b/src/YPartitionSplitter.h | ||
429 | index 2839bbc..9de1174 100644 | ||
430 | --- a/src/YPartitionSplitter.h | 374 | --- a/src/YPartitionSplitter.h |
431 | +++ b/src/YPartitionSplitter.h | 375 | +++ b/src/YPartitionSplitter.h |
432 | @@ -28,7 +28,7 @@ | 376 | @@ -28,7 +28,7 @@ |
@@ -438,8 +382,6 @@ index 2839bbc..9de1174 100644 | |||
438 | 382 | ||
439 | 383 | ||
440 | /** | 384 | /** |
441 | diff --git a/src/YProgressBar.h b/src/YProgressBar.h | ||
442 | index 718352f..baab662 100644 | ||
443 | --- a/src/YProgressBar.h | 385 | --- a/src/YProgressBar.h |
444 | +++ b/src/YProgressBar.h | 386 | +++ b/src/YProgressBar.h |
445 | @@ -27,7 +27,7 @@ | 387 | @@ -27,7 +27,7 @@ |
@@ -451,8 +393,6 @@ index 718352f..baab662 100644 | |||
451 | 393 | ||
452 | 394 | ||
453 | /** | 395 | /** |
454 | diff --git a/src/YPushButton.h b/src/YPushButton.h | ||
455 | index 5b65c98..e288252 100644 | ||
456 | --- a/src/YPushButton.h | 396 | --- a/src/YPushButton.h |
457 | +++ b/src/YPushButton.h | 397 | +++ b/src/YPushButton.h |
458 | @@ -27,7 +27,7 @@ | 398 | @@ -27,7 +27,7 @@ |
@@ -464,8 +404,6 @@ index 5b65c98..e288252 100644 | |||
464 | 404 | ||
465 | 405 | ||
466 | 406 | ||
467 | diff --git a/src/YRadioButton.h b/src/YRadioButton.h | ||
468 | index 9dc62de..5a7c0dd 100644 | ||
469 | --- a/src/YRadioButton.h | 407 | --- a/src/YRadioButton.h |
470 | +++ b/src/YRadioButton.h | 408 | +++ b/src/YRadioButton.h |
471 | @@ -28,7 +28,7 @@ | 409 | @@ -28,7 +28,7 @@ |
@@ -477,8 +415,6 @@ index 9dc62de..5a7c0dd 100644 | |||
477 | 415 | ||
478 | 416 | ||
479 | /** | 417 | /** |
480 | diff --git a/src/YRadioButtonGroup.h b/src/YRadioButtonGroup.h | ||
481 | index 063a52e..671a257 100644 | ||
482 | --- a/src/YRadioButtonGroup.h | 418 | --- a/src/YRadioButtonGroup.h |
483 | +++ b/src/YRadioButtonGroup.h | 419 | +++ b/src/YRadioButtonGroup.h |
484 | @@ -28,7 +28,7 @@ | 420 | @@ -28,7 +28,7 @@ |
@@ -490,8 +426,6 @@ index 063a52e..671a257 100644 | |||
490 | 426 | ||
491 | typedef std::list<YRadioButton *> YRadioButtonList; | 427 | typedef std::list<YRadioButton *> YRadioButtonList; |
492 | typedef YRadioButtonList::iterator YRadioButtonListIterator; | 428 | typedef YRadioButtonList::iterator YRadioButtonListIterator; |
493 | diff --git a/src/YRichText.h b/src/YRichText.h | ||
494 | index 149bfb3..86b3f80 100644 | ||
495 | --- a/src/YRichText.h | 429 | --- a/src/YRichText.h |
496 | +++ b/src/YRichText.h | 430 | +++ b/src/YRichText.h |
497 | @@ -30,7 +30,7 @@ | 431 | @@ -30,7 +30,7 @@ |
@@ -503,8 +437,6 @@ index 149bfb3..86b3f80 100644 | |||
503 | 437 | ||
504 | 438 | ||
505 | /** | 439 | /** |
506 | diff --git a/src/YSelectionBox.h b/src/YSelectionBox.h | ||
507 | index 7fc4fb8..9bbf9f3 100644 | ||
508 | --- a/src/YSelectionBox.h | 440 | --- a/src/YSelectionBox.h |
509 | +++ b/src/YSelectionBox.h | 441 | +++ b/src/YSelectionBox.h |
510 | @@ -27,7 +27,7 @@ | 442 | @@ -27,7 +27,7 @@ |
@@ -516,8 +448,6 @@ index 7fc4fb8..9bbf9f3 100644 | |||
516 | 448 | ||
517 | 449 | ||
518 | /** | 450 | /** |
519 | diff --git a/src/YSelectionWidget.h b/src/YSelectionWidget.h | ||
520 | index abbdfb4..cf05afd 100644 | ||
521 | --- a/src/YSelectionWidget.h | 451 | --- a/src/YSelectionWidget.h |
522 | +++ b/src/YSelectionWidget.h | 452 | +++ b/src/YSelectionWidget.h |
523 | @@ -29,7 +29,7 @@ | 453 | @@ -29,7 +29,7 @@ |
@@ -529,8 +459,6 @@ index abbdfb4..cf05afd 100644 | |||
529 | 459 | ||
530 | /** | 460 | /** |
531 | * Base class for various kinds of multi-value widgets. | 461 | * Base class for various kinds of multi-value widgets. |
532 | diff --git a/src/YSimpleInputField.h b/src/YSimpleInputField.h | ||
533 | index 6d926d4..b93fe6b 100644 | ||
534 | --- a/src/YSimpleInputField.h | 462 | --- a/src/YSimpleInputField.h |
535 | +++ b/src/YSimpleInputField.h | 463 | +++ b/src/YSimpleInputField.h |
536 | @@ -27,7 +27,7 @@ | 464 | @@ -27,7 +27,7 @@ |
@@ -542,8 +470,6 @@ index 6d926d4..b93fe6b 100644 | |||
542 | 470 | ||
543 | 471 | ||
544 | /** | 472 | /** |
545 | diff --git a/src/YSlider.h b/src/YSlider.h | ||
546 | index d29f6b8..4bcd7d3 100644 | ||
547 | --- a/src/YSlider.h | 473 | --- a/src/YSlider.h |
548 | +++ b/src/YSlider.h | 474 | +++ b/src/YSlider.h |
549 | @@ -27,7 +27,7 @@ | 475 | @@ -27,7 +27,7 @@ |
@@ -555,8 +481,6 @@ index d29f6b8..4bcd7d3 100644 | |||
555 | 481 | ||
556 | 482 | ||
557 | /** | 483 | /** |
558 | diff --git a/src/YSpacing.h b/src/YSpacing.h | ||
559 | index e8aafd3..066cd68 100644 | ||
560 | --- a/src/YSpacing.h | 484 | --- a/src/YSpacing.h |
561 | +++ b/src/YSpacing.h | 485 | +++ b/src/YSpacing.h |
562 | @@ -28,7 +28,7 @@ | 486 | @@ -28,7 +28,7 @@ |
@@ -568,8 +492,6 @@ index e8aafd3..066cd68 100644 | |||
568 | 492 | ||
569 | 493 | ||
570 | /** | 494 | /** |
571 | diff --git a/src/YSquash.h b/src/YSquash.h | ||
572 | index 4bd0fb6..3804cc4 100644 | ||
573 | --- a/src/YSquash.h | 495 | --- a/src/YSquash.h |
574 | +++ b/src/YSquash.h | 496 | +++ b/src/YSquash.h |
575 | @@ -29,7 +29,7 @@ | 497 | @@ -29,7 +29,7 @@ |
@@ -581,8 +503,6 @@ index 4bd0fb6..3804cc4 100644 | |||
581 | 503 | ||
582 | /** | 504 | /** |
583 | * HSquash, VSquash HVSquash: reduce child to its preferred size. | 505 | * HSquash, VSquash HVSquash: reduce child to its preferred size. |
584 | diff --git a/src/YTable.h b/src/YTable.h | ||
585 | index 6694f10..469b8ca 100644 | ||
586 | --- a/src/YTable.h | 506 | --- a/src/YTable.h |
587 | +++ b/src/YTable.h | 507 | +++ b/src/YTable.h |
588 | @@ -30,7 +30,7 @@ | 508 | @@ -30,7 +30,7 @@ |
@@ -594,8 +514,6 @@ index 6694f10..469b8ca 100644 | |||
594 | 514 | ||
595 | 515 | ||
596 | 516 | ||
597 | diff --git a/src/YTableHeader.h b/src/YTableHeader.h | ||
598 | index 70166c2..4ae99b4 100644 | ||
599 | --- a/src/YTableHeader.h | 517 | --- a/src/YTableHeader.h |
600 | +++ b/src/YTableHeader.h | 518 | +++ b/src/YTableHeader.h |
601 | @@ -31,7 +31,7 @@ | 519 | @@ -31,7 +31,7 @@ |
@@ -607,8 +525,6 @@ index 70166c2..4ae99b4 100644 | |||
607 | 525 | ||
608 | /** | 526 | /** |
609 | * Helper class for YTable for table column properties: | 527 | * Helper class for YTable for table column properties: |
610 | diff --git a/src/YTimeField.h b/src/YTimeField.h | ||
611 | index ab2f9a3..f3a7b94 100644 | ||
612 | --- a/src/YTimeField.h | 528 | --- a/src/YTimeField.h |
613 | +++ b/src/YTimeField.h | 529 | +++ b/src/YTimeField.h |
614 | @@ -27,7 +27,7 @@ | 530 | @@ -27,7 +27,7 @@ |
@@ -620,8 +536,6 @@ index ab2f9a3..f3a7b94 100644 | |||
620 | 536 | ||
621 | 537 | ||
622 | /** | 538 | /** |
623 | diff --git a/src/YTimezoneSelector.cc b/src/YTimezoneSelector.cc | ||
624 | index 9259b64..e2f9b6f 100644 | ||
625 | --- a/src/YTimezoneSelector.cc | 539 | --- a/src/YTimezoneSelector.cc |
626 | +++ b/src/YTimezoneSelector.cc | 540 | +++ b/src/YTimezoneSelector.cc |
627 | @@ -32,7 +32,7 @@ | 541 | @@ -32,7 +32,7 @@ |
@@ -633,8 +547,6 @@ index 9259b64..e2f9b6f 100644 | |||
633 | }; | 547 | }; |
634 | 548 | ||
635 | 549 | ||
636 | diff --git a/src/YTree.h b/src/YTree.h | ||
637 | index 14fa279..70e1364 100644 | ||
638 | --- a/src/YTree.h | 550 | --- a/src/YTree.h |
639 | +++ b/src/YTree.h | 551 | +++ b/src/YTree.h |
640 | @@ -28,7 +28,7 @@ | 552 | @@ -28,7 +28,7 @@ |
@@ -646,8 +558,6 @@ index 14fa279..70e1364 100644 | |||
646 | 558 | ||
647 | 559 | ||
648 | /** | 560 | /** |
649 | diff --git a/src/YUILog.h b/src/YUILog.h | ||
650 | index 0890bc5..4a927a7 100644 | ||
651 | --- a/src/YUILog.h | 561 | --- a/src/YUILog.h |
652 | +++ b/src/YUILog.h | 562 | +++ b/src/YUILog.h |
653 | @@ -64,7 +64,7 @@ | 563 | @@ -64,7 +64,7 @@ |
@@ -659,11 +569,9 @@ index 0890bc5..4a927a7 100644 | |||
659 | 569 | ||
660 | enum YUILogLevel_t | 570 | enum YUILogLevel_t |
661 | { | 571 | { |
662 | diff --git a/src/YWidget.h b/src/YWidget.h | ||
663 | index 5b285d0..636a41b 100644 | ||
664 | --- a/src/YWidget.h | 572 | --- a/src/YWidget.h |
665 | +++ b/src/YWidget.h | 573 | +++ b/src/YWidget.h |
666 | @@ -45,7 +45,7 @@ typedef YChildrenManager<YWidget> YWidgetChildrenManager; | 574 | @@ -45,7 +45,7 @@ typedef YChildrenManager<YWidget> YWidge |
667 | typedef YSingleChildManager<YWidget> YSingleWidgetChildManager; | 575 | typedef YSingleChildManager<YWidget> YSingleWidgetChildManager; |
668 | typedef YChildrenRejector<YWidget> YWidgetChildrenRejector; | 576 | typedef YChildrenRejector<YWidget> YWidgetChildrenRejector; |
669 | 577 | ||
@@ -672,8 +580,6 @@ index 5b285d0..636a41b 100644 | |||
672 | 580 | ||
673 | 581 | ||
674 | /** | 582 | /** |
675 | diff --git a/src/YWizard.h b/src/YWizard.h | ||
676 | index 7671cbf..975b597 100644 | ||
677 | --- a/src/YWizard.h | 583 | --- a/src/YWizard.h |
678 | +++ b/src/YWizard.h | 584 | +++ b/src/YWizard.h |
679 | @@ -28,7 +28,7 @@ | 585 | @@ -28,7 +28,7 @@ |
diff --git a/meta-oe/recipes-graphics/libyui/libyui_3.6.0.bb b/meta-oe/recipes-graphics/libyui/libyui_3.6.0.bb index d8a921925a..7c6f4c13d2 100644 --- a/meta-oe/recipes-graphics/libyui/libyui_3.6.0.bb +++ b/meta-oe/recipes-graphics/libyui/libyui_3.6.0.bb | |||
@@ -18,6 +18,8 @@ inherit cmake gettext pkgconfig | |||
18 | 18 | ||
19 | DEPENDS += "boost" | 19 | DEPENDS += "boost" |
20 | 20 | ||
21 | EXTRA_OECMAKE += "-DENABLE_WERROR=OFF" | ||
22 | |||
21 | BBCLASSEXTEND = "native nativesdk" | 23 | BBCLASSEXTEND = "native nativesdk" |
22 | 24 | ||
23 | do_configure_prepend () { | 25 | do_configure_prepend () { |