summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-gnome/recipes-connectivity/geary/geary/0001-meson-Do-not-check-for-iso-xml-files-during-build.patch28
-rw-r--r--meta-gnome/recipes-connectivity/geary/geary_46.0.bb5
2 files changed, 31 insertions, 2 deletions
diff --git a/meta-gnome/recipes-connectivity/geary/geary/0001-meson-Do-not-check-for-iso-xml-files-during-build.patch b/meta-gnome/recipes-connectivity/geary/geary/0001-meson-Do-not-check-for-iso-xml-files-during-build.patch
new file mode 100644
index 0000000000..ecab7155e6
--- /dev/null
+++ b/meta-gnome/recipes-connectivity/geary/geary/0001-meson-Do-not-check-for-iso-xml-files-during-build.patch
@@ -0,0 +1,28 @@
1From 474cd5a9d22ef9f25c37194d3c8ce1bc4d18102d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 22 Nov 2024 00:44:49 -0800
4Subject: [PATCH] meson: Do not check for iso xml files during build
5
6These files are needed during runtime and may exist in a different
7path ( staging area ) when cross-compiled, therefore its not completely
8valid to check for these files to exist during build-time
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 meson.build | 2 --
14 1 file changed, 2 deletions(-)
15
16diff --git a/meson.build b/meson.build
17index 87261baee..032629f5f 100644
18--- a/meson.build
19+++ b/meson.build
20@@ -219,8 +219,6 @@ if iso_3166_xml == ''
21 iso_3166_xml = iso_codes_dir / 'iso_3166.xml'
22 endif
23
24-files(iso_639_xml, iso_3166_xml) # Check to make sure these exist
25-
26 # Post-install script
27 gnome.post_install(
28 gtk_update_icon_cache: true,
diff --git a/meta-gnome/recipes-connectivity/geary/geary_46.0.bb b/meta-gnome/recipes-connectivity/geary/geary_46.0.bb
index 6d6d9f5443..7474ee0bab 100644
--- a/meta-gnome/recipes-connectivity/geary/geary_46.0.bb
+++ b/meta-gnome/recipes-connectivity/geary/geary_46.0.bb
@@ -38,6 +38,7 @@ inherit meson pkgconfig mime-xdg gsettings gtk-icon-cache gobject-introspection
38SRC_URI = " \ 38SRC_URI = " \
39 git://github.com/GNOME/geary.git;nobranch=1;protocol=https \ 39 git://github.com/GNOME/geary.git;nobranch=1;protocol=https \
40 file://0001-application-client.vala-hardcode-some-paths.patch \ 40 file://0001-application-client.vala-hardcode-some-paths.patch \
41 file://0001-meson-Do-not-check-for-iso-xml-files-during-build.patch \
41" 42"
42 43
43S = "${WORKDIR}/git" 44S = "${WORKDIR}/git"
@@ -48,8 +49,8 @@ REQUIRED_DISTRO_FEATURES = "gobject-introspection-data opengl"
48 49
49GIR_MESON_OPTION = "" 50GIR_MESON_OPTION = ""
50EXTRA_OEMESON = "-Dprofile=release \ 51EXTRA_OEMESON = "-Dprofile=release \
51 -Diso_639_xml=${STAGING_DATADIR}/xml/iso-codes/iso_639.xml \ 52 -Diso_639_xml=${datadir}/xml/iso-codes/iso_639.xml \
52 -Diso_3166_xml=${STAGING_DATADIR}/xml/iso-codes/iso_3166.xml \ 53 -Diso_3166_xml=${datadir}/xml/iso-codes/iso_3166.xml \
53 " 54 "
54 55
55PACKAGECONFIG[libunwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind" 56PACKAGECONFIG[libunwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"