summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb b/meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb
new file mode 100644
index 0000000000..179e071277
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb
@@ -0,0 +1,17 @@
1SUMMARY = "Expose your Python functions to the command line with one easy step!"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=ea70b07c354e36056bd35e17c9c3face"
4
5inherit pypi setuptools3
6
7SRC_URI[md5sum] = "9fac09884c54db79e57ab80f0c423794"
8SRC_URI[sha256sum] = "e271286b280f930aeaae7496454573f8029c3f48ef1dc47c780155dd4a7b9e7f"
9
10DEPENDS += "python3-setuptools-scm-native"
11RDEPENDS_${PN} += "\
12 python3-typing \
13 python3-dynamic-dispatch \
14 python3-typeguard \
15"
16
17BBCLASSEXTEND = "native nativesdk"