summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/bmap-writer/bmap-writer_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bmap-writer/bmap-writer_git.bb b/meta-oe/recipes-support/bmap-writer/bmap-writer_git.bb
new file mode 100644
index 0000000000..f25ed70111
--- /dev/null
+++ b/meta-oe/recipes-support/bmap-writer/bmap-writer_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "bmaptool alternative written in C++"
2DESCRIPTION = "bmap-writer is a command-line utility designed to efficiently write disk images \
3to storage devices using block mapping (BMAP). It serves as \
4a lightweight alternative to the Yocto BMAP tool, \
5bmap-writer is C++ based does not require Python and focuses solely on writing an image."
6HOMEPAGE = "https://github.com/embetrix/bmap-writer"
7SECTION = "console/utils"
8LICENSE = "GPL-3.0-only"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=e49f4652534af377a713df3d9dec60cb"
10
11SRC_URI = "git://github.com/embetrix/${BPN};branch=master;protocol=https"
12SRCREV = "74826a19f7eb31e029405cd0ea6b07c2aaddc73d"
13S = "${WORKDIR}/git"
14
15DEPENDS= "openssl libxml2 xz zlib"
16inherit cmake
17
18EXTRA_OEMAKE += 'LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2"'
19
20FILES:${PN} = "${bindir}/bmap-writer"
21
22BBCLASSEXTEND = "native nativesdk"