diff options
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch | 24 | ||||
-rw-r--r-- | meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb | 3 |
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch new file mode 100644 index 0000000000..90242aeb64 --- /dev/null +++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | From 84d70b6bc744cd348e66a0bc6c7958cdfa9ce670 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 29 Jun 2017 12:56:21 -0700 | ||
4 | Subject: [PATCH] flb-plugin-proxy-go: Add missing dependency on jemalloc | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/proxy/go/CMakeLists.txt | 3 +++ | ||
9 | 1 file changed, 3 insertions(+) | ||
10 | |||
11 | diff --git a/src/proxy/go/CMakeLists.txt b/src/proxy/go/CMakeLists.txt | ||
12 | index 3273346..02a54c2 100644 | ||
13 | --- a/src/proxy/go/CMakeLists.txt | ||
14 | +++ b/src/proxy/go/CMakeLists.txt | ||
15 | @@ -2,3 +2,6 @@ set(src | ||
16 | go.c) | ||
17 | |||
18 | add_library(flb-plugin-proxy-go STATIC ${src}) | ||
19 | +if(FLB_JEMALLOC) | ||
20 | + target_link_libraries(flb-plugin-proxy-go libjemalloc) | ||
21 | +endif() | ||
22 | -- | ||
23 | 2.13.2 | ||
24 | |||
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb index 46c47fd55e..83818c84d5 100644 --- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb +++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb | |||
@@ -3,6 +3,7 @@ HOMEPAGE = "http://fluentbit.io" | |||
3 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" | 3 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" |
4 | 4 | ||
5 | SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \ | 5 | SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \ |
6 | file://0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch \ | ||
6 | file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \ | 7 | file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \ |
7 | " | 8 | " |
8 | SRC_URI[md5sum] = "7bce8091c41fb6412b7fe0185b3cb8d6" | 9 | SRC_URI[md5sum] = "7bce8091c41fb6412b7fe0185b3cb8d6" |
@@ -21,3 +22,5 @@ inherit cmake systemd | |||
21 | EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1" | 22 | EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1" |
22 | 23 | ||
23 | SYSTEMD_SERVICE_${PN} = "fluent-bit.service" | 24 | SYSTEMD_SERVICE_${PN} = "fluent-bit.service" |
25 | |||
26 | TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}" | ||