summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch24
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb3
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch
new file mode 100644
index 0000000000..90242aeb64
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch
@@ -0,0 +1,24 @@
1From 84d70b6bc744cd348e66a0bc6c7958cdfa9ce670 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 29 Jun 2017 12:56:21 -0700
4Subject: [PATCH] flb-plugin-proxy-go: Add missing dependency on jemalloc
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 src/proxy/go/CMakeLists.txt | 3 +++
9 1 file changed, 3 insertions(+)
10
11diff --git a/src/proxy/go/CMakeLists.txt b/src/proxy/go/CMakeLists.txt
12index 3273346..02a54c2 100644
13--- a/src/proxy/go/CMakeLists.txt
14+++ b/src/proxy/go/CMakeLists.txt
15@@ -2,3 +2,6 @@ set(src
16 go.c)
17
18 add_library(flb-plugin-proxy-go STATIC ${src})
19+if(FLB_JEMALLOC)
20+ target_link_libraries(flb-plugin-proxy-go libjemalloc)
21+endif()
22--
232.13.2
24
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb
index 46c47fd55e..83818c84d5 100644
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://fluentbit.io"
3BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" 3BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
4 4
5SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \ 5SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \
6 file://0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch \
6 file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \ 7 file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \
7 " 8 "
8SRC_URI[md5sum] = "7bce8091c41fb6412b7fe0185b3cb8d6" 9SRC_URI[md5sum] = "7bce8091c41fb6412b7fe0185b3cb8d6"
@@ -21,3 +22,5 @@ inherit cmake systemd
21EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1" 22EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1"
22 23
23SYSTEMD_SERVICE_${PN} = "fluent-bit.service" 24SYSTEMD_SERVICE_${PN} = "fluent-bit.service"
25
26TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"