summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch16
-rw-r--r--meta-oe/recipes-support/zbar/zbar/0001-undefine-__va_arg_pack.patch51
-rw-r--r--meta-oe/recipes-support/zbar/zbar_git.bb (renamed from meta-oe/recipes-support/zbar/zbar_0.10.bb)17
3 files changed, 20 insertions, 64 deletions
diff --git a/meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch b/meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch
index 04239bacdb..c93af32966 100644
--- a/meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch
+++ b/meta-oe/recipes-support/zbar/zbar/0001-make-relies-GNU-extentions.patch
@@ -14,8 +14,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
14 configure.ac | 2 +- 14 configure.ac | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-) 15 1 file changed, 1 insertion(+), 1 deletion(-)
16 16
17diff --git a/configure.ac b/configure.ac
18index 56d3dd0..9f85fd7 100644
19--- a/configure.ac 17--- a/configure.ac
20+++ b/configure.ac 18+++ b/configure.ac
21@@ -3,7 +3,7 @@ AC_PREREQ([2.61]) 19@@ -3,7 +3,7 @@ AC_PREREQ([2.61])
@@ -23,10 +21,16 @@ index 56d3dd0..9f85fd7 100644
23 AC_CONFIG_AUX_DIR(config) 21 AC_CONFIG_AUX_DIR(config)
24 AC_CONFIG_MACRO_DIR(config) 22 AC_CONFIG_MACRO_DIR(config)
25-AM_INIT_AUTOMAKE([1.10 -Wall -Werror foreign subdir-objects std-options dist-bzip2]) 23-AM_INIT_AUTOMAKE([1.10 -Wall -Werror foreign subdir-objects std-options dist-bzip2])
26+AM_INIT_AUTOMAKE([1.10 -Wall -Werror -Wno-portability foreign subdir-objects std-options dist-bzip2]) 24+AM_INIT_AUTOMAKE([1.10 -Wall -Wno-error foreign subdir-objects std-options dist-bzip2])
27 AC_CONFIG_HEADERS([include/config.h]) 25 AC_CONFIG_HEADERS([include/config.h])
28 AC_CONFIG_SRCDIR(zbar/scanner.c) 26 AC_CONFIG_SRCDIR(zbar/scanner.c)
29 LT_PREREQ([2.2]) 27 LT_PREREQ([2.2])
30-- 28@@ -47,7 +47,7 @@ AC_DEFINE_UNQUOTED([LIB_VERSION_REVISION
312.10.2 29 [Library revision])
32 30
31 AM_CPPFLAGS="-I$srcdir/include"
32-AM_CFLAGS="-Wall -Wno-parentheses -Werror"
33+AM_CFLAGS="-Wall -Wno-parentheses"
34 AM_CXXFLAGS="$AM_CFLAGS"
35 AC_SUBST([AM_CPPFLAGS])
36 AC_SUBST([AM_CFLAGS])
diff --git a/meta-oe/recipes-support/zbar/zbar/0001-undefine-__va_arg_pack.patch b/meta-oe/recipes-support/zbar/zbar/0001-undefine-__va_arg_pack.patch
deleted file mode 100644
index f7d8ba1e96..0000000000
--- a/meta-oe/recipes-support/zbar/zbar/0001-undefine-__va_arg_pack.patch
+++ /dev/null
@@ -1,51 +0,0 @@
1From f842872244219d9881fbec77054702412b1e16f8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 2 Dec 2016 16:41:27 -0800
4Subject: [PATCH] undefine __va_arg_pack
5
6dprintf() is also a libc function. This fixes
7the compile errors
8
9/usr/include/bits/stdio2.h:140:1: error: expected identifier or '(' before '{' token
10| {
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 zbar/debug.h | 10 +++++-----
15 1 file changed, 5 insertions(+), 5 deletions(-)
16
17diff --git a/zbar/debug.h b/zbar/debug.h
18index 482ca8d..68948f6 100644
19--- a/zbar/debug.h
20+++ b/zbar/debug.h
21@@ -23,6 +23,7 @@
22
23 /* varargs variations on compile time debug spew */
24
25+#undef __va_arg_pack
26 #ifndef DEBUG_LEVEL
27
28 # ifdef __GNUC__
29@@ -36,15 +37,14 @@
30 #else
31
32 # include <stdio.h>
33-
34 # ifdef __GNUC__
35-# define dprintf(level, args...) \
36+# define dprintf(level, format, args...) \
37 if((level) <= DEBUG_LEVEL) \
38- fprintf(stderr, args)
39+ fprintf(stderr, format, args)
40 # else
41-# define dprintf(level, ...) \
42+# define dprintf(level, format, ...) \
43 if((level) <= DEBUG_LEVEL) \
44- fprintf(stderr, __VA_ARGS__)
45+ fprintf(stderr, format, __VA_ARGS__)
46 # endif
47
48 #endif /* DEBUG_LEVEL */
49--
502.10.2
51
diff --git a/meta-oe/recipes-support/zbar/zbar_0.10.bb b/meta-oe/recipes-support/zbar/zbar_git.bb
index ebd1f7a12f..935e09cd53 100644
--- a/meta-oe/recipes-support/zbar/zbar_0.10.bb
+++ b/meta-oe/recipes-support/zbar/zbar_git.bb
@@ -4,15 +4,16 @@ LICENSE = "LGPL-2.1"
4 4
5DEPENDS = "pkgconfig intltool-native libpng jpeg" 5DEPENDS = "pkgconfig intltool-native libpng jpeg"
6 6
7LIC_FILES_CHKSUM = "file://COPYING;md5=42bafded1b380c6fefbeb6c5cd5448d9" 7LIC_FILES_CHKSUM = "file://COPYING;md5=4015840237ca7f0175cd626f78714ca8"
8 8
9SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.bz2 \ 9PV = "0.10+git${SRCPV}"
10 file://0001-undefine-__va_arg_pack.patch \ 10
11# iPhoneSDK-1.3.1 tag
12SRCREV = "67003d2a985b5f9627bee2d8e3e0b26d0c474b57"
13SRC_URI = "git://github.com/ZBar/Zbar \
11 file://0001-make-relies-GNU-extentions.patch \ 14 file://0001-make-relies-GNU-extentions.patch \
12" 15"
13 16S = "${WORKDIR}/git"
14SRC_URI[md5sum] = "0fd61eb590ac1bab62a77913c8b086a5"
15SRC_URI[sha256sum] = "234efb39dbbe5cef4189cc76f37afbe3cfcfb45ae52493bfe8e191318bdbadc6"
16 17
17inherit autotools pkgconfig 18inherit autotools pkgconfig
18 19
@@ -20,7 +21,9 @@ PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
20 21
21PACKAGECONFIG[x11] = "--with-x,-without-x,libxcb libx11 libsm libxau libxext libxv libice libxdmcp" 22PACKAGECONFIG[x11] = "--with-x,-without-x,libxcb libx11 libsm libxau libxext libxv libice libxdmcp"
22 23
23EXTRA_OECONF = " --without-imagemagick --without-qt --without-python --disable-video --without-gtk" 24EXTRA_OECONF = "--without-imagemagick --without-qt --without-python --disable-video --without-gtk"
25
26CPPFLAGS += "-Wno-error"
24 27
25do_install_append() { 28do_install_append() {
26 #remove usr/bin if empty 29 #remove usr/bin if empty