summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-oe/recipes-devtools/tomlplusplus/files/run-ptest12
-rw-r--r--meta-oe/recipes-devtools/tomlplusplus/tomlplusplus_git.bb15
2 files changed, 25 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/tomlplusplus/files/run-ptest b/meta-oe/recipes-devtools/tomlplusplus/files/run-ptest
new file mode 100755
index 0000000000..4f682c5eb2
--- /dev/null
+++ b/meta-oe/recipes-devtools/tomlplusplus/files/run-ptest
@@ -0,0 +1,12 @@
1#!/bin/sh
2
3cd tests
4for atest in tomlplusplus_* ; do
5 rm -rf tests.log
6 ./${atest} > tests.log 2>&1
7 if [ $? = 0 ] ; then
8 echo "PASS: ${atest}"
9 else
10 echo "FAIL: ${atest}"
11 fi
12done
diff --git a/meta-oe/recipes-devtools/tomlplusplus/tomlplusplus_git.bb b/meta-oe/recipes-devtools/tomlplusplus/tomlplusplus_git.bb
index 0e8202bdcc..245c309a2e 100644
--- a/meta-oe/recipes-devtools/tomlplusplus/tomlplusplus_git.bb
+++ b/meta-oe/recipes-devtools/tomlplusplus/tomlplusplus_git.bb
@@ -3,7 +3,9 @@ HOMEPAGE = "https://github.com/marzer/tomlplusplus"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90960f22c10049c117d56ed2ee5ee167" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=90960f22c10049c117d56ed2ee5ee167"
5 5
6SRC_URI = "git://github.com/marzer/tomlplusplus.git;protocol=https;branch=master" 6SRC_URI = "git://github.com/marzer/tomlplusplus.git;protocol=https;branch=master \
7 file://run-ptest \
8"
7 9
8PV = "3.4.0" 10PV = "3.4.0"
9SRCREV = "30172438cee64926dc41fdd9c11fb3ba5b2ba9de" 11SRCREV = "30172438cee64926dc41fdd9c11fb3ba5b2ba9de"
@@ -11,4 +13,13 @@ S = "${WORKDIR}/git"
11 13
12DEPENDS = "cmake-native" 14DEPENDS = "cmake-native"
13 15
14inherit meson 16inherit meson ptest
17
18EXTRA_OEMESON += "-Dbuild_tests=${@bb.utils.contains("DISTRO_FEATURES", "ptest", "true", "false", d)} \
19"
20
21do_install_ptest () {
22 install -d ${D}${PTEST_PATH}/tests
23 cp ${B}/tests/tomlplusplus_odr_test ${D}${PTEST_PATH}/tests
24 cp ${B}/tests/tomlplusplus_tests ${D}${PTEST_PATH}/tests
25}