summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib/0001-Fix-build-error-with-input_event_sec-for-old-kernel.patch30
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib_1.21.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/tslib/tslib/0001-Fix-build-error-with-input_event_sec-for-old-kernel.patch b/meta-oe/recipes-graphics/tslib/tslib/0001-Fix-build-error-with-input_event_sec-for-old-kernel.patch
new file mode 100644
index 0000000000..ea8a9e5651
--- /dev/null
+++ b/meta-oe/recipes-graphics/tslib/tslib/0001-Fix-build-error-with-input_event_sec-for-old-kernel.patch
@@ -0,0 +1,30 @@
1From 050bf24c16e95f63a76e13156346a072035d45b4 Mon Sep 17 00:00:00 2001
2From: Evan Harvey <evanwork1234@gmail.com>
3Date: Thu, 19 Mar 2020 01:32:03 -0700
4Subject: [PATCH] Fix build error with input_event_sec for old kernel
5
6Upstream-Status: Backport [https://github.com/libts/tslib/commit/050bf24c16e95f63a76e13156346a072035d45b4]
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 tools/ts_uinput.c | 5 +++++
10 1 file changed, 5 insertions(+)
11
12diff --git a/tools/ts_uinput.c b/tools/ts_uinput.c
13index 1832a07..9c40bb3 100644
14--- a/tools/ts_uinput.c
15+++ b/tools/ts_uinput.c
16@@ -51,6 +51,11 @@
17 #include <linux/fb.h>
18 #endif
19
20+#ifndef input_event_sec
21+#define input_event_sec time.tv_sec
22+#define input_event_usec time.tv_usec
23+#endif
24+
25 #define RESET "\033[0m"
26 #define RED "\033[31m"
27 #define GREEN "\033[32m"
28--
292.26.2
30
diff --git a/meta-oe/recipes-graphics/tslib/tslib_1.21.bb b/meta-oe/recipes-graphics/tslib/tslib_1.21.bb
index bb28ee410c..76c4231441 100644
--- a/meta-oe/recipes-graphics/tslib/tslib_1.21.bb
+++ b/meta-oe/recipes-graphics/tslib/tslib_1.21.bb
@@ -15,6 +15,7 @@ LIC_FILES_CHKSUM = "\
15 15
16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \ 16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
17 file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch \ 17 file://0001-Fix-build-on-32bit-arches-with-64bit-time_t.patch \
18 file://0001-Fix-build-error-with-input_event_sec-for-old-kernel.patch \
18 file://ts.conf \ 19 file://ts.conf \
19 file://tslib.sh \ 20 file://tslib.sh \
20" 21"