summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-build-when-compiling-with-std-c23.patch26
-rw-r--r--meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-build-when-compiling-with-std-c23.patch b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-build-when-compiling-with-std-c23.patch
new file mode 100644
index 0000000000..aad1b10b52
--- /dev/null
+++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools/0001-Fix-build-when-compiling-with-std-c23.patch
@@ -0,0 +1,26 @@
1From 2a79621f58bf1c4bc0166ccc044fcf343fb66b44 Mon Sep 17 00:00:00 2001
2From: Rudi Heitbaum <rudi@heitbaum.com>
3Date: Wed, 20 Nov 2024 10:40:03 +1100
4Subject: [PATCH] Fix build when compiling with -std=c23
5
6Fixes the build when using gcc 15
7
8Upstream-Status: Submitted [https://github.com/vmware/open-vm-tools/pull/751]
9Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
10---
11 open-vm-tools/lib/lock/ul.c | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/open-vm-tools/lib/lock/ul.c b/open-vm-tools/lib/lock/ul.c
15index d376a98af..fc9fdb714 100644
16--- a/open-vm-tools/lib/lock/ul.c
17+++ b/open-vm-tools/lib/lock/ul.c
18@@ -29,7 +29,7 @@
19 static Bool mxInPanic = FALSE; // track when involved in a panic
20 static Bool mxUserCollectLockingTree = FALSE;
21
22-Bool (*MXUserTryAcquireForceFail)() = NULL;
23+Bool (*MXUserTryAcquireForceFail)(const char *) = NULL;
24
25 static MX_Rank (*MXUserMxCheckRank)(void) = NULL;
26 static void (*MXUserMxLockLister)(void) = NULL;
diff --git a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb
index d44709a64d..0288a59458 100644
--- a/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb
+++ b/meta-networking/recipes-support/open-vm-tools/open-vm-tools_12.5.0.bb
@@ -43,6 +43,7 @@ SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https;branch=stabl
43 file://0012-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \ 43 file://0012-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \
44 file://0013-open-vm-tools-Correct-include-path-for-poll.h.patch;patchdir=.. \ 44 file://0013-open-vm-tools-Correct-include-path-for-poll.h.patch;patchdir=.. \
45 file://0014-timeSync-Portable-way-to-print-64bit-time_t.patch;patchdir=.. \ 45 file://0014-timeSync-Portable-way-to-print-64bit-time_t.patch;patchdir=.. \
46 file://0001-Fix-build-when-compiling-with-std-c23.patch;patchdir=.. \
46 " 47 "
47 48
48UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)" 49UPSTREAM_CHECK_GITTAGREGEX = "stable-(?P<pver>\d+(\.\d+)+)"