diff options
-rw-r--r-- | meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb | 10 | ||||
-rw-r--r-- | meta-oe/recipes-support/glog/glog_0.3.5.bb | 9 | ||||
-rw-r--r-- | meta-oe/recipes-support/gperftools/gperftools_2.7.90.bb | 3 |
3 files changed, 16 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb index fabb45c88d..d5c6288cdf 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb | |||
@@ -129,8 +129,8 @@ RDEPENDS_packagegroup-meta-oe-devtools_remove_mips64el = "nodejs" | |||
129 | RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc = "android-tools breakpad uftrace lshw" | 129 | RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc = "android-tools breakpad uftrace lshw" |
130 | RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc64 = "android-tools uftrace lshw" | 130 | RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc64 = "android-tools uftrace lshw" |
131 | RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc64le = "android-tools uftrace lshw" | 131 | RDEPENDS_packagegroup-meta-oe-devtools_remove_powerpc64le = "android-tools uftrace lshw" |
132 | RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv64 = "nodejs uftrace lshw" | 132 | RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv64 = "breakpad ltrace nodejs uftrace lshw" |
133 | RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv32 = "nodejs uftrace lshw" | 133 | RDEPENDS_packagegroup-meta-oe-devtools_remove_riscv32 = "breakpad ltrace nodejs uftrace lshw" |
134 | 134 | ||
135 | RDEPENDS_packagegroup-meta-oe-extended ="\ | 135 | RDEPENDS_packagegroup-meta-oe-extended ="\ |
136 | byacc cfengine cfengine-masterfiles cmpi-bindings \ | 136 | byacc cfengine cfengine-masterfiles cmpi-bindings \ |
@@ -203,6 +203,9 @@ RDEPENDS_packagegroup-meta-oe-kernel_remove_libc-musl = "crash minicoredumper" | |||
203 | RDEPENDS_packagegroup-meta-oe-kernel_remove_mips64 = "crash" | 203 | RDEPENDS_packagegroup-meta-oe-kernel_remove_mips64 = "crash" |
204 | RDEPENDS_packagegroup-meta-oe-kernel_remove_mips64el = "crash" | 204 | RDEPENDS_packagegroup-meta-oe-kernel_remove_mips64el = "crash" |
205 | 205 | ||
206 | RDEPENDS_packagegroup-meta-oe-kernel_remove_riscv64 = "crash oprofile" | ||
207 | RDEPENDS_packagegroup-meta-oe-kernel_remove_riscv32 = "crash oprofile" | ||
208 | |||
206 | RDEPENDS_packagegroup-meta-oe-multimedia ="\ | 209 | RDEPENDS_packagegroup-meta-oe-multimedia ="\ |
207 | alsa-oss audiofile cdrkit id3lib \ | 210 | alsa-oss audiofile cdrkit id3lib \ |
208 | a2jmidid jack libass libburn libcdio libcdio-paranoia \ | 211 | a2jmidid jack libass libburn libcdio libcdio-paranoia \ |
@@ -304,6 +307,9 @@ RDEPENDS_packagegroup-meta-oe-ptest-packages = "\ | |||
304 | libee-ptest \ | 307 | libee-ptest \ |
305 | poco-ptest \ | 308 | poco-ptest \ |
306 | " | 309 | " |
310 | RDEPENDS_packagegroup-meta-oe-ptest-packages_remove_riscv64 = "oprofile-ptest" | ||
311 | RDEPENDS_packagegroup-meta-oe-ptest-packages_remove_riscv32 = "oprofile-ptest" | ||
312 | |||
307 | RDEPENDS_packagegroup-meta-oe-ptest-packages_append_x86 = "\ | 313 | RDEPENDS_packagegroup-meta-oe-ptest-packages_append_x86 = "\ |
308 | mcelog-ptest \ | 314 | mcelog-ptest \ |
309 | " | 315 | " |
diff --git a/meta-oe/recipes-support/glog/glog_0.3.5.bb b/meta-oe/recipes-support/glog/glog_0.3.5.bb index 70eef72057..9a8332836b 100644 --- a/meta-oe/recipes-support/glog/glog_0.3.5.bb +++ b/meta-oe/recipes-support/glog/glog_0.3.5.bb | |||
@@ -6,8 +6,6 @@ HOMEPAGE = "https://github.com/google/glog" | |||
6 | LICENSE = "BSD-3-Clause" | 6 | LICENSE = "BSD-3-Clause" |
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b" | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b" |
8 | 8 | ||
9 | DEPENDS = "libunwind" | ||
10 | |||
11 | SRC_URI = " \ | 9 | SRC_URI = " \ |
12 | git://github.com/google/glog.git;nobranch=1 \ | 10 | git://github.com/google/glog.git;nobranch=1 \ |
13 | file://0001-Rework-CMake-glog-VERSION-management.patch \ | 11 | file://0001-Rework-CMake-glog-VERSION-management.patch \ |
@@ -21,6 +19,9 @@ S = "${WORKDIR}/git" | |||
21 | 19 | ||
22 | inherit cmake | 20 | inherit cmake |
23 | 21 | ||
24 | RDEPENDS_${PN} += "libunwind" | 22 | PACKAGECONFIG ?= "shared unwind" |
23 | PACKAGECONFIG_remove_riscv64 = "unwind" | ||
24 | PACKAGECONFIG_remove_riscv32 = "unwind" | ||
25 | 25 | ||
26 | EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON" | 26 | PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind" |
27 | PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,," | ||
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.7.90.bb b/meta-oe/recipes-support/gperftools/gperftools_2.7.90.bb index 9dfb0d974f..e15133c1b9 100644 --- a/meta-oe/recipes-support/gperftools/gperftools_2.7.90.bb +++ b/meta-oe/recipes-support/gperftools/gperftools_2.7.90.bb | |||
@@ -20,6 +20,7 @@ S = "${WORKDIR}/git" | |||
20 | # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008 | 20 | # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008 |
21 | # Segmentation fault (core dumped) | 21 | # Segmentation fault (core dumped) |
22 | COMPATIBLE_HOST_mipsarch = "null" | 22 | COMPATIBLE_HOST_mipsarch = "null" |
23 | |||
23 | # Disable thumb1 | 24 | # Disable thumb1 |
24 | # {standard input}: Assembler messages: | 25 | # {standard input}: Assembler messages: |
25 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' | 26 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' |
@@ -29,6 +30,8 @@ ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm" | |||
29 | 30 | ||
30 | PACKAGECONFIG ?= "libunwind static" | 31 | PACKAGECONFIG ?= "libunwind static" |
31 | PACKAGECONFIG_remove_arm_libc-musl = "libunwind" | 32 | PACKAGECONFIG_remove_arm_libc-musl = "libunwind" |
33 | PACKAGECONFIG_remove_riscv64 = "libunwind" | ||
34 | PACKAGECONFIG_remove_riscv32 = "libunwind" | ||
32 | 35 | ||
33 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" | 36 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" |
34 | PACKAGECONFIG[static] = "--enable-static,--disable-static," | 37 | PACKAGECONFIG[static] = "--enable-static,--disable-static," |