diff options
-rw-r--r-- | meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch (renamed from meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch) | 24 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb | 3 |
2 files changed, 16 insertions, 11 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch index c6e9465ac3..04cef960fc 100644 --- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch +++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch | |||
@@ -1,30 +1,34 @@ | |||
1 | From 73fdc58ca4eb9e2f24d854b3af3a4e5daac5a33e Mon Sep 17 00:00:00 2001 | 1 | From ea683a0dbaa30a0bf101adb09a1a2531c7112c62 Mon Sep 17 00:00:00 2001 |
2 | From: Ting Liu <b28495@freescale.com> | 2 | From: Mingli Yu <Mingli.Yu@windriver.com> |
3 | Date: Fri, 22 Nov 2013 15:20:08 +0800 | 3 | Date: Mon, 27 Aug 2018 11:02:45 +0800 |
4 | Subject: [PATCH] use base_libdir instead of hardcoded /lib | 4 | Subject: [PATCH] src/Makefile: use libdir instead of hardcoded /lib |
5 | 5 | ||
6 | Upstream Status: Inappropriate [configuration] | 6 | use libdir instead of hardcoded /lib |
7 | 7 | ||
8 | Signed-off-by: Ting Liu <b28495@freescale.com> | 8 | Upstream-Status: Inappropriate [configuration] |
9 | 9 | ||
10 | Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> | ||
10 | --- | 11 | --- |
11 | src/Makefile | 4 ++-- | 12 | src/Makefile | 4 ++-- |
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | 13 | 1 file changed, 2 insertions(+), 2 deletions(-) |
13 | 14 | ||
14 | diff --git a/src/Makefile b/src/Makefile | 15 | diff --git a/src/Makefile b/src/Makefile |
15 | index c7a8c79..c7e4e3c 100644 | 16 | index 4678d54..b73ddb6 100644 |
16 | --- a/src/Makefile | 17 | --- a/src/Makefile |
17 | +++ b/src/Makefile | 18 | +++ b/src/Makefile |
18 | @@ -143,10 +143,10 @@ install-target: | 19 | @@ -141,10 +141,10 @@ install-target: |
19 | if [ ! -d $(BASE) ]; then mkdir $(BASE); fi | 20 | if [ ! -d $(BASE) ]; then mkdir $(BASE); fi |
20 | if [ ! -d $(BASE)/bin ]; then mkdir $(BASE)/bin; fi | 21 | if [ ! -d $(BASE)/bin ]; then mkdir $(BASE)/bin; fi |
21 | if [ ! -d $(BASE)/include ]; then mkdir $(BASE)/include; fi | 22 | if [ ! -d $(BASE)/include ]; then mkdir $(BASE)/include; fi |
22 | - if [ ! -d $(BASE)/lib ]; then mkdir $(BASE)/lib; fi | 23 | - if [ ! -d $(BASE)/lib ]; then mkdir $(BASE)/lib; fi |
23 | + if [ ! -d $(BASE)$(base_libdir) ]; then mkdir $(BASE)$(base_libdir); fi | 24 | + if [ ! -d $(DESTDIR)$(libdir) ]; then mkdir $(DESTDIR)$(libdir); fi |
24 | cp $(EXES) $(BASE)/bin | 25 | cp $(EXES) $(BASE)/bin |
25 | cp $(INCS) $(BASE)/include | 26 | cp $(INCS) $(BASE)/include |
26 | - cp $O/lmbench.a $(BASE)/lib/libmbench.a | 27 | - cp $O/lmbench.a $(BASE)/lib/libmbench.a |
27 | + cp $O/lmbench.a $(BASE)$(base_libdir) | 28 | + cp $O/lmbench.a $(DESTDIR)$(libdir)/libmbench.a |
28 | cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install | 29 | cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install |
29 | 30 | ||
30 | 31 | ||
32 | -- | ||
33 | 2.7.4 | ||
34 | |||
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb index 593b62f013..8e6e803a8d 100644 --- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb +++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb | |||
@@ -19,13 +19,13 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \ | |||
19 | file://update-results-script.patch \ | 19 | file://update-results-script.patch \ |
20 | file://obey-ranlib.patch \ | 20 | file://obey-ranlib.patch \ |
21 | file://update-config-script.patch \ | 21 | file://update-config-script.patch \ |
22 | file://use-base_libdir-instead-of-hardcoded-lib.patch \ | ||
23 | file://lmbench_result_html_report.patch \ | 22 | file://lmbench_result_html_report.patch \ |
24 | file://fix-lmbench-memory-check-failure.patch \ | 23 | file://fix-lmbench-memory-check-failure.patch \ |
25 | file://0001-avoid-gcc-optimize-away-the-loops.patch \ | 24 | file://0001-avoid-gcc-optimize-away-the-loops.patch \ |
26 | file://0001-lat_http.c-Add-printf-format.patch \ | 25 | file://0001-lat_http.c-Add-printf-format.patch \ |
27 | file://0001-Check-for-musl-define-guard-before-redefining-sockle.patch \ | 26 | file://0001-Check-for-musl-define-guard-before-redefining-sockle.patch \ |
28 | file://0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch \ | 27 | file://0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch \ |
28 | file://0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch \ | ||
29 | " | 29 | " |
30 | SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" | 30 | SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" |
31 | SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" | 31 | SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" |
@@ -66,6 +66,7 @@ do_install () { | |||
66 | fi | 66 | fi |
67 | 67 | ||
68 | oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \ | 68 | oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \ |
69 | DESTDIR="${D}" \ | ||
69 | -C src install | 70 | -C src install |
70 | mv ${D}${bindir}/line ${D}${bindir}/lm_line | 71 | mv ${D}${bindir}/line ${D}${bindir}/lm_line |
71 | install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/ | 72 | install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/ |