diff options
-rw-r--r-- | file | 0 | ||||
-rw-r--r-- | meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb | 29 |
3 files changed, 60 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch new file mode 100644 index 0000000000..d4c7765697 --- /dev/null +++ b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From a47ca75702318ff43446c70120f7aacde4ccee1b Mon Sep 17 00:00:00 2001 | ||
2 | From: Eero Aaltonen <eero.aaltonen@vaisala.com> | ||
3 | Date: Thu, 20 Jun 2019 16:21:20 +0300 | ||
4 | Subject: [PATCH] Set library VERSION and SOVERSION | ||
5 | |||
6 | With soversion and version specified, `install` target will install the | ||
7 | library with the specified version and also create the proper symlink. | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/docopt/docopt.cpp/pull/112] | ||
10 | but unlikely to be merged soon as it is a duplicate of | ||
11 | [https://github.com/docopt/docopt.cpp/pull/112] which has been **Open** | ||
12 | since 2016-12-08. | ||
13 | --- | ||
14 | CMakeLists.txt | 4 ++++ | ||
15 | 1 file changed, 4 insertions(+) | ||
16 | |||
17 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
18 | index 23da468..feff32e 100644 | ||
19 | --- a/CMakeLists.txt | ||
20 | +++ b/CMakeLists.txt | ||
21 | @@ -50,6 +50,10 @@ else() | ||
22 | set_target_properties(docopt_o PROPERTIES POSITION_INDEPENDENT_CODE TRUE) | ||
23 | |||
24 | add_library(docopt SHARED $<TARGET_OBJECTS:docopt_o>) | ||
25 | + set_target_properties(docopt PROPERTIES | ||
26 | + VERSION ${PROJECT_VERSION} | ||
27 | + SOVERSION ${PROJECT_VERSION_MAJOR} | ||
28 | + ) | ||
29 | add_library(docopt_s STATIC $<TARGET_OBJECTS:docopt_o>) | ||
30 | endif() | ||
31 | |||
diff --git a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb new file mode 100644 index 0000000000..95c60617cc --- /dev/null +++ b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SUMMARY = "C++11 port of docopt command-line interface description language and parser" | ||
2 | |||
3 | DESCRIPTION = "docopt is library that lets you define a command line interface with the \ | ||
4 | utility argument syntax that has been used by command line utilities for \ | ||
5 | decades (formalized in POSIX.1-2017). From the description, docopt \ | ||
6 | automatically generates a parser for the command line arguments." | ||
7 | |||
8 | HOMEPAGE = "https://github.com/docopt/docopt.cpp" | ||
9 | |||
10 | LICENSE = "MIT | BSL-1.0" | ||
11 | LIC_FILES_CHKSUM = "\ | ||
12 | file://LICENSE-Boost-1.0;md5=e4224ccaecb14d942c71d31bef20d78c \ | ||
13 | file://LICENSE-MIT;md5=4b242fd9ef20207e18286d73da8a6677 \ | ||
14 | " | ||
15 | |||
16 | DEPENDS = "boost" | ||
17 | SRCREV = "3dd23e3280f213bacefdf5fcb04857bf52e90917" | ||
18 | PV = "0.6.2+git${SRCPV}" | ||
19 | |||
20 | SRC_URI = "\ | ||
21 | git://git@github.com/docopt/docopt.cpp.git;protocol=ssh \ | ||
22 | file://0001-Set-library-VERSION-and-SOVERSION.patch \ | ||
23 | " | ||
24 | |||
25 | S = "${WORKDIR}/git" | ||
26 | |||
27 | inherit cmake gitpkgv | ||
28 | |||
29 | PKGV = "0.6.2+git${GITPKGV}" | ||