summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--file0
-rw-r--r--meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch31
-rw-r--r--meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb29
3 files changed, 60 insertions, 0 deletions
diff --git a/file b/file
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/file
diff --git a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch
new file mode 100644
index 0000000000..d4c7765697
--- /dev/null
+++ b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp/0001-Set-library-VERSION-and-SOVERSION.patch
@@ -0,0 +1,31 @@
1From a47ca75702318ff43446c70120f7aacde4ccee1b Mon Sep 17 00:00:00 2001
2From: Eero Aaltonen <eero.aaltonen@vaisala.com>
3Date: Thu, 20 Jun 2019 16:21:20 +0300
4Subject: [PATCH] Set library VERSION and SOVERSION
5
6With soversion and version specified, `install` target will install the
7library with the specified version and also create the proper symlink.
8
9Upstream-Status: Submitted [https://github.com/docopt/docopt.cpp/pull/112]
10but unlikely to be merged soon as it is a duplicate of
11[https://github.com/docopt/docopt.cpp/pull/112] which has been **Open**
12since 2016-12-08.
13---
14 CMakeLists.txt | 4 ++++
15 1 file changed, 4 insertions(+)
16
17diff --git a/CMakeLists.txt b/CMakeLists.txt
18index 23da468..feff32e 100644
19--- a/CMakeLists.txt
20+++ b/CMakeLists.txt
21@@ -50,6 +50,10 @@ else()
22 set_target_properties(docopt_o PROPERTIES POSITION_INDEPENDENT_CODE TRUE)
23
24 add_library(docopt SHARED $<TARGET_OBJECTS:docopt_o>)
25+ set_target_properties(docopt PROPERTIES
26+ VERSION ${PROJECT_VERSION}
27+ SOVERSION ${PROJECT_VERSION_MAJOR}
28+ )
29 add_library(docopt_s STATIC $<TARGET_OBJECTS:docopt_o>)
30 endif()
31
diff --git a/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
new file mode 100644
index 0000000000..95c60617cc
--- /dev/null
+++ b/meta-oe/recipes-extended/docopt.cpp/docopt.cpp_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "C++11 port of docopt command-line interface description language and parser"
2
3DESCRIPTION = "docopt is library that lets you define a command line interface with the \
4utility argument syntax that has been used by command line utilities for \
5decades (formalized in POSIX.1-2017). From the description, docopt \
6automatically generates a parser for the command line arguments."
7
8HOMEPAGE = "https://github.com/docopt/docopt.cpp"
9
10LICENSE = "MIT | BSL-1.0"
11LIC_FILES_CHKSUM = "\
12 file://LICENSE-Boost-1.0;md5=e4224ccaecb14d942c71d31bef20d78c \
13 file://LICENSE-MIT;md5=4b242fd9ef20207e18286d73da8a6677 \
14"
15
16DEPENDS = "boost"
17SRCREV = "3dd23e3280f213bacefdf5fcb04857bf52e90917"
18PV = "0.6.2+git${SRCPV}"
19
20SRC_URI = "\
21 git://git@github.com/docopt/docopt.cpp.git;protocol=ssh \
22 file://0001-Set-library-VERSION-and-SOVERSION.patch \
23"
24
25S = "${WORKDIR}/git"
26
27inherit cmake gitpkgv
28
29PKGV = "0.6.2+git${GITPKGV}"