summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch32
-rw-r--r--meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-musl-s-ERANGE-mapping.patch29
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2023.1.bb (renamed from meta-oe/recipes-extended/ostree/ostree_2022.7.bb)14
3 files changed, 5 insertions, 70 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch b/meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch
deleted file mode 100644
index 1502f1d4fd..0000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 6aef666a2911c15b31efeed08d89fe9997d89e04 Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Sat, 31 Dec 2022 11:11:14 +0000
4Subject: [PATCH] lib/repo-checkout: Add ALLPERMS for musl
5
6ALLPERMS is glibc specific, add a definition for musl.
7
8Upstream-Status: Submitted [https://github.com/ostreedev/ostree/pull/2797]
9Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
10---
11 src/libostree/ostree-core-private.h | 5 +++++
12 1 file changed, 5 insertions(+)
13
14diff --git a/src/libostree/ostree-core-private.h b/src/libostree/ostree-core-private.h
15index 2bd2f9848718..48b2b8ab307f 100644
16--- a/src/libostree/ostree-core-private.h
17+++ b/src/libostree/ostree-core-private.h
18@@ -34,6 +34,11 @@ G_BEGIN_DECLS
19 #define DEFAULT_DIRECTORY_MODE 0775
20 #define DEFAULT_REGFILE_MODE 0660
21
22+/* This exists in glibc's sys/stat.h, but not on musl */
23+#ifndef ALLPERMS
24+#define ALLPERMS (S_ISUID|S_ISGID|S_ISVTX|S_IRWXU|S_IRWXG|S_IRWXO)
25+#endif
26+
27 /* This file contains private implementation data format definitions
28 * read by multiple implementation .c files.
29 */
30--
312.39.0
32
diff --git a/meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-musl-s-ERANGE-mapping.patch b/meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-musl-s-ERANGE-mapping.patch
deleted file mode 100644
index d0a8447e3d..0000000000
--- a/meta-oe/recipes-extended/ostree/ostree/0001-tests-Handle-musl-s-ERANGE-mapping.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From bd182584a1e2f820493d9db689598a20c5700ba5 Mon Sep 17 00:00:00 2001
2From: Alex Kiernan <alex.kiernan@gmail.com>
3Date: Mon, 2 Jan 2023 10:37:49 +0000
4Subject: [PATCH] tests: Handle musl's ERANGE mapping
5
6musl uses "Result not representable" for ERANGE, support this in
7addition to glibc's "Numerical result out of range".
8
9Upstream-Status: Backport [https://github.com/ostreedev/ostree/commit/2d4ee168d7eae0afcce356a3f8135294e6d7fe6f]
10Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
11---
12 tests/test-commit-timestamp.sh | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/tests/test-commit-timestamp.sh b/tests/test-commit-timestamp.sh
16index 0688c63a4bdb..de105b768a9c 100755
17--- a/tests/test-commit-timestamp.sh
18+++ b/tests/test-commit-timestamp.sh
19@@ -40,6 +40,6 @@ fi
20 ${CMD_PREFIX} ostree --repo=./testrepo show env > show-env.txt
21 rm -rf testrepo testrepo-files
22 assert_file_has_content_literal commit-invalid.txt 'Failed to convert SOURCE_DATE_EPOCH'
23-assert_file_has_content_literal commit-overflowing.txt 'Parsing SOURCE_DATE_EPOCH: Numerical result out of range'
24+assert_file_has_content commit-overflowing.txt 'Parsing SOURCE_DATE_EPOCH: \(Numerical result out of range\|Result not representable\)'
25 assert_file_has_content_literal show-env.txt 'Date: 2009-02-13 23:31:30 +0000'
26 echo "ok commit with env timestamp"
27--
282.39.0
29
diff --git a/meta-oe/recipes-extended/ostree/ostree_2022.7.bb b/meta-oe/recipes-extended/ostree/ostree_2023.1.bb
index 61e208b3b7..bd566e1c28 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2022.7.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2023.1.bb
@@ -17,19 +17,16 @@ DEPENDS = " \
17 bison-native \ 17 bison-native \
18" 18"
19 19
20GITHUB_BASE_URI = "https://github.com/ostreedev/ostree/releases"
20SRC_URI = " \ 21SRC_URI = " \
21 https://github.com/ostreedev/ostree/releases/download/v${PV}/libostree-${PV}.tar.xz \ 22 ${GITHUB_BASE_URI}/download/v${PV}/libostree-${PV}.tar.xz \
22 file://0001-lib-repo-checkout-Add-ALLPERMS-for-musl.patch \
23 file://0001-tests-Handle-musl-s-ERANGE-mapping.patch \
24 file://run-ptest \ 23 file://run-ptest \
25" 24"
26SRC_URI[sha256sum] = "8be2a9261c94e8b9ec4113380ffc480f8598245fb321a009bad4fae4b822411f" 25SRC_URI[sha256sum] = "dd792b167693a1971c9f6e3168013d906ac035100ff6c719a3b322eb44b96f55"
27
28UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+\.\d+)"
29 26
30S = "${WORKDIR}/libostree-${PV}" 27S = "${WORKDIR}/libostree-${PV}"
31 28
32inherit autotools bash-completion gobject-introspection gtk-doc manpages pkgconfig ptest-gnome systemd 29inherit autotools bash-completion gobject-introspection github-releases gtk-doc manpages pkgconfig ptest-gnome systemd
33 30
34# Workaround compile failure: 31# Workaround compile failure:
35# |../git/src/libotutil/zbase32.c:37:1: error: function returns an aggregate [-Werror=aggregate-return] 32# |../git/src/libotutil/zbase32.c:37:1: error: function returns an aggregate [-Werror=aggregate-return]
@@ -183,7 +180,7 @@ RDEPENDS:${PN}:class-target = " \
183# ostree-trivial-httpd (requires soup - note soup and curl can coexist) 180# ostree-trivial-httpd (requires soup - note soup and curl can coexist)
184# overlayfs in your kernel 181# overlayfs in your kernel
185# busybox built statically 182# busybox built statically
186# C.UTF-8 locale available 183# C.UTF-8 locale available (default)
187# Sufficient disk space/RAM (e.g. core-image-sato-sdk) 184# Sufficient disk space/RAM (e.g. core-image-sato-sdk)
188# 185#
189# Something like this in your local.conf: 186# Something like this in your local.conf:
@@ -191,7 +188,6 @@ RDEPENDS:${PN}:class-target = " \
191# PACKAGECONFIG:append:pn-ostree = " static soup" 188# PACKAGECONFIG:append:pn-ostree = " static soup"
192# KERNEL_EXTRA_FEATURES:append = " features/overlayfs/overlayfs.scc" 189# KERNEL_EXTRA_FEATURES:append = " features/overlayfs/overlayfs.scc"
193# TARGET_CFLAGS:append:pn-busybox = " -static" 190# TARGET_CFLAGS:append:pn-busybox = " -static"
194# IMAGE_LINGUAS:append:libc-glibc = " c"
195# 191#
196RDEPENDS:${PN}-ptest += " \ 192RDEPENDS:${PN}-ptest += " \
197 attr \ 193 attr \