summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb-native_11.4.4.bb (renamed from meta-oe/recipes-dbs/mysql/mariadb-native_10.11.10.bb)0
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb.inc5
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch14
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-Ensure-compatibility-with-ARMv9-by-updating-.arch-di.patch13
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-Fix-library-LZ4-lookup.patch10
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-aio_linux-Check-if-syscall-exists-before-using-it.patch15
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-innobase-Define-__NR_futex-if-it-does-not-exist.patch7
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch11
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/configure.cmake-fix-valgrind.patch7
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/cross-compiling.patch9
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/fix-arm-atomic.patch9
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/lfs64.patch10
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/mm_malloc.patch10
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/ssize_t.patch11
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/support-files-CMakeLists.txt-fix-do_populate_sysroot.patch7
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/sys_futex.patch12
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb_11.4.4.bb (renamed from meta-oe/recipes-dbs/mysql/mariadb_10.11.10.bb)0
17 files changed, 80 insertions, 70 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.10.bb b/meta-oe/recipes-dbs/mysql/mariadb-native_11.4.4.bb
index 578357b480..578357b480 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.10.bb
+++ b/meta-oe/recipes-dbs/mysql/mariadb-native_11.4.4.bb
diff --git a/meta-oe/recipes-dbs/mysql/mariadb.inc b/meta-oe/recipes-dbs/mysql/mariadb.inc
index ae782e78af..dae41d89aa 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb.inc
+++ b/meta-oe/recipes-dbs/mysql/mariadb.inc
@@ -25,7 +25,7 @@ SRC_URI = "https://archive.mariadb.org/${BP}/source/${BP}.tar.gz \
25 file://0001-Add-missing-includes-cstdint-and-cstdio.patch \ 25 file://0001-Add-missing-includes-cstdint-and-cstdio.patch \
26 file://0001-Ensure-compatibility-with-ARMv9-by-updating-.arch-di.patch \ 26 file://0001-Ensure-compatibility-with-ARMv9-by-updating-.arch-di.patch \
27 " 27 "
28SRC_URI[sha256sum] = "b06a74650b83a16aa9ab098984482b028e75b000674b11ff288772c619a6f022" 28SRC_URI[sha256sum] = "96fbd2e6e93fb7e8b373eea75d85b6fea57c0e111a02090cbbefed52599dc77b"
29 29
30UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/tags" 30UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/tags"
31 31
@@ -98,6 +98,9 @@ EXTRA_OECMAKE = "-DWITH_EMBEDDED_SERVER=ON \
98 -DCAT_EXECUTABLE=`which cat` \ 98 -DCAT_EXECUTABLE=`which cat` \
99 -DSTACK_DIRECTION=1 \ 99 -DSTACK_DIRECTION=1 \
100 -DHAVE_SYSTEM_LIBFMT_EXITCODE=0 \ 100 -DHAVE_SYSTEM_LIBFMT_EXITCODE=0 \
101 -DLSTAT_FOLLOWS_SLASHED_SYMLINK_EXITCODE=0 \
102 -DSTAT_EMPTY_STRING_BUG_EXITCODE=0 \
103 -DMASK_LONGDOUBLE_EXITCODE=0 \
101 -DCMAKE_AR:FILEPATH=${AR}" 104 -DCMAKE_AR:FILEPATH=${AR}"
102 105
103 106
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch
index f8ccb998be..08e73424d1 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-Add-missing-includes-cstdint-and-cstdio.patch
@@ -1,4 +1,4 @@
1From 68100b1f2243304289b9a9a35e8fb0e1bb0cf70f Mon Sep 17 00:00:00 2001 1From ef47f8f41722b90a86ace86f0f509b4775c2f725 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 24 Jan 2023 21:40:43 -0800 3Date: Tue, 24 Jan 2023 21:40:43 -0800
4Subject: [PATCH] Add missing includes <cstdint> and <cstdio> 4Subject: [PATCH] Add missing includes <cstdint> and <cstdio>
@@ -66,19 +66,15 @@ index 6db11cc9..c26b6a21 100644
66 #include "rocksdb/slice_transform.h" 66 #include "rocksdb/slice_transform.h"
67 #include "rocksdb/slice.h" 67 #include "rocksdb/slice.h"
68 #include "util/string_util.h" 68 #include "util/string_util.h"
69 69diff --git a/storage/rocksdb/rocksdb/util/string_util.h b/storage/rocksdb/rocksdb/util/string_util.h
70diff --git a/util/string_util.h b/util/string_util.h 70index a761be66..064d059f 100644
71index 55d106fff02..11178fd1d7b 100644
72--- a/storage/rocksdb/rocksdb/util/string_util.h 71--- a/storage/rocksdb/rocksdb/util/string_util.h
73+++ b/storage/rocksdb/rocksdb/util/string_util.h 72+++ b/storage/rocksdb/rocksdb/util/string_util.h
74@@ -6,6 +6,7 @@ 73@@ -6,6 +6,7 @@
75 74
76 #pragma once 75 #pragma once
77 76
78+#include <cstdint> 77+#include <cstdint>
79 #include <sstream> 78 #include <sstream>
80 #include <string> 79 #include <string>
81 #include <unordered_map> 80 #include <unordered_map>
82--
832.25.1
84
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Ensure-compatibility-with-ARMv9-by-updating-.arch-di.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Ensure-compatibility-with-ARMv9-by-updating-.arch-di.patch
index 11d1724768..2a1c74a68c 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-Ensure-compatibility-with-ARMv9-by-updating-.arch-di.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-Ensure-compatibility-with-ARMv9-by-updating-.arch-di.patch
@@ -1,4 +1,4 @@
1From 1b0c05b53ede7decb3f4dfe6187f9573cab5e0ab Mon Sep 17 00:00:00 2001 1From 0b1ba174bd5148c0675b335fcebde767a56e10bb Mon Sep 17 00:00:00 2001
2From: Ruiqiang Hao <Ruiqiang.Hao@windriver.com> 2From: Ruiqiang Hao <Ruiqiang.Hao@windriver.com>
3Date: Mon, 2 Dec 2024 02:18:46 +0000 3Date: Mon, 2 Dec 2024 02:18:46 +0000
4Subject: [PATCH] Ensure compatibility with ARMv9 by updating .arch directive 4Subject: [PATCH] Ensure compatibility with ARMv9 by updating .arch directive
@@ -19,11 +19,11 @@ Upstream-Status: Submitted
19 19
20Signed-off-by: Ruiqiang Hao <Ruiqiang.Hao@windriver.com> 20Signed-off-by: Ruiqiang Hao <Ruiqiang.Hao@windriver.com>
21--- 21---
22 storage/innobase/sync/cache.cc | 2 +- 22 storage/innobase/sync/cache.cc | 5 +++++
23 1 file changed, 1 insertion(+), 1 deletion(-) 23 1 file changed, 5 insertions(+)
24 24
25diff --git a/storage/innobase/sync/cache.cc b/storage/innobase/sync/cache.cc 25diff --git a/storage/innobase/sync/cache.cc b/storage/innobase/sync/cache.cc
26index 43d642d05b5..af2d1f3d221 100644 26index 43d642d0..c5e67709 100644
27--- a/storage/innobase/sync/cache.cc 27--- a/storage/innobase/sync/cache.cc
28+++ b/storage/innobase/sync/cache.cc 28+++ b/storage/innobase/sync/cache.cc
29@@ -82,7 +82,12 @@ static void pmem_cvap(const void* buf, size_t size) 29@@ -82,7 +82,12 @@ static void pmem_cvap(const void* buf, size_t size)
@@ -38,7 +38,4 @@ index 43d642d05b5..af2d1f3d221 100644
38+ 38+
39 __asm__ __volatile__("dmb ishst" ::: "memory"); 39 __asm__ __volatile__("dmb ishst" ::: "memory");
40 } 40 }
41 41
42--
432.43.0
44
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Fix-library-LZ4-lookup.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Fix-library-LZ4-lookup.patch
index d8671b76b0..8105d3d785 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-Fix-library-LZ4-lookup.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-Fix-library-LZ4-lookup.patch
@@ -1,18 +1,17 @@
1From f15fbdf1244ca9ce01c5507660a86d685ed88bcf Mon Sep 17 00:00:00 2001 1From 2e64c0c22f630cbc301d385e46021853116f9c75 Mon Sep 17 00:00:00 2001
2From: Sumit Garg <sumit.garg@linaro.org> 2From: Sumit Garg <sumit.garg@linaro.org>
3Date: Mon, 21 Mar 2022 15:08:40 +0800 3Date: Mon, 21 Mar 2022 15:08:40 +0800
4Subject: [PATCH] Fix library LZ4 lookup. 4Subject: [PATCH] Fix library LZ4 lookup.
5 5
6Upstream-Status: Pending
6Signed-off-by: Sumit Garg <sumit.garg@linaro.org> 7Signed-off-by: Sumit Garg <sumit.garg@linaro.org>
7Signed-off-by: Mingli Yu <mingli.yu@windriver.com> 8Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
8--- 9---
9Upstream-Status: Pending
10
11 cmake/FindLZ4.cmake | 9 +++++++-- 10 cmake/FindLZ4.cmake | 9 +++++++--
12 1 file changed, 7 insertions(+), 2 deletions(-) 11 1 file changed, 7 insertions(+), 2 deletions(-)
13 12
14diff --git a/cmake/FindLZ4.cmake b/cmake/FindLZ4.cmake 13diff --git a/cmake/FindLZ4.cmake b/cmake/FindLZ4.cmake
15index eebd859..094241c 100644 14index eebd8596..094241ce 100644
16--- a/cmake/FindLZ4.cmake 15--- a/cmake/FindLZ4.cmake
17+++ b/cmake/FindLZ4.cmake 16+++ b/cmake/FindLZ4.cmake
18@@ -1,5 +1,10 @@ 17@@ -1,5 +1,10 @@
@@ -28,6 +27,3 @@ index eebd859..094241c 100644
28 27
29 if(LZ4_INCLUDE_DIRS AND EXISTS "${LZ4_INCLUDE_DIRS}/lz4.h") 28 if(LZ4_INCLUDE_DIRS AND EXISTS "${LZ4_INCLUDE_DIRS}/lz4.h")
30 file(STRINGS "${LZ4_INCLUDE_DIRS}/lz4.h" LZ4_H REGEX "^#define LZ4_VERSION_[MR]") 29 file(STRINGS "${LZ4_INCLUDE_DIRS}/lz4.h" LZ4_H REGEX "^#define LZ4_VERSION_[MR]")
31--
322.25.1
33
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-aio_linux-Check-if-syscall-exists-before-using-it.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-aio_linux-Check-if-syscall-exists-before-using-it.patch
index aba9b9d966..eddfdaaf77 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-aio_linux-Check-if-syscall-exists-before-using-it.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-aio_linux-Check-if-syscall-exists-before-using-it.patch
@@ -1,4 +1,4 @@
1From 0a3222338efc108c831fbdd719a47d35f4b0adcd Mon Sep 17 00:00:00 2001 1From f9f019049a9bb09471e8303d4510afae07f225c8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 18 Aug 2021 06:49:25 +0000 3Date: Wed, 18 Aug 2021 06:49:25 +0000
4Subject: [PATCH] aio_linux: Check if syscall exists before using it 4Subject: [PATCH] aio_linux: Check if syscall exists before using it
@@ -10,19 +10,17 @@ tpool/aio_linux.cc:63:20: error: '__NR_io_getevents' was not declared in this sc
10 | ^~~~~~~~~~~~~~~~~ 10 | ^~~~~~~~~~~~~~~~~
11 | io_getevents 11 | io_getevents
12 12
13Upstream-Staus: Pending 13Upstream-Status: Pending
14Signed-off-by: Khem Raj <raj.khem@gmail.com> 14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15--- 15---
16Upstream-Status: Pending
17
18 tpool/aio_linux.cc | 4 ++++ 16 tpool/aio_linux.cc | 4 ++++
19 1 file changed, 4 insertions(+) 17 1 file changed, 4 insertions(+)
20 18
21diff --git a/tpool/aio_linux.cc b/tpool/aio_linux.cc 19diff --git a/tpool/aio_linux.cc b/tpool/aio_linux.cc
22index 4abc213..da75411 100644 20index 507c6b92..a6adf1af 100644
23--- a/tpool/aio_linux.cc 21--- a/tpool/aio_linux.cc
24+++ b/tpool/aio_linux.cc 22+++ b/tpool/aio_linux.cc
25@@ -58,6 +58,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02111 - 1301 USA*/ 23@@ -59,6 +59,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02111 - 1301 USA*/
26 */ 24 */
27 static int my_getevents(io_context_t ctx, long min_nr, long nr, io_event *ev) 25 static int my_getevents(io_context_t ctx, long min_nr, long nr, io_event *ev)
28 { 26 {
@@ -30,7 +28,7 @@ index 4abc213..da75411 100644
30 int saved_errno= errno; 28 int saved_errno= errno;
31 int ret= syscall(__NR_io_getevents, reinterpret_cast<long>(ctx), 29 int ret= syscall(__NR_io_getevents, reinterpret_cast<long>(ctx),
32 min_nr, nr, ev, 0); 30 min_nr, nr, ev, 0);
33@@ -67,6 +68,9 @@ static int my_getevents(io_context_t ctx, long min_nr, long nr, io_event *ev) 31@@ -68,6 +69,9 @@ static int my_getevents(io_context_t ctx, long min_nr, long nr, io_event *ev)
34 errno= saved_errno; 32 errno= saved_errno;
35 } 33 }
36 return ret; 34 return ret;
@@ -40,6 +38,3 @@ index 4abc213..da75411 100644
40 } 38 }
41 39
42 40
43--
442.29.2
45
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-innobase-Define-__NR_futex-if-it-does-not-exist.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-innobase-Define-__NR_futex-if-it-does-not-exist.patch
index 0a2eed44f4..bfcd45b64b 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-innobase-Define-__NR_futex-if-it-does-not-exist.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-innobase-Define-__NR_futex-if-it-does-not-exist.patch
@@ -1,4 +1,4 @@
1From d611f78198dee64bb6a05933d200b544e2510b76 Mon Sep 17 00:00:00 2001 1From 3a29c2f7afe10bf0bc0529b5d9ea44866946ac5a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 14 Nov 2020 14:37:13 -0800 3Date: Sat, 14 Nov 2020 14:37:13 -0800
4Subject: [PATCH] innobase: Define __NR_futex if it does not exist 4Subject: [PATCH] innobase: Define __NR_futex if it does not exist
@@ -19,7 +19,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
19 1 file changed, 3 insertions(+) 19 1 file changed, 3 insertions(+)
20 20
21diff --git a/storage/innobase/log/log0sync.cc b/storage/innobase/log/log0sync.cc 21diff --git a/storage/innobase/log/log0sync.cc b/storage/innobase/log/log0sync.cc
22index 7799e605..4fab8f74 100644 22index 0de283ca..265ab691 100644
23--- a/storage/innobase/log/log0sync.cc 23--- a/storage/innobase/log/log0sync.cc
24+++ b/storage/innobase/log/log0sync.cc 24+++ b/storage/innobase/log/log0sync.cc
25@@ -66,6 +66,9 @@ Note that if write operation is very fast, a) or b) can be fine as alternative. 25@@ -66,6 +66,9 @@ Note that if write operation is very fast, a) or b) can be fine as alternative.
@@ -32,6 +32,3 @@ index 7799e605..4fab8f74 100644
32 #endif 32 #endif
33 33
34 #include <atomic> 34 #include <atomic>
35--
362.29.2
37
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch
index 456a2bad64..1475bb1a51 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch
@@ -1,4 +1,4 @@
1From f92f657973997df30afdb0032c88ad3a14ead46b Mon Sep 17 00:00:00 2001 1From 360d41c1dd2d28d5102d66179095cedacaf5dc3a Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 23 Sep 2022 15:48:21 +0800 3Date: Fri, 23 Sep 2022 15:48:21 +0800
4Subject: [PATCH] sql/CMakeLists.txt: fix gen_lex_hash not found 4Subject: [PATCH] sql/CMakeLists.txt: fix gen_lex_hash not found
@@ -15,10 +15,10 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
15 1 file changed, 22 insertions(+), 8 deletions(-) 15 1 file changed, 22 insertions(+), 8 deletions(-)
16 16
17diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt 17diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
18index 241b482..27a3991 100644 18index 0195555e..507136cb 100644
19--- a/sql/CMakeLists.txt 19--- a/sql/CMakeLists.txt
20+++ b/sql/CMakeLists.txt 20+++ b/sql/CMakeLists.txt
21@@ -60,11 +60,18 @@ ${CMAKE_BINARY_DIR}/sql 21@@ -64,11 +64,18 @@ ${CMAKE_BINARY_DIR}/sql
22 ${CMAKE_SOURCE_DIR}/tpool 22 ${CMAKE_SOURCE_DIR}/tpool
23 ) 23 )
24 24
@@ -41,7 +41,7 @@ index 241b482..27a3991 100644
41 41
42 FIND_PACKAGE(BISON 2.4) 42 FIND_PACKAGE(BISON 2.4)
43 43
44@@ -372,11 +379,18 @@ IF(NOT CMAKE_CROSSCOMPILING OR DEFINED CMAKE_CROSSCOMPILING_EMULATOR) 44@@ -405,11 +412,18 @@ IF(NOT CMAKE_CROSSCOMPILING OR DEFINED CMAKE_CROSSCOMPILING_EMULATOR)
45 ADD_EXECUTABLE(gen_lex_hash gen_lex_hash.cc) 45 ADD_EXECUTABLE(gen_lex_hash gen_lex_hash.cc)
46 ENDIF() 46 ENDIF()
47 47
@@ -64,6 +64,3 @@ index 241b482..27a3991 100644
64 64
65 MYSQL_ADD_EXECUTABLE(mariadb-tzinfo-to-sql tztime.cc) 65 MYSQL_ADD_EXECUTABLE(mariadb-tzinfo-to-sql tztime.cc)
66 SET_TARGET_PROPERTIES(mariadb-tzinfo-to-sql PROPERTIES COMPILE_FLAGS "-DTZINFO2SQL") 66 SET_TARGET_PROPERTIES(mariadb-tzinfo-to-sql PROPERTIES COMPILE_FLAGS "-DTZINFO2SQL")
67--
682.25.1
69
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/configure.cmake-fix-valgrind.patch b/meta-oe/recipes-dbs/mysql/mariadb/configure.cmake-fix-valgrind.patch
index ac94279585..2841a59a73 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/configure.cmake-fix-valgrind.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/configure.cmake-fix-valgrind.patch
@@ -1,4 +1,4 @@
1From 24e2b0edc2612acefcc48414bb6f0aeb086061a9 Mon Sep 17 00:00:00 2001 1From c24181245bc502a384635d7f7f48f12863f84c2f Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Tue, 26 Feb 2019 23:57:06 -0800 3Date: Tue, 26 Feb 2019 23:57:06 -0800
4Subject: [PATCH] configure.cmake: fix valgrind 4Subject: [PATCH] configure.cmake: fix valgrind
@@ -16,16 +16,15 @@ Upstream-Status: Inappropriate [oe specific]
16 16
17Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 17Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
18Signed-off-by: Mingli Yu <mingli.yu@windriver.com> 18Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
19
20--- 19---
21 configure.cmake | 5 ++--- 20 configure.cmake | 5 ++---
22 1 file changed, 2 insertions(+), 3 deletions(-) 21 1 file changed, 2 insertions(+), 3 deletions(-)
23 22
24diff --git a/configure.cmake b/configure.cmake 23diff --git a/configure.cmake b/configure.cmake
25index 3cfc4b31..d017b3b3 100644 24index 61f30a75..3e730082 100644
26--- a/configure.cmake 25--- a/configure.cmake
27+++ b/configure.cmake 26+++ b/configure.cmake
28@@ -930,10 +930,9 @@ HAVE_GCC_C11_ATOMICS) 27@@ -881,10 +881,9 @@ ENDIF()
29 28
30 IF(WITH_VALGRIND) 29 IF(WITH_VALGRIND)
31 SET(HAVE_valgrind 1) 30 SET(HAVE_valgrind 1)
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/cross-compiling.patch b/meta-oe/recipes-dbs/mysql/mariadb/cross-compiling.patch
index d0d6e3c730..dc34c07d31 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/cross-compiling.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/cross-compiling.patch
@@ -1,4 +1,4 @@
1From 80be37351d995654f86b838f6b5ed47e8a90261b Mon Sep 17 00:00:00 2001 1From b6d8dbb7e930f5caa9e3e3c71706b0cf9eea7bb3 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 23 Sep 2022 12:05:17 +0800 3Date: Fri, 23 Sep 2022 12:05:17 +0800
4Subject: [PATCH] CMakeLists.txt: not include import_executables.cmake 4Subject: [PATCH] CMakeLists.txt: not include import_executables.cmake
@@ -14,10 +14,10 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
14 1 file changed, 5 deletions(-) 14 1 file changed, 5 deletions(-)
15 15
16diff --git a/CMakeLists.txt b/CMakeLists.txt 16diff --git a/CMakeLists.txt b/CMakeLists.txt
17index f9e2b1b..34924ba 100644 17index 3828420c..ee38615a 100644
18--- a/CMakeLists.txt 18--- a/CMakeLists.txt
19+++ b/CMakeLists.txt 19+++ b/CMakeLists.txt
20@@ -394,11 +394,6 @@ CHECK_LIBFMT() 20@@ -428,11 +428,6 @@ CHECK_LIBFMT()
21 ADD_SUBDIRECTORY(tpool) 21 ADD_SUBDIRECTORY(tpool)
22 CHECK_SYSTEMD() 22 CHECK_SYSTEMD()
23 23
@@ -29,6 +29,3 @@ index f9e2b1b..34924ba 100644
29 # 29 #
30 # Setup maintainer mode options. Platform checks are 30 # Setup maintainer mode options. Platform checks are
31 # not run with the warning options as to not perturb fragile checks 31 # not run with the warning options as to not perturb fragile checks
32--
332.25.1
34
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/fix-arm-atomic.patch b/meta-oe/recipes-dbs/mysql/mariadb/fix-arm-atomic.patch
index 05b0cf8ff7..39b7fad983 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/fix-arm-atomic.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/fix-arm-atomic.patch
@@ -1,4 +1,4 @@
1From f447aca534d1a12809eeb146e8220d305cc3884d Mon Sep 17 00:00:00 2001 1From af4247cd24eab2d728fb3592f6e125ef5290361b Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Thu, 9 Apr 2020 14:07:19 +0800 3Date: Thu, 9 Apr 2020 14:07:19 +0800
4Subject: [PATCH] build_rocksdb.cmake: fix atomic support on arm 4Subject: [PATCH] build_rocksdb.cmake: fix atomic support on arm
@@ -16,10 +16,10 @@ Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
16 1 file changed, 3 insertions(+) 16 1 file changed, 3 insertions(+)
17 17
18diff --git a/storage/rocksdb/build_rocksdb.cmake b/storage/rocksdb/build_rocksdb.cmake 18diff --git a/storage/rocksdb/build_rocksdb.cmake b/storage/rocksdb/build_rocksdb.cmake
19index d7895b0..3bcd52a 100644 19index e89dbfc0..acc6b48e 100644
20--- a/storage/rocksdb/build_rocksdb.cmake 20--- a/storage/rocksdb/build_rocksdb.cmake
21+++ b/storage/rocksdb/build_rocksdb.cmake 21+++ b/storage/rocksdb/build_rocksdb.cmake
22@@ -470,6 +470,9 @@ list(APPEND SOURCES ${CMAKE_CURRENT_BINARY_DIR}/build_version.cc) 22@@ -490,6 +490,9 @@ list(APPEND SOURCES ${CMAKE_CURRENT_BINARY_DIR}/build_version.cc)
23 23
24 ADD_CONVENIENCE_LIBRARY(rocksdblib ${SOURCES}) 24 ADD_CONVENIENCE_LIBRARY(rocksdblib ${SOURCES})
25 target_link_libraries(rocksdblib ${THIRDPARTY_LIBS} ${SYSTEM_LIBS}) 25 target_link_libraries(rocksdblib ${THIRDPARTY_LIBS} ${SYSTEM_LIBS})
@@ -29,6 +29,3 @@ index d7895b0..3bcd52a 100644
29 IF(CMAKE_CXX_COMPILER_ID MATCHES "GNU" OR CMAKE_CXX_COMPILER_ID MATCHES "Clang") 29 IF(CMAKE_CXX_COMPILER_ID MATCHES "GNU" OR CMAKE_CXX_COMPILER_ID MATCHES "Clang")
30 set_target_properties(rocksdblib PROPERTIES COMPILE_FLAGS "-fPIC -fno-builtin-memcmp -Wno-error") 30 set_target_properties(rocksdblib PROPERTIES COMPILE_FLAGS "-fPIC -fno-builtin-memcmp -Wno-error")
31 endif() 31 endif()
32--
332.7.4
34
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/lfs64.patch b/meta-oe/recipes-dbs/mysql/mariadb/lfs64.patch
index 7a685a6521..d53eb99e4c 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/lfs64.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/lfs64.patch
@@ -1,5 +1,15 @@
1From 24667f728fabe141a92d4de828ab24d9fe953b08 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 25 Dec 2022 19:23:17 -0800
4Subject: [PATCH] mariadb: Alias lseek64/open64/ftruncate64 on musl systems
5
1Upstream-Status: Pending 6Upstream-Status: Pending
7---
8 storage/connect/os.h | 4 +++-
9 1 file changed, 3 insertions(+), 1 deletion(-)
2 10
11diff --git a/storage/connect/os.h b/storage/connect/os.h
12index 7d0d5cab..10da630f 100644
3--- a/storage/connect/os.h 13--- a/storage/connect/os.h
4+++ b/storage/connect/os.h 14+++ b/storage/connect/os.h
5@@ -2,13 +2,15 @@ 15@@ -2,13 +2,15 @@
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/mm_malloc.patch b/meta-oe/recipes-dbs/mysql/mariadb/mm_malloc.patch
index 6aa6c84882..a590a3fa36 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/mm_malloc.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/mm_malloc.patch
@@ -1,5 +1,15 @@
1From 76e4c3e8d001eaaabd0fb34c136b81b82830c420 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 15 Jun 2021 22:48:07 -0700
4Subject: [PATCH] mariadb: Fix build with clang/musl
5
1Upstream-Status: Pending 6Upstream-Status: Pending
7---
8 storage/rocksdb/rocksdb/port/jemalloc_helper.h | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
2 10
11diff --git a/storage/rocksdb/rocksdb/port/jemalloc_helper.h b/storage/rocksdb/rocksdb/port/jemalloc_helper.h
12index f6f72f8c..b9657cf3 100644
3--- a/storage/rocksdb/rocksdb/port/jemalloc_helper.h 13--- a/storage/rocksdb/rocksdb/port/jemalloc_helper.h
4+++ b/storage/rocksdb/rocksdb/port/jemalloc_helper.h 14+++ b/storage/rocksdb/rocksdb/port/jemalloc_helper.h
5@@ -5,7 +5,7 @@ 15@@ -5,7 +5,7 @@
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/ssize_t.patch b/meta-oe/recipes-dbs/mysql/mariadb/ssize_t.patch
index 4e499d4137..819b65f041 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/ssize_t.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/ssize_t.patch
@@ -1,7 +1,16 @@
1ssize_t comes from sys/types.h therefore include it 1From cfa843c91a036d0926c76c6dec6fd2a1f38e4843 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 31 May 2021 21:55:00 -0700
4Subject: [PATCH] ssize_t comes from sys/types.h therefore include it
2 5
3Upstream-Status: Pending 6Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com> 7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 wsrep-lib/include/wsrep/gtid.hpp | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/wsrep-lib/include/wsrep/gtid.hpp b/wsrep-lib/include/wsrep/gtid.hpp
13index 0d49c58d..d61a6585 100644
5--- a/wsrep-lib/include/wsrep/gtid.hpp 14--- a/wsrep-lib/include/wsrep/gtid.hpp
6+++ b/wsrep-lib/include/wsrep/gtid.hpp 15+++ b/wsrep-lib/include/wsrep/gtid.hpp
7@@ -25,7 +25,7 @@ 16@@ -25,7 +25,7 @@
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/support-files-CMakeLists.txt-fix-do_populate_sysroot.patch b/meta-oe/recipes-dbs/mysql/mariadb/support-files-CMakeLists.txt-fix-do_populate_sysroot.patch
index 233d9e6af6..30c9e2452a 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/support-files-CMakeLists.txt-fix-do_populate_sysroot.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/support-files-CMakeLists.txt-fix-do_populate_sysroot.patch
@@ -1,4 +1,4 @@
1From 4ac5b555d058d4d489f25a3806a787b7b2465d09 Mon Sep 17 00:00:00 2001 1From 34713c3bba68cb94b373b750c1c8fcc0b04b2c45 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com> 2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Wed, 27 Feb 2019 22:41:26 -0800 3Date: Wed, 27 Feb 2019 22:41:26 -0800
4Subject: [PATCH] support-files/CMakeLists.txt: fix do_populate_sysroot issue 4Subject: [PATCH] support-files/CMakeLists.txt: fix do_populate_sysroot issue
@@ -10,16 +10,15 @@ ERROR: mariadb-native-10.3.13-r0 do_populate_sysroot: sstate found an absolute p
10Upstream-Status: Inappropriate [oe build specific] 10Upstream-Status: Inappropriate [oe build specific]
11 11
12Signed-off-by: Mingli Yu <mingli.yu@windriver.com> 12Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
13
14--- 13---
15 support-files/CMakeLists.txt | 7 ------- 14 support-files/CMakeLists.txt | 7 -------
16 1 file changed, 7 deletions(-) 15 1 file changed, 7 deletions(-)
17 16
18diff --git a/support-files/CMakeLists.txt b/support-files/CMakeLists.txt 17diff --git a/support-files/CMakeLists.txt b/support-files/CMakeLists.txt
19index b5767432..56733de1 100644 18index ee1d420e..a99c0605 100644
20--- a/support-files/CMakeLists.txt 19--- a/support-files/CMakeLists.txt
21+++ b/support-files/CMakeLists.txt 20+++ b/support-files/CMakeLists.txt
22@@ -165,12 +165,5 @@ IF(UNIX) 21@@ -245,12 +245,5 @@ IF(UNIX AND NOT WITHOUT_SERVER)
23 INSTALL(FILES rpm/enable_encryption.preset DESTINATION ${INSTALL_SYSCONF2DIR} 22 INSTALL(FILES rpm/enable_encryption.preset DESTINATION ${INSTALL_SYSCONF2DIR}
24 COMPONENT IniFiles) 23 COMPONENT IniFiles)
25 ENDIF() 24 ENDIF()
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/sys_futex.patch b/meta-oe/recipes-dbs/mysql/mariadb/sys_futex.patch
index 3244ab8da2..3840472213 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb/sys_futex.patch
+++ b/meta-oe/recipes-dbs/mysql/mariadb/sys_futex.patch
@@ -1,14 +1,22 @@
1Use SYS_futex for syscall 1From 166811dfcfc61e7646275aa993d7d7f4b02d1f49 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 3 Apr 2021 12:40:14 -0700
4Subject: [PATCH] Use SYS_futex for syscall
2 5
3glibc defines SYS_futex and on newer 32bit CPUs like RISCV-32, arc there 6glibc defines SYS_futex and on newer 32bit CPUs like RISCV-32, arc there
4is no 32bit time_t therefore define SYS_futex in terms of SYS_futex_time64 7is no 32bit time_t therefore define SYS_futex in terms of SYS_futex_time64
5 8
6Upstream-Status: Pending 9Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com> 10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 storage/innobase/sync/srw_lock.cc | 6 ++++++
13 1 file changed, 6 insertions(+)
8 14
15diff --git a/storage/innobase/sync/srw_lock.cc b/storage/innobase/sync/srw_lock.cc
16index 28b586de..3ee71142 100644
9--- a/storage/innobase/sync/srw_lock.cc 17--- a/storage/innobase/sync/srw_lock.cc
10+++ b/storage/innobase/sync/srw_lock.cc 18+++ b/storage/innobase/sync/srw_lock.cc
11@@ -210,6 +210,12 @@ void ssux_lock_low::wake() { WakeByAddre 19@@ -226,6 +226,12 @@ void ssux_lock_impl<spinloop>::wake() noexcept { WakeByAddressSingle(&readers);
12 # ifdef __linux__ 20 # ifdef __linux__
13 # include <linux/futex.h> 21 # include <linux/futex.h>
14 # include <sys/syscall.h> 22 # include <sys/syscall.h>
diff --git a/meta-oe/recipes-dbs/mysql/mariadb_10.11.10.bb b/meta-oe/recipes-dbs/mysql/mariadb_11.4.4.bb
index b1d1355e2b..b1d1355e2b 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb_10.11.10.bb
+++ b/meta-oe/recipes-dbs/mysql/mariadb_11.4.4.bb