diff options
-rw-r--r-- | meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch | 23 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/umip/umip_1.0.bb | 6 |
2 files changed, 26 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch new file mode 100644 index 0000000000..dbf0082640 --- /dev/null +++ b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | When "make -j10", the compilation will fail, | ||
2 | because scan.c has included gram.h, but gram.h was produced | ||
3 | after scan.c was compiled | ||
4 | |||
5 | So add this dependency to ensure that gram.h is produced | ||
6 | before scan.c is produced. | ||
7 | |||
8 | Upstream-Status: Inappropriate [upstream is not active] | ||
9 | |||
10 | Signed-off-by: Roy.Li <RongQing.Li@windriver.com> | ||
11 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | ||
12 | --- | ||
13 | src/Makefile.am | 2 ++ | ||
14 | 1 file changed, 2 insertions(+) | ||
15 | |||
16 | --- a/src/Makefile.am | ||
17 | +++ b/src/Makefile.am | ||
18 | @@ -81,3 +81,5 @@ CLEANFILES = gram.c gram.h \ | ||
19 | |||
20 | DISTCLEANFILES = $(BUILT_SOURCES) | ||
21 | MAINTAINERCLEANFILES = Makefile.in | ||
22 | + | ||
23 | +scan.c: gram.h | ||
diff --git a/meta-oe/recipes-connectivity/umip/umip_1.0.bb b/meta-oe/recipes-connectivity/umip/umip_1.0.bb index e80c1b1309..e97dd48f69 100644 --- a/meta-oe/recipes-connectivity/umip/umip_1.0.bb +++ b/meta-oe/recipes-connectivity/umip/umip_1.0.bb | |||
@@ -9,12 +9,12 @@ LICENSE = "GPLv2" | |||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33" | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33" |
10 | DEPENDS = "rpm indent-native" | 10 | DEPENDS = "rpm indent-native" |
11 | 11 | ||
12 | SRC_URI = "git://git.umip.org/umip.git" | 12 | SRC_URI = "git://git.umip.org/umip.git \ |
13 | file://add-dependency-to-support-parallel-compilation.patch \ | ||
14 | " | ||
13 | SRCREV = "428974c2d0d8e75a2750a3ab0488708c5dfdd8e3" | 15 | SRCREV = "428974c2d0d8e75a2750a3ab0488708c5dfdd8e3" |
14 | 16 | ||
15 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
16 | EXTRA_OE_CONF = "--enable-vt" | 18 | EXTRA_OE_CONF = "--enable-vt" |
17 | 19 | ||
18 | inherit autotools-brokensep | 20 | inherit autotools-brokensep |
19 | |||
20 | PARALLEL_MAKE = "" | ||