diff options
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-bcrypt.inc b/meta-python/recipes-devtools/python/python-bcrypt.inc new file mode 100644 index 0000000000..667a3fb6e0 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-bcrypt.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "Modern password hashing for your software and your servers." | ||
2 | LICENSE = "Apache-2.0" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c" | ||
4 | |||
5 | DEPENDS += "${PYTHON_PN}-cffi-native" | ||
6 | |||
7 | SRC_URI[md5sum] = "20da8b40790caad99c4086dba533154b" | ||
8 | SRC_URI[sha256sum] = "6645c8d0ad845308de3eb9be98b6fd22a46ec5412bfc664a423e411cdd8f5488" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN}_class-target += "\ | ||
13 | ${PYTHON_PN}-cffi \ | ||
14 | ${PYTHON_PN}-six \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb b/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb index c690f0dfd3..24333540b6 100644 --- a/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb +++ b/meta-python/recipes-devtools/python/python-bcrypt_3.1.3.bb | |||
@@ -1,15 +1,2 @@ | |||
1 | DESCRIPTION = "Modern password hashing for your software and your servers." | 1 | inherit setuptools |
2 | LICENSE = "Apache-2.0" | 2 | require python-bcrypt.inc |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c" | ||
4 | |||
5 | DEPENDS = "python-cffi-native" | ||
6 | |||
7 | SRC_URI[md5sum] = "20da8b40790caad99c4086dba533154b" | ||
8 | SRC_URI[sha256sum] = "6645c8d0ad845308de3eb9be98b6fd22a46ec5412bfc664a423e411cdd8f5488" | ||
9 | |||
10 | inherit pypi setuptools | ||
11 | |||
12 | RDEPENDS_${PN}_class-target += "\ | ||
13 | ${PYTHON_PN}-cffi \ | ||
14 | ${PYTHON_PN}-six \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-bcrypt_3.1.3.bb b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.3.bb new file mode 100644 index 0000000000..d2ec9e386c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-bcrypt_3.1.3.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-bcrypt.inc | ||