summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/php/php_8.4.5.bb22
1 files changed, 10 insertions, 12 deletions
diff --git a/meta-oe/recipes-devtools/php/php_8.4.5.bb b/meta-oe/recipes-devtools/php/php_8.4.5.bb
index cf4b756b85..7c7c425d3d 100644
--- a/meta-oe/recipes-devtools/php/php_8.4.5.bb
+++ b/meta-oe/recipes-devtools/php/php_8.4.5.bb
@@ -92,27 +92,25 @@ PACKAGECONFIG ??= "mysql sqlite3 opcache openssl \
92" 92"
93PACKAGECONFIG:class-native = "" 93PACKAGECONFIG:class-native = ""
94 94
95PACKAGECONFIG[zip] = "--with-zip --with-zlib-dir=${STAGING_EXECPREFIXDIR},,libzip" 95PACKAGECONFIG[apache2] = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs,,apache2-native apache2"
96 96PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
97PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma"
98PACKAGECONFIG[mbstring] = "--enable-mbstring,,"
97PACKAGECONFIG[mysql] = "--with-mysqli=mysqlnd \ 99PACKAGECONFIG[mysql] = "--with-mysqli=mysqlnd \
98 --with-pdo-mysql=mysqlnd \ 100 --with-pdo-mysql=mysqlnd \
99 ,--without-mysqli --without-pdo-mysql \ 101 ,--without-mysqli --without-pdo-mysql \
100 ,mysql5" 102 ,mysql5"
101 103PACKAGECONFIG[opcache] = "--enable-opcache,--disable-opcache"
104PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
105PACKAGECONFIG[pam] = ",,libpam"
106PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--without-pgsql,postgresql"
107PACKAGECONFIG[soap] = "--enable-soap, --disable-soap, libxml2"
102PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_LIBDIR}/.. \ 108PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_LIBDIR}/.. \
103 --with-pdo-sqlite=${STAGING_LIBDIR}/.. \ 109 --with-pdo-sqlite=${STAGING_LIBDIR}/.. \
104 ,--without-sqlite3 --without-pdo-sqlite \ 110 ,--without-sqlite3 --without-pdo-sqlite \
105 ,sqlite3" 111 ,sqlite3"
106PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--without-pgsql,postgresql"
107PACKAGECONFIG[soap] = "--enable-soap, --disable-soap, libxml2"
108PACKAGECONFIG[apache2] = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs,,apache2-native apache2"
109PACKAGECONFIG[pam] = ",,libpam"
110PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
111PACKAGECONFIG[opcache] = "--enable-opcache,--disable-opcache"
112PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
113PACKAGECONFIG[valgrind] = "--with-valgrind=${STAGING_DIR_TARGET}/usr,--with-valgrind=no,valgrind" 112PACKAGECONFIG[valgrind] = "--with-valgrind=${STAGING_DIR_TARGET}/usr,--with-valgrind=no,valgrind"
114PACKAGECONFIG[mbregex] = "--enable-mbregex, --disable-mbregex, oniguruma" 113PACKAGECONFIG[zip] = "--with-zip --with-zlib-dir=${STAGING_EXECPREFIXDIR},,libzip"
115PACKAGECONFIG[mbstring] = "--enable-mbstring,,"
116 114
117export HOSTCC = "${BUILD_CC}" 115export HOSTCC = "${BUILD_CC}"
118export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}" 116export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"