diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aspectlib/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb | 4 |
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest index b63c4de0d9..8d2017d39c 100644 --- a/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest +++ b/meta-python/recipes-devtools/python/python3-aspectlib/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb index 416b031c5e..d2b0864caa 100644 --- a/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb +++ b/meta-python/recipes-devtools/python/python3-aspectlib_2.0.0.bb | |||
@@ -21,8 +21,10 @@ do_install_ptest() { | |||
21 | } | 21 | } |
22 | 22 | ||
23 | RDEPENDS:${PN}-ptest += "\ | 23 | RDEPENDS:${PN}-ptest += "\ |
24 | python3-tornado \ | ||
25 | python3-process-tests \ | 24 | python3-process-tests \ |
25 | python3-pytest \ | ||
26 | python3-tornado \ | ||
27 | python3-unittest-automake-output \ | ||
26 | " | 28 | " |
27 | 29 | ||
28 | RDEPENDS:${PN} += "python3-core python3-fields" | 30 | RDEPENDS:${PN} += "python3-core python3-fields" |