diff options
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba/9aa5c43315d83c19514251a11c4fba5a137f2821.patch | 70 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba_4.19.8.bb | 1 |
2 files changed, 71 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba/9aa5c43315d83c19514251a11c4fba5a137f2821.patch b/meta-networking/recipes-connectivity/samba/samba/9aa5c43315d83c19514251a11c4fba5a137f2821.patch new file mode 100644 index 0000000000..e07e86e887 --- /dev/null +++ b/meta-networking/recipes-connectivity/samba/samba/9aa5c43315d83c19514251a11c4fba5a137f2821.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | From 9aa5c43315d83c19514251a11c4fba5a137f2821 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andreas Schneider <asn@samba.org> | ||
3 | Date: Tue, 21 Jan 2025 17:59:27 +0100 | ||
4 | Subject: [PATCH] lib:replace: Don't use deprecated readline CPPFunction cast | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | HAVE_RL_COMPLETION_FUNC_T was unused and not checking for the right | ||
10 | function. | ||
11 | |||
12 | libcli/smbreadline/smbreadline.c: In function ‘smb_readline’: | ||
13 | libcli/smbreadline/smbreadline.c:139:17: warning: ‘CPPFunction’ is deprecated [-Wdeprecated-declarations] | ||
14 | 139 | rl_attempted_completion_function = RL_COMPLETION_CAST completion_fn; | ||
15 | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
16 | libcli/smbreadline/smbreadline.c:139:50: error: assignment to ‘char ** (*)(const char *, int, int)’ from incompatible pointer type ‘char ** (*)(void)’ [-Wincompatible-pointer-types] | ||
17 | 139 | rl_attempted_completion_function = RL_COMPLETION_CAST completion_fn; | ||
18 | | ^ | ||
19 | |||
20 | BUG: https://bugzilla.samba.org/show_bug.cgi?id=15788 | ||
21 | |||
22 | Signed-off-by: Andreas Schneider <asn@samba.org> | ||
23 | Reviewed-by: Alexander Bokovoy <ab@samba.org> | ||
24 | |||
25 | Autobuild-User(master): Andreas Schneider <asn@cryptomilk.org> | ||
26 | Autobuild-Date(master): Tue Jan 21 19:38:37 UTC 2025 on atb-devel-224 | ||
27 | |||
28 | Upstream-Status: Backport [https://github.com/samba-team/samba/commit/9aa5c43315d83c19514251a11c4fba5a137f2821] | ||
29 | |||
30 | Signed-off-by: Markus Volk <f_l_k@t-online.de> | ||
31 | --- | ||
32 | lib/replace/system/readline.h | 4 +++- | ||
33 | libcli/smbreadline/wscript_configure | 8 +++++--- | ||
34 | 2 files changed, 8 insertions(+), 4 deletions(-) | ||
35 | |||
36 | diff --git a/lib/replace/system/readline.h b/lib/replace/system/readline.h | ||
37 | index 9a9af266ca6d..ac3604fc12e0 100644 | ||
38 | --- a/lib/replace/system/readline.h | ||
39 | +++ b/lib/replace/system/readline.h | ||
40 | @@ -46,7 +46,9 @@ | ||
41 | #endif | ||
42 | |||
43 | #ifdef HAVE_NEW_LIBREADLINE | ||
44 | -#ifdef HAVE_CPPFUNCTION | ||
45 | +#if defined(HAVE_RL_COMPLETION_FUNC_T) | ||
46 | +# define RL_COMPLETION_CAST (rl_completion_func_t *) | ||
47 | +#elif defined(HAVE_CPPFUNCTION) | ||
48 | # define RL_COMPLETION_CAST (CPPFunction *) | ||
49 | #elif defined(HAVE_RL_COMPLETION_T) | ||
50 | # define RL_COMPLETION_CAST (rl_completion_t *) | ||
51 | diff --git a/libcli/smbreadline/wscript_configure b/libcli/smbreadline/wscript_configure | ||
52 | index 912ff53a150d..f5a401ebae00 100644 | ||
53 | --- a/libcli/smbreadline/wscript_configure | ||
54 | +++ b/libcli/smbreadline/wscript_configure | ||
55 | @@ -51,10 +51,12 @@ conf.CHECK_CODE(''' | ||
56 | # endif | ||
57 | # endif | ||
58 | #endif | ||
59 | -int main(void) {rl_completion_t f; return 0;} | ||
60 | +int main(void) {rl_completion_func_t f; return 0;} | ||
61 | ''', | ||
62 | -'HAVE_RL_COMPLETION_FUNC_T', execute=False, addmain=False, | ||
63 | -msg='Checking for rl_completion_t') | ||
64 | + 'HAVE_RL_COMPLETION_FUNC_T', | ||
65 | + execute=False, | ||
66 | + addmain=False, | ||
67 | + msg='Checking for rl_completion_func_t') | ||
68 | |||
69 | conf.CHECK_CODE(''' | ||
70 | #ifdef HAVE_READLINE_READLINE_H | ||
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.19.8.bb b/meta-networking/recipes-connectivity/samba/samba_4.19.8.bb index 05dca8d9c0..0ec0051c43 100644 --- a/meta-networking/recipes-connectivity/samba/samba_4.19.8.bb +++ b/meta-networking/recipes-connectivity/samba/samba_4.19.8.bb | |||
@@ -24,6 +24,7 @@ SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \ | |||
24 | file://0005-Fix-pyext_PATTERN-for-cross-compilation.patch \ | 24 | file://0005-Fix-pyext_PATTERN-for-cross-compilation.patch \ |
25 | file://0006-smbtorture-skip-test-case-tfork_cmd_send.patch \ | 25 | file://0006-smbtorture-skip-test-case-tfork_cmd_send.patch \ |
26 | file://0007-Deleted-settiong-of-python-to-fix-the-install-confli.patch \ | 26 | file://0007-Deleted-settiong-of-python-to-fix-the-install-confli.patch \ |
27 | file://9aa5c43315d83c19514251a11c4fba5a137f2821.patch \ | ||
27 | " | 28 | " |
28 | 29 | ||
29 | SRC_URI:append:libc-musl = " \ | 30 | SRC_URI:append:libc-musl = " \ |