summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-chardet.inc23
-rw-r--r--meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb29
2 files changed, 23 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python-chardet.inc b/meta-python/recipes-devtools/python/python-chardet.inc
deleted file mode 100644
index 6305299780..0000000000
--- a/meta-python/recipes-devtools/python/python-chardet.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Universal encoding detector for Python 2 and 3"
2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
4
5inherit pypi
6
7# setup.py of chardet needs this.
8DEPENDS += "${PYTHON_PN}-pytest-runner-native"
9
10SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c"
11SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae"
12
13BBCLASSEXTEND = "native nativesdk"
14
15PACKAGES =+ "${PN}-cli"
16RDEPENDS_${PN}-cli = "${PN} "
17FILES_${PN}-cli += " \
18 ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
19"
20
21RDEPENDS_${PN}_class-target += " \
22 ${PYTHON_PN}-logging \
23"
diff --git a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
index 38d8122ce9..80785b8d4e 100644
--- a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
@@ -1,7 +1,24 @@
1inherit setuptools3 1SUMMARY = "Universal encoding detector for Python 2 and 3"
2require python-chardet.inc 2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
3 4
4do_install_append () { 5SRC_URI[md5sum] = "7dd1ba7f9c77e32351b0a0cfacf4055c"
5 # rename scripts that would conflict with the Python 2 build of chardet 6SRC_URI[sha256sum] = "84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae"
6 mv ${D}${bindir}/chardetect ${D}${bindir}/chardetect3 7
7} 8# setup.py of chardet needs this.
9DEPENDS += "${PYTHON_PN}-pytest-runner-native"
10
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-cli"
14FILES_${PN}-cli += " \
15 ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
16"
17
18RDEPENDS_${PN}-cli = "${PN} "
19
20RDEPENDS_${PN}_class-target += " \
21 ${PYTHON_PN}-logging \
22"
23
24BBCLASSEXTEND = "native nativesdk"