summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-colorclass/0001-pyproject.toml-Use-poetry-core.patch30
-rw-r--r--meta-python/recipes-devtools/python/python3-colorclass_2.2.2.bb3
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-colorclass/0001-pyproject.toml-Use-poetry-core.patch b/meta-python/recipes-devtools/python/python3-colorclass/0001-pyproject.toml-Use-poetry-core.patch
new file mode 100644
index 0000000000..d3e29d0a15
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-colorclass/0001-pyproject.toml-Use-poetry-core.patch
@@ -0,0 +1,30 @@
1From 32a8a6bff42dfa493ae3c4a722109f2d3a32108e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 11 Apr 2025 19:14:16 -0700
4Subject: [PATCH] pyproject.toml: Use poetry-core
5
6Needed for using latest poetry infrastructure
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 pyproject.toml | 6 +++---
12 1 file changed, 3 insertions(+), 3 deletions(-)
13
14diff --git a/pyproject.toml b/pyproject.toml
15index 65eaec9..50d26cc 100644
16--- a/pyproject.toml
17+++ b/pyproject.toml
18@@ -58,9 +58,9 @@ documentation = "https://github.com/matthewdeanmartin/colorclass"
19 # per vermin's estimation
20 python = ">=2.6 || >=3.0"
21
22-[tool.poetry.dev-dependencies]
23+[tool.poetry.group.dev.dependencies]
24 pytest = "==6.0.1"
25
26 [build-system]
27-requires = ["poetry>=0.12"]
28-build-backend = "poetry.masonry.api"
29+requires = ["poetry-core"]
30+build-backend = "poetry.core.masonry.api"
diff --git a/meta-python/recipes-devtools/python/python3-colorclass_2.2.2.bb b/meta-python/recipes-devtools/python/python3-colorclass_2.2.2.bb
index e605b459ce..498682cd6d 100644
--- a/meta-python/recipes-devtools/python/python3-colorclass_2.2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-colorclass_2.2.2.bb
@@ -4,8 +4,9 @@ LICENSE = "MIT"
4SECTION = "devel/python" 4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1b2a533055839e54558a727657c1c73e" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1b2a533055839e54558a727657c1c73e"
6 6
7inherit pypi setuptools3 7inherit pypi python_poetry_core
8 8
9SRC_URI += "file://0001-pyproject.toml-Use-poetry-core.patch"
9SRC_URI[sha256sum] = "6d4fe287766166a98ca7bc6f6312daf04a0481b1eda43e7173484051c0ab4366" 10SRC_URI[sha256sum] = "6d4fe287766166a98ca7bc6f6312daf04a0481b1eda43e7173484051c0ab4366"
10 11
11PYPI_PACKAGE = "colorclass" 12PYPI_PACKAGE = "colorclass"