diff options
-rw-r--r-- | meta-oe/recipes-connectivity/libtorrent/libtorrent/don-t-run-code-while-configuring-package.patch | 98 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb | 4 |
2 files changed, 18 insertions, 84 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent/don-t-run-code-while-configuring-package.patch b/meta-oe/recipes-connectivity/libtorrent/libtorrent/don-t-run-code-while-configuring-package.patch index 79d4f29fab..8d8867aea7 100644 --- a/meta-oe/recipes-connectivity/libtorrent/libtorrent/don-t-run-code-while-configuring-package.patch +++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent/don-t-run-code-while-configuring-package.patch | |||
@@ -4,91 +4,25 @@ cross-compiling. Don't run code while configuring package. | |||
4 | Upstream-Status: Pending | 4 | Upstream-Status: Pending |
5 | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> | 5 | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> |
6 | 6 | ||
7 | Index: libtorrent-0.13.3/scripts/checks.m4 | 7 | Index: git/scripts/common.m4 |
8 | =================================================================== | 8 | =================================================================== |
9 | --- libtorrent-0.13.3.orig/scripts/checks.m4 2012-05-14 14:17:04.000000000 +0300 | 9 | --- git.orig/scripts/common.m4 |
10 | +++ libtorrent-0.13.3/scripts/checks.m4 2013-02-10 15:28:37.414445524 +0200 | 10 | +++ git/scripts/common.m4 |
11 | @@ -95,40 +95,6 @@ | 11 | @@ -153,7 +153,7 @@ dnl Need to fix this so that it uses t |
12 | |||
13 | AC_DEFUN([TORRENT_CHECK_KQUEUE_SOCKET_ONLY], [ | ||
14 | AC_MSG_CHECKING(whether kqueue supports pipes and ptys) | ||
15 | - | ||
16 | - AC_RUN_IFELSE([AC_LANG_SOURCE([ | ||
17 | - #include <fcntl.h> | ||
18 | - #include <stdlib.h> | ||
19 | - #include <unistd.h> | ||
20 | - #include <sys/event.h> | ||
21 | - #include <sys/time.h> | ||
22 | - int main() { | ||
23 | - struct kevent ev@<:@2@:>@, ev_out@<:@2@:>@; | ||
24 | - struct timespec ts = { 0, 0 }; | ||
25 | - int pfd@<:@2@:>@, pty@<:@2@:>@, kfd, n; | ||
26 | - char buffer@<:@9001@:>@; | ||
27 | - if (pipe(pfd) == -1) return 1; | ||
28 | - if (fcntl(pfd@<:@1@:>@, F_SETFL, O_NONBLOCK) == -1) return 2; | ||
29 | - while ((n = write(pfd@<:@1@:>@, buffer, sizeof(buffer))) == sizeof(buffer)); | ||
30 | - if ((pty@<:@0@:>@=posix_openpt(O_RDWR | O_NOCTTY)) == -1) return 3; | ||
31 | - if ((pty@<:@1@:>@=grantpt(pty@<:@0@:>@)) == -1) return 4; | ||
32 | - EV_SET(ev+0, pfd@<:@1@:>@, EVFILT_WRITE, EV_ADD | EV_ENABLE, 0, 0, NULL); | ||
33 | - EV_SET(ev+1, pty@<:@1@:>@, EVFILT_READ, EV_ADD | EV_ENABLE, 0, 0, NULL); | ||
34 | - if ((kfd = kqueue()) == -1) return 5; | ||
35 | - if ((n = kevent(kfd, ev, 2, NULL, 0, NULL)) == -1) return 6; | ||
36 | - if (ev_out@<:@0@:>@.flags & EV_ERROR) return 7; | ||
37 | - if (ev_out@<:@1@:>@.flags & EV_ERROR) return 8; | ||
38 | - read(pfd@<:@0@:>@, buffer, sizeof(buffer)); | ||
39 | - if ((n = kevent(kfd, NULL, 0, ev_out, 2, &ts)) < 1) return 9; | ||
40 | - return 0; | ||
41 | - } | ||
42 | - ])], | ||
43 | - [ | ||
44 | - AC_MSG_RESULT(yes) | ||
45 | - ], [ | ||
46 | - AC_DEFINE(KQUEUE_SOCKET_ONLY, 1, kqueue only supports sockets.) | ||
47 | - AC_MSG_RESULT(no) | ||
48 | - ]) | ||
49 | ]) | ||
50 | |||
51 | AC_DEFUN([TORRENT_WITH_KQUEUE], [ | ||
52 | Index: libtorrent-0.13.3/scripts/common.m4 | ||
53 | =================================================================== | ||
54 | --- libtorrent-0.13.3.orig/scripts/common.m4 2012-05-14 14:17:04.000000000 +0300 | ||
55 | +++ libtorrent-0.13.3/scripts/common.m4 2013-02-10 15:27:55.874446741 +0200 | ||
56 | @@ -222,38 +222,10 @@ | ||
57 | |||
58 | AC_DEFUN([TORRENT_CHECK_EXECINFO], [ | 12 | AC_DEFUN([TORRENT_CHECK_EXECINFO], [ |
59 | AC_MSG_CHECKING(for execinfo.h) | 13 | AC_MSG_CHECKING(for execinfo.h) |
60 | - | 14 | |
61 | - AC_RUN_IFELSE([AC_LANG_SOURCE([ | 15 | - AC_COMPILE_IFELSE([AC_LANG_SOURCE([ |
62 | - #include <execinfo.h> | 16 | + AC_LINK_IFELSE([AC_LANG_SOURCE([ |
63 | - int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;} | 17 | #include <execinfo.h> |
64 | - ])], | 18 | int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;} |
65 | - [ | 19 | ])], |
66 | - AC_MSG_RESULT(yes) | 20 | @@ -168,7 +168,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [ |
67 | - AC_DEFINE(USE_EXECINFO, 1, Use execinfo.h) | ||
68 | - ], [ | ||
69 | - AC_MSG_RESULT(no) | ||
70 | - ]) | ||
71 | ]) | ||
72 | |||
73 | AC_DEFUN([TORRENT_CHECK_ALIGNED], [ | 21 | AC_DEFUN([TORRENT_CHECK_ALIGNED], [ |
74 | AC_MSG_CHECKING(the byte alignment) | 22 | AC_MSG_CHECKING(the byte alignment) |
75 | - | 23 | |
76 | - AC_RUN_IFELSE([AC_LANG_SOURCE([ | 24 | - AC_RUN_IFELSE([AC_LANG_SOURCE([ |
77 | - #include <inttypes.h> | 25 | + AC_LINK_IFELSE([AC_LANG_SOURCE([ |
78 | - int main() { | 26 | #include <inttypes.h> |
79 | - char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 }; | 27 | int main() { |
80 | - int i; | 28 | char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 }; |
81 | - for (i = 1; i < 4; ++i) | ||
82 | - if (*(uint32_t*)(buf + i) == 0) return -1; | ||
83 | - return 0; | ||
84 | - } | ||
85 | - ])], | ||
86 | - [ | ||
87 | - AC_MSG_RESULT(none needed) | ||
88 | - ], [ | ||
89 | - AC_DEFINE(USE_ALIGNED, 1, Require byte alignment) | ||
90 | - AC_MSG_RESULT(required) | ||
91 | - ]) | ||
92 | ]) | ||
93 | |||
94 | |||
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb index 92e65289a9..b2dffcdb91 100644 --- a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb +++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb | |||
@@ -11,9 +11,9 @@ SRC_URI = "git://github.com/rakshasa/libtorrent \ | |||
11 | file://0001-implement-64bit-atomic-for-mips.patch \ | 11 | file://0001-implement-64bit-atomic-for-mips.patch \ |
12 | file://0001-Define-64bit-atomic-helpers-for-ppc-32-bit.patch \ | 12 | file://0001-Define-64bit-atomic-helpers-for-ppc-32-bit.patch \ |
13 | " | 13 | " |
14 | SRCREV = "c167c5a9e0bcf0df23ae5efd91396aae0e37eb87" | 14 | SRCREV = "074f6ec51a2e4bc5c6140b4dad13c9bb56f3f0dc" |
15 | 15 | ||
16 | PV = "0.13.6+git${SRCPV}" | 16 | PV = "0.13.7+git${SRCPV}" |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | 19 | ||