summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_2.7.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_2.7.1.bb b/meta-python/recipes-devtools/python/python3-typeguard_2.7.1.bb
new file mode 100644
index 0000000000..b62b60564a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-typeguard_2.7.1.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Run-time type checker for Python"
2HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5
6SRC_URI[md5sum] = "ef743359de59f8fe17e7c5e3af70e2c5"
7SRC_URI[sha256sum] = "2d545c71e9439c21bcd7c28f5f55b3606e6106f7031ab58375656a1aed483ef2"
8
9inherit pypi setuptools3
10
11DEPENDS += "\
12 python3-distutils-extra-native \
13 python3-setuptools-scm-native \
14"
15
16RDEPENDS_${PN} += "python3-typing"
17
18BBCLASSEXTEND = "native nativesdk"