summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch38
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch38
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb24
3 files changed, 100 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch b/meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch
new file mode 100644
index 0000000000..cf03cd0f29
--- /dev/null
+++ b/meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch
@@ -0,0 +1,38 @@
1From 8bb183926078b6dd54048fb6820838fe7b6e6163 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Sun, 23 Oct 2016 22:46:43 +0200
4Subject: [PATCH] use pkg-config to find freetype2
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: inappropriate [OE specific]
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 configure.ac | 9 +++++++--
14 1 file changed, 7 insertions(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index 53560ea..b5bb6a3 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -41,8 +41,13 @@ AC_CHECK_FUNCS(strndup)
21
22 AC_PATH_X
23
24-AC_CHECK_FT2([9.0.3],[],
25- [AC_MSG_ERROR([FreeType2 is required to compile this library])])
26+PKG_CHECK_MODULES(FT2, freetype2,
27+ CFLAGS="$CFLAGS $FT2_CFLAGS"
28+ LIBS="$LIBS $FT2_LIBS",
29+ AC_MSG_ERROR([FreeType2 is required to compile this library])
30+)
31+AC_SUBST([FT2_CFLAGS])
32+AC_SUBST([FT2_LIBS])
33
34 AC_PATH_XTRA
35
36--
372.5.5
38
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch b/meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch
new file mode 100644
index 0000000000..830783e204
--- /dev/null
+++ b/meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch
@@ -0,0 +1,38 @@
1From daabb4110661c4358ec73293d5c0b2106f567c1f Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Sun, 23 Oct 2016 23:54:14 +0200
4Subject: [PATCH] Makefile.am: remove useless and breaking code
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Pending
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 Makefile.am | 9 ---------
14 1 file changed, 9 deletions(-)
15
16diff --git a/Makefile.am b/Makefile.am
17index 89a8a7f..e582a34 100644
18--- a/Makefile.am
19+++ b/Makefile.am
20@@ -24,15 +24,6 @@ EXTRA_DIST = \
21 m4 \
22 $(NULL)
23
24-# Print out an informative summary.
25-all-local:
26- @$(ECHO) "Done."
27- @$(ECHO)
28- @if test "x$(MAKECMDGOALS)" = "xall-am" -o "x$(.TARGETS)" = "xall-am" -o "x$(MAKECMDGOALS)" = "x" -o "x$(.TARGETS)" = "x" ; then \
29- $(ECHO) "---" ;\
30- $(ECHO) "Run 'make install' to begin installation into $(prefix)" ;\
31- fi
32- @$(ECHO)
33
34 # Upload documentation
35 DOC = docs/html docs/latex/ftgl.pdf
36--
372.5.5
38
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb b/meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb
new file mode 100644
index 0000000000..4af3803f1a
--- /dev/null
+++ b/meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb
@@ -0,0 +1,24 @@
1SUMMARY = "OpenGL frontend to Freetype 2"
2HOMEPAGE = "https://sourceforge.net/projects/ftgl/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=527a83e92c7bf363025380eec05df6e4"
5
6inherit autotools pkgconfig
7
8DEPENDS += " \
9 freetype \
10 freeglut \
11"
12
13SRC_URI = " \
14 ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://0001-use-pkg-config-to-find-freetype2.patch \
16 file://0002-Makefile.am-remove-useless-and-breaking-code.patch \
17"
18SRC_URI[md5sum] = "c7879018cde844059495b3029b0b6503"
19SRC_URI[sha256sum] = "521ff7bd62c459ff5372e269c223e2a6107a6a99a36afdc2ae634a973af70c59"
20
21S = "${WORKDIR}/ftgl-2.1.3~rc5"
22
23# undefined reference to symbol 'sin@@GLIBC_2.4'
24CFLAGS += "-lm"