diff options
-rw-r--r-- | meta-oe/recipes-bsp/fwupd/fwupd/c54ae9c524998e449b822feb465a0c90317cd735.patch | 26 | ||||
-rw-r--r-- | meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb (renamed from meta-oe/recipes-bsp/fwupd/fwupd_1.8.4.bb) | 20 |
2 files changed, 12 insertions, 34 deletions
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd/c54ae9c524998e449b822feb465a0c90317cd735.patch b/meta-oe/recipes-bsp/fwupd/fwupd/c54ae9c524998e449b822feb465a0c90317cd735.patch deleted file mode 100644 index 947c764030..0000000000 --- a/meta-oe/recipes-bsp/fwupd/fwupd/c54ae9c524998e449b822feb465a0c90317cd735.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From c54ae9c524998e449b822feb465a0c90317cd735 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 20 Sep 2022 15:10:26 +0100 | ||
4 | Subject: [PATCH] trivial: Fix compile when using python 3.7 or older | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/fwupd/fwupd/pull/5051] | ||
7 | Signed-off-by: Richard Hughes <richard@hughsie.com> | ||
8 | --- | ||
9 | contrib/generate-gresource-xml.py | 5 ++++- | ||
10 | 1 file changed, 4 insertions(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/contrib/generate-gresource-xml.py b/contrib/generate-gresource-xml.py | ||
13 | index 235a770020..569c804937 100755 | ||
14 | --- a/contrib/generate-gresource-xml.py | ||
15 | +++ b/contrib/generate-gresource-xml.py | ||
16 | @@ -23,6 +23,9 @@ | ||
17 | n_file.set("preprocess", "xml-stripblanks") | ||
18 | n_file.set("alias", os.path.basename(fn)) | ||
19 | with open(sys.argv[1], "wb") as f: | ||
20 | - f.write(ET.tostring(root, "utf-8", xml_declaration=True)) | ||
21 | + try: | ||
22 | + f.write(ET.tostring(root, "utf-8", xml_declaration=True)) | ||
23 | + except TypeError: | ||
24 | + f.write(ET.tostring(root, "utf-8")) | ||
25 | |||
26 | sys.exit(0) | ||
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd_1.8.4.bb b/meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb index 99077923dc..0f889ca8fc 100644 --- a/meta-oe/recipes-bsp/fwupd/fwupd_1.8.4.bb +++ b/meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb | |||
@@ -5,9 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | |||
5 | DEPENDS = "glib-2.0 libxmlb json-glib libjcat gcab vala-native" | 5 | DEPENDS = "glib-2.0 libxmlb json-glib libjcat gcab vala-native" |
6 | 6 | ||
7 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz \ | 7 | SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz \ |
8 | file://c54ae9c524998e449b822feb465a0c90317cd735.patch \ | ||
9 | file://run-ptest" | 8 | file://run-ptest" |
10 | SRC_URI[sha256sum] = "adfa07434cdc29ec41c40fef460e8d970963fe0c7e849dec7f3932adb161f886" | 9 | SRC_URI[sha256sum] = "719a791ac4ba5988aeb93ec42778bd65d33cb075d0c093b5c04e5e1682be528a" |
11 | 10 | ||
12 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases" | 11 | UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases" |
13 | 12 | ||
@@ -18,7 +17,7 @@ inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-do | |||
18 | 17 | ||
19 | GIDOCGEN_MESON_OPTION = 'docs' | 18 | GIDOCGEN_MESON_OPTION = 'docs' |
20 | GIDOCGEN_MESON_ENABLE_FLAG = 'docgen' | 19 | GIDOCGEN_MESON_ENABLE_FLAG = 'docgen' |
21 | GIDOCGEN_MESON_DISABLE_FLAG = 'none' | 20 | GIDOCGEN_MESON_DISABLE_FLAG = 'disabled' |
22 | 21 | ||
23 | PACKAGECONFIG ??= "curl gnutls gudev gusb \ | 22 | PACKAGECONFIG ??= "curl gnutls gudev gusb \ |
24 | ${@bb.utils.filter('DISTRO_FEATURES', 'bluetooth polkit', d)} \ | 23 | ${@bb.utils.filter('DISTRO_FEATURES', 'bluetooth polkit', d)} \ |
@@ -26,23 +25,25 @@ PACKAGECONFIG ??= "curl gnutls gudev gusb \ | |||
26 | ${@bb.utils.contains('MACHINE_FEATURES', 'efi', 'plugin_uefi_capsule plugin_uefi_pk', '', d)} \ | 25 | ${@bb.utils.contains('MACHINE_FEATURES', 'efi', 'plugin_uefi_capsule plugin_uefi_pk', '', d)} \ |
27 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests plugin_dummy', '', d)} \ | 26 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests plugin_dummy', '', d)} \ |
28 | hsi \ | 27 | hsi \ |
28 | plugin_android_boot \ | ||
29 | plugin_acpi_phat \ | 29 | plugin_acpi_phat \ |
30 | plugin_amt \ | ||
31 | plugin_bcm57xx \ | 30 | plugin_bcm57xx \ |
32 | plugin_emmc \ | 31 | plugin_emmc \ |
33 | plugin_ep963x \ | 32 | plugin_ep963x \ |
34 | plugin_fastboot \ | 33 | plugin_fastboot \ |
35 | plugin_flashrom \ | 34 | plugin_flashrom \ |
36 | plugin_gpio \ | 35 | plugin_gpio \ |
36 | plugin_igsc \ | ||
37 | plugin_intel_me \ | ||
37 | plugin_intel_spi \ | 38 | plugin_intel_spi \ |
38 | plugin_logitech_bulkcontroller \ | 39 | plugin_logitech_bulkcontroller \ |
40 | plugin_logitech_scribe \ | ||
39 | plugin_modem_manager \ | 41 | plugin_modem_manager \ |
40 | plugin_msr \ | 42 | plugin_msr \ |
41 | plugin_nitrokey \ | 43 | plugin_nitrokey \ |
42 | plugin_nvme \ | 44 | plugin_nvme \ |
43 | plugin_parade_lspcon \ | 45 | plugin_parade_lspcon \ |
44 | plugin_pixart_rf \ | 46 | plugin_pixart_rf \ |
45 | plugin_platform_integrity \ | ||
46 | plugin_realtek_mst \ | 47 | plugin_realtek_mst \ |
47 | plugin_redfish \ | 48 | plugin_redfish \ |
48 | plugin_synaptics_mst \ | 49 | plugin_synaptics_mst \ |
@@ -74,7 +75,7 @@ PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gcab-native" | |||
74 | 75 | ||
75 | # TODO plugins-all meta-option that expands to all plugin_*? | 76 | # TODO plugins-all meta-option that expands to all plugin_*? |
76 | PACKAGECONFIG[plugin_acpi_phat] = "-Dplugin_acpi_phat=true,-Dplugin_acpi_phat=false" | 77 | PACKAGECONFIG[plugin_acpi_phat] = "-Dplugin_acpi_phat=true,-Dplugin_acpi_phat=false" |
77 | PACKAGECONFIG[plugin_amt] = "-Dplugin_amt=true,-Dplugin_amt=false" | 78 | PACKAGECONFIG[plugin_android_boot] = "-Dplugin_android_boot=enabled,-Dplugin_android_boot=disabled" |
78 | PACKAGECONFIG[plugin_bcm57xx] = "-Dplugin_bcm57xx=true,-Dplugin_bcm57xx=false" | 79 | PACKAGECONFIG[plugin_bcm57xx] = "-Dplugin_bcm57xx=true,-Dplugin_bcm57xx=false" |
79 | PACKAGECONFIG[plugin_cfu] = "-Dplugin_cfu=true,-Dplugin_cfu=false" | 80 | PACKAGECONFIG[plugin_cfu] = "-Dplugin_cfu=true,-Dplugin_cfu=false" |
80 | PACKAGECONFIG[plugin_dell] = "-Dplugin_dell=true,-Dplugin_dell=false,libsmbios" | 81 | PACKAGECONFIG[plugin_dell] = "-Dplugin_dell=true,-Dplugin_dell=false,libsmbios" |
@@ -84,15 +85,17 @@ PACKAGECONFIG[plugin_ep963x] = "-Dplugin_ep963x=true,-Dplugin_ep963x=false" | |||
84 | PACKAGECONFIG[plugin_fastboot] = "-Dplugin_fastboot=true,-Dplugin_fastboot=false" | 85 | PACKAGECONFIG[plugin_fastboot] = "-Dplugin_fastboot=true,-Dplugin_fastboot=false" |
85 | PACKAGECONFIG[plugin_flashrom] = "-Dplugin_flashrom=true,-Dplugin_flashrom=false,flashrom" | 86 | PACKAGECONFIG[plugin_flashrom] = "-Dplugin_flashrom=true,-Dplugin_flashrom=false,flashrom" |
86 | PACKAGECONFIG[plugin_gpio] = "-Dplugin_gpio=true,-Dplugin_gpio=false" | 87 | PACKAGECONFIG[plugin_gpio] = "-Dplugin_gpio=true,-Dplugin_gpio=false" |
88 | PACKAGECONFIG[plugin_igsc] = "-Dplugin_igsc=enabled,-Dplugin_igsc=disabled" | ||
89 | PACKAGECONFIG[plugin_intel_me] = "-Dplugin_intel_me=enabled,-Dplugin_intel_me=disabled" | ||
87 | PACKAGECONFIG[plugin_intel_spi] = "-Dplugin_intel_spi=true -Dlzma=true,-Dplugin_intel_spi=false -Dlzma=false,xz" | 90 | PACKAGECONFIG[plugin_intel_spi] = "-Dplugin_intel_spi=true -Dlzma=true,-Dplugin_intel_spi=false -Dlzma=false,xz" |
88 | PACKAGECONFIG[plugin_logitech_bulkcontroller] = "-Dplugin_logitech_bulkcontroller=true,-Dplugin_logitech_bulkcontroller=false,protobuf-c-native protobuf-c" | 91 | PACKAGECONFIG[plugin_logitech_bulkcontroller] = "-Dplugin_logitech_bulkcontroller=true,-Dplugin_logitech_bulkcontroller=false,protobuf-c-native protobuf-c" |
92 | PACKAGECONFIG[plugin_logitech_scribe] = "-Dplugin_logitech_scribe=enabled,-Dplugin_logitech_scribe=disabled" | ||
89 | PACKAGECONFIG[plugin_modem_manager] = "-Dplugin_modem_manager=true,-Dplugin_modem_manager=false,libqmi modemmanager" | 93 | PACKAGECONFIG[plugin_modem_manager] = "-Dplugin_modem_manager=true,-Dplugin_modem_manager=false,libqmi modemmanager" |
90 | PACKAGECONFIG[plugin_msr] = "-Dplugin_msr=true,-Dplugin_msr=false,cpuid" | 94 | PACKAGECONFIG[plugin_msr] = "-Dplugin_msr=true,-Dplugin_msr=false,cpuid" |
91 | PACKAGECONFIG[plugin_nitrokey] = "-Dplugin_nitrokey=true,-Dplugin_nitrokey=false" | 95 | PACKAGECONFIG[plugin_nitrokey] = "-Dplugin_nitrokey=true,-Dplugin_nitrokey=false" |
92 | PACKAGECONFIG[plugin_nvme] = "-Dplugin_nvme=true,-Dplugin_nvme=false" | 96 | PACKAGECONFIG[plugin_nvme] = "-Dplugin_nvme=true,-Dplugin_nvme=false" |
93 | PACKAGECONFIG[plugin_parade_lspcon] = "-Dplugin_parade_lspcon=true,-Dplugin_parade_lspcon=false" | 97 | PACKAGECONFIG[plugin_parade_lspcon] = "-Dplugin_parade_lspcon=true,-Dplugin_parade_lspcon=false" |
94 | PACKAGECONFIG[plugin_pixart_rf] = "-Dplugin_pixart_rf=true,-Dplugin_pixart_rf=false" | 98 | PACKAGECONFIG[plugin_pixart_rf] = "-Dplugin_pixart_rf=true,-Dplugin_pixart_rf=false" |
95 | PACKAGECONFIG[plugin_platform_integrity] = "-Dplugin_platform_integrity=true,-Dplugin_platform_integrity=false" | ||
96 | PACKAGECONFIG[plugin_powerd] = "-Dplugin_powerd=true,-Dplugin_powerd=false" | 99 | PACKAGECONFIG[plugin_powerd] = "-Dplugin_powerd=true,-Dplugin_powerd=false" |
97 | PACKAGECONFIG[plugin_realtek_mst] = "-Dplugin_realtek_mst=true,-Dplugin_realtek_mst=false" | 100 | PACKAGECONFIG[plugin_realtek_mst] = "-Dplugin_realtek_mst=true,-Dplugin_realtek_mst=false" |
98 | PACKAGECONFIG[plugin_redfish] = "-Dplugin_redfish=true,-Dplugin_redfish=false" | 101 | PACKAGECONFIG[plugin_redfish] = "-Dplugin_redfish=true,-Dplugin_redfish=false" |
@@ -107,12 +110,13 @@ PACKAGECONFIG[plugin_uf2] = "-Dplugin_uf2=true,-Dplugin_uf2=false" | |||
107 | PACKAGECONFIG[plugin_upower] = "-Dplugin_upower=true,-Dplugin_upower=false" | 110 | PACKAGECONFIG[plugin_upower] = "-Dplugin_upower=true,-Dplugin_upower=false" |
108 | 111 | ||
109 | # Always disable these plugins on non-x86 platforms as they don't compile or are useless | 112 | # Always disable these plugins on non-x86 platforms as they don't compile or are useless |
110 | DISABLE_NON_X86 = "plugin_amt plugin_intel_spi plugin_msr" | 113 | DISABLE_NON_X86 = "plugin_intel_me plugin_intel_spi plugin_msr" |
111 | DISABLE_NON_X86:x86 = "" | 114 | DISABLE_NON_X86:x86 = "" |
112 | DISABLE_NON_X86:x86-64 = "" | 115 | DISABLE_NON_X86:x86-64 = "" |
113 | PACKAGECONFIG:remove = "${DISABLE_NON_X86}" | 116 | PACKAGECONFIG:remove = "${DISABLE_NON_X86}" |
114 | 117 | ||
115 | FILES:${PN} += "${libdir}/fwupd-plugins-* \ | 118 | FILES:${PN} += "${libdir}/fwupd-plugins-* \ |
119 | ${libdir}/fwupd-${PV} \ | ||
116 | ${systemd_unitdir} \ | 120 | ${systemd_unitdir} \ |
117 | ${datadir}/fish \ | 121 | ${datadir}/fish \ |
118 | ${datadir}/metainfo \ | 122 | ${datadir}/metainfo \ |