summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/geany/geany/0001-configure-Upgrade-to-a-modern-Gettext.patch11
-rw-r--r--meta-oe/recipes-devtools/geany/geany/geany-2.0-gcc15.patch146
-rw-r--r--meta-oe/recipes-devtools/geany/geany_2.0.bb (renamed from meta-oe/recipes-devtools/geany/geany_1.38.bb)3
3 files changed, 153 insertions, 7 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany/0001-configure-Upgrade-to-a-modern-Gettext.patch b/meta-oe/recipes-devtools/geany/geany/0001-configure-Upgrade-to-a-modern-Gettext.patch
index b966847195..e6db688974 100644
--- a/meta-oe/recipes-devtools/geany/geany/0001-configure-Upgrade-to-a-modern-Gettext.patch
+++ b/meta-oe/recipes-devtools/geany/geany/0001-configure-Upgrade-to-a-modern-Gettext.patch
@@ -11,12 +11,11 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
11 11
12--- a/configure.ac 12--- a/configure.ac
13+++ b/configure.ac 13+++ b/configure.ac
14@@ -8,7 +8,7 @@ AC_CONFIG_AUX_DIR([build-aux]) 14@@ -9,6 +9,7 @@ AC_CONFIG_MACRO_DIR([m4])
15 AC_CONFIG_MACRO_DIR([m4])
16 AM_INIT_AUTOMAKE([1.11 -Wall parallel-tests subdir-objects]) 15 AM_INIT_AUTOMAKE([1.11 -Wall parallel-tests subdir-objects])
17 AC_CONFIG_HEADERS([config.h]) 16 AC_CONFIG_HEADERS([config.h])
18-
19+AC_PROG_INTLTOOL
20 m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
21 17
22 GEANY_PREFIX 18+AC_PROG_INTLTOOL
19 # Silence "AC_LINK_IFELSE before AC_USE_SYSTEM_EXTENSIONS" warnings
20 # Note: Enables _GNU_SOURCE on Linux
21 AC_USE_SYSTEM_EXTENSIONS
diff --git a/meta-oe/recipes-devtools/geany/geany/geany-2.0-gcc15.patch b/meta-oe/recipes-devtools/geany/geany/geany-2.0-gcc15.patch
new file mode 100644
index 0000000000..2886b73d22
--- /dev/null
+++ b/meta-oe/recipes-devtools/geany/geany/geany-2.0-gcc15.patch
@@ -0,0 +1,146 @@
1Fix build with GCC-15
2
3Upstream-Status: Backport [https://sourceforge.net/p/scintilla/code/ci/c7ffad21b23dfad4e8e9f36bb587acc2f6e84fee/]
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5
6--- a/scintilla/gtk/PlatGTK.cxx
7+++ b/scintilla/gtk/PlatGTK.cxx
8@@ -5,6 +5,7 @@
9
10 #include <cstddef>
11 #include <cstdlib>
12+#include <cstdint>
13 #include <cstring>
14 #include <cstdio>
15 #include <cmath>
16--- a/scintilla/src/AutoComplete.cxx
17+++ b/scintilla/src/AutoComplete.cxx
18@@ -7,6 +7,7 @@
19
20 #include <cstddef>
21 #include <cstdlib>
22+#include <cstdint>
23 #include <cassert>
24 #include <cstring>
25 #include <cstdio>
26--- a/scintilla/src/CallTip.cxx
27+++ b/scintilla/src/CallTip.cxx
28@@ -7,6 +7,7 @@
29
30 #include <cstddef>
31 #include <cstdlib>
32+#include <cstdint>
33 #include <cassert>
34 #include <cstring>
35 #include <cstdio>
36--- a/scintilla/src/CellBuffer.cxx
37+++ b/scintilla/src/CellBuffer.cxx
38@@ -7,6 +7,7 @@
39
40 #include <cstddef>
41 #include <cstdlib>
42+#include <cstdint>
43 #include <cassert>
44 #include <cstring>
45 #include <cstdio>
46--- a/scintilla/src/ChangeHistory.cxx
47+++ b/scintilla/src/ChangeHistory.cxx
48@@ -7,6 +7,7 @@
49
50 #include <cstddef>
51 #include <cstdlib>
52+#include <cstdint>
53 #include <cassert>
54
55 #include <stdexcept>
56--- a/scintilla/src/Decoration.cxx
57+++ b/scintilla/src/Decoration.cxx
58@@ -6,6 +6,7 @@
59
60 #include <cstddef>
61 #include <cstdlib>
62+#include <cstdint>
63 #include <cstring>
64 #include <cstdio>
65 #include <cstdarg>
66--- a/scintilla/src/Document.cxx
67+++ b/scintilla/src/Document.cxx
68@@ -7,6 +7,7 @@
69
70 #include <cstddef>
71 #include <cstdlib>
72+#include <cstdint>
73 #include <cassert>
74 #include <cstring>
75 #include <cstdio>
76--- a/scintilla/src/Indicator.cxx
77+++ b/scintilla/src/Indicator.cxx
78@@ -5,6 +5,7 @@
79 // Copyright 1998-2001 by Neil Hodgson <neilh@scintilla.org>
80 // The License.txt file describes the conditions under which this software may be distributed.
81
82+#include <cstdint>
83 #include <cmath>
84
85 #include <stdexcept>
86--- a/scintilla/src/KeyMap.cxx
87+++ b/scintilla/src/KeyMap.cxx
88@@ -6,6 +6,7 @@
89 // The License.txt file describes the conditions under which this software may be distributed.
90
91 #include <cstdlib>
92+#include <cstdint>
93
94 #include <stdexcept>
95 #include <string_view>
96--- a/scintilla/src/LineMarker.cxx
97+++ b/scintilla/src/LineMarker.cxx
98@@ -5,6 +5,7 @@
99 // Copyright 1998-2011 by Neil Hodgson <neilh@scintilla.org>
100 // The License.txt file describes the conditions under which this software may be distributed.
101
102+#include <cstdint>
103 #include <cstring>
104 #include <cmath>
105
106--- a/scintilla/src/PerLine.cxx
107+++ b/scintilla/src/PerLine.cxx
108@@ -6,6 +6,7 @@
109 // The License.txt file describes the conditions under which this software may be distributed.
110
111 #include <cstddef>
112+#include <cstdint>
113 #include <cassert>
114 #include <cstring>
115
116--- a/scintilla/src/Style.cxx
117+++ b/scintilla/src/Style.cxx
118@@ -5,6 +5,8 @@
119 // Copyright 1998-2001 by Neil Hodgson <neilh@scintilla.org>
120 // The License.txt file describes the conditions under which this software may be distributed.
121
122+#include <cstdint>
123+
124 #include <stdexcept>
125 #include <string_view>
126 #include <vector>
127--- a/scintilla/src/ViewStyle.cxx
128+++ b/scintilla/src/ViewStyle.cxx
129@@ -6,6 +6,7 @@
130 // The License.txt file describes the conditions under which this software may be distributed.
131
132 #include <cstddef>
133+#include <cstdint>
134 #include <cassert>
135 #include <cstring>
136 #include <cmath>
137--- a/scintilla/src/XPM.cxx
138+++ b/scintilla/src/XPM.cxx
139@@ -6,6 +6,7 @@
140 // The License.txt file describes the conditions under which this software may be distributed.
141
142 #include <cstdlib>
143+#include <cstdint>
144 #include <cstring>
145 #include <climits>
146
diff --git a/meta-oe/recipes-devtools/geany/geany_1.38.bb b/meta-oe/recipes-devtools/geany/geany_2.0.bb
index d75e3b57fb..4b51195e08 100644
--- a/meta-oe/recipes-devtools/geany/geany_1.38.bb
+++ b/meta-oe/recipes-devtools/geany/geany_2.0.bb
@@ -11,8 +11,9 @@ REQUIRED_DISTRO_FEATURES = "x11"
11 11
12SRC_URI = "https://download.geany.org/${BP}.tar.bz2 \ 12SRC_URI = "https://download.geany.org/${BP}.tar.bz2 \
13 file://0001-configure-Upgrade-to-a-modern-Gettext.patch \ 13 file://0001-configure-Upgrade-to-a-modern-Gettext.patch \
14 file://geany-2.0-gcc15.patch \
14 " 15 "
15SRC_URI[sha256sum] = "abff176e4d48bea35ee53037c49c82f90b6d4c23e69aed6e4a5ca8ccd3aad546" 16SRC_URI[sha256sum] = "565b4cd2f0311c1e3a167ec71c4a32dba642e0fe554ae5bb6b8177b7a74ccc92"
16 17
17FILES:${PN} += "${datadir}/icons" 18FILES:${PN} += "${datadir}/icons"
18 19