summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-periphery.inc9
-rw-r--r--meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb13
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-periphery.inc b/meta-python/recipes-devtools/python/python-periphery.inc
deleted file mode 100644
index 0171f63f83..0000000000
--- a/meta-python/recipes-devtools/python/python-periphery.inc
+++ /dev/null
@@ -1,9 +0,0 @@
1DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
2HOMEPAGE = "http://pythonhosted.org/python-periphery/"
3LICENSE = "MIT"
4
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1ecf5c2354c22fb5bfd53eefb8f9e65b"
6
7PYPI_PACKAGE = "python-periphery"
8
9RDEPENDS_${PN} += "${PYTHON_PN}-mmap"
diff --git a/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb b/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb
index e9944274b9..1aa48625ff 100644
--- a/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb
@@ -1,5 +1,14 @@
1inherit pypi setuptools3 1DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
2require python-periphery.inc 2HOMEPAGE = "http://pythonhosted.org/python-periphery/"
3LICENSE = "MIT"
4
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1ecf5c2354c22fb5bfd53eefb8f9e65b"
3 6
4SRC_URI[md5sum] = "1d958f02575d4a19734ee2dd92336157" 7SRC_URI[md5sum] = "1d958f02575d4a19734ee2dd92336157"
5SRC_URI[sha256sum] = "5da4d5f40ff8974cf6c724587baa674d7e0593f07b6f6ee896104f11c1be18ec" 8SRC_URI[sha256sum] = "5da4d5f40ff8974cf6c724587baa674d7e0593f07b6f6ee896104f11c1be18ec"
9
10inherit pypi setuptools3
11
12PYPI_PACKAGE = "python-periphery"
13
14RDEPENDS_${PN} += "${PYTHON_PN}-mmap"