diff options
-rw-r--r-- | meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch | 57 | ||||
-rw-r--r-- | meta-oe/recipes-support/srecord/srecord_1.64.bb | 23 |
2 files changed, 80 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch b/meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch new file mode 100644 index 0000000000..9b2bd99795 --- /dev/null +++ b/meta-oe/recipes-support/srecord/files/add-option-to-remove-docs.patch | |||
@@ -0,0 +1,57 @@ | |||
1 | Add option to build this utility without a documentation. | ||
2 | |||
3 | For full documentation building are necessary utilities like | ||
4 | groff and ps2pdf. Full documentation can takes a lot of space. | ||
5 | So it can be disabled by overloading makefile variable WITHOUT_DOC. | ||
6 | |||
7 | Upstream-Status: Inappropriate [Other] | ||
8 | Workaround specific to our build system. | ||
9 | |||
10 | Signed-off-by: Andrej Valek <andrej.valek@siemens.com> | ||
11 | |||
12 | diff --git a/Makefile.in b/Makefile.in | ||
13 | index 9bdd8f1..a2b5494 100644 | ||
14 | --- a/Makefile.in | ||
15 | +++ b/Makefile.in | ||
16 | @@ -141,6 +141,14 @@ GROFF = @GROFF@ | ||
17 | # | ||
18 | SOELIM = @SOELIM@ | ||
19 | |||
20 | +# Option to build this utility without building and installing the documentation. | ||
21 | +WITHOUT_DOC ?= 0 | ||
22 | +ifeq ($(WITHOUT_DOC),0) | ||
23 | + BUILD_DOC = all-doc | ||
24 | + INST_DOC = install-doc | ||
25 | + CLR_DOC = clean-doc | ||
26 | +endif | ||
27 | + | ||
28 | # --------------------------------------------------------- | ||
29 | # You should not need to change anything below this line. | ||
30 | |||
31 | @@ -4090,7 +4098,7 @@ bin/test_url_decode: $(test_url_decode_obj) .bin srecord/libsrecord.la | ||
32 | $(LIBTOOL) --mode=link --tag=CXX $(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ \ | ||
33 | $(test_url_decode_obj) srecord/libsrecord.la $(LDFLAGS) $(LIBS) | ||
34 | |||
35 | -all: all-bin all-doc | ||
36 | +all: all-bin $(BUILD_DOC) | ||
37 | |||
38 | all-bin: bin/srec_cat bin/srec_cmp bin/srec_info bin/test_arglex_ambiguous \ | ||
39 | bin/test_crc16 bin/test_fletcher16 bin/test_gecos \ | ||
40 | @@ -4156,7 +4164,7 @@ test_files = t0001a t0002a t0003a t0004a t0005a t0006a t0007a t0008a t0009a \ | ||
41 | sure: $(test_files) | ||
42 | @echo Passed All Tests | ||
43 | |||
44 | -clean: clean-bin clean-doc clean-misc clean-obj | ||
45 | +clean: clean-bin $(CLR_DOC) clean-misc clean-obj | ||
46 | |||
47 | clean-bin: | ||
48 | rm -f bin/srec_cat bin/srec_cmp bin/srec_info bin/test_arglex_ambiguous | ||
49 | @@ -4443,7 +4451,7 @@ distclean-directories: | ||
50 | rm -rf test/fletcher16/.libs test/gecos/.libs test/hyphen/.libs | ||
51 | rm -rf test/url_decode/.libs | ||
52 | |||
53 | -install: install-bin install-doc install-include install-libdir install-man | ||
54 | +install: install-bin $(INST_DOC) install-include install-libdir install-man | ||
55 | |||
56 | install-bin: $(bindir)/srec_cat $(bindir)/srec_cmp $(bindir)/srec_info | ||
57 | |||
diff --git a/meta-oe/recipes-support/srecord/srecord_1.64.bb b/meta-oe/recipes-support/srecord/srecord_1.64.bb new file mode 100644 index 0000000000..fe1af476f2 --- /dev/null +++ b/meta-oe/recipes-support/srecord/srecord_1.64.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "A collection of powerful tools for manipulating EPROM load files." | ||
2 | SECTION = "devel" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8dfcbf2f0a144b97f0931b6394debea7" | ||
5 | |||
6 | SRC_URI = " \ | ||
7 | http://srecord.sourceforge.net/srecord-${PV}.tar.gz \ | ||
8 | file://add-option-to-remove-docs.patch \ | ||
9 | " | ||
10 | |||
11 | SRC_URI[md5sum] = "4de4a7497472d7972645c2af91313769" | ||
12 | SRC_URI[sha256sum] = "49a4418733c508c03ad79a29e95acec9a2fbc4c7306131d2a8f5ef32012e67e2" | ||
13 | |||
14 | DEPENDS = "libtool-native boost groff-native" | ||
15 | |||
16 | inherit autotools-brokensep | ||
17 | |||
18 | EXTRA_OECONF = "--without-gcrypt LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool" | ||
19 | |||
20 | # Set variable WITHOUT_DOC=0 to enable documentation generation | ||
21 | EXTRA_OEMAKE = "WITHOUT_DOC=1" | ||
22 | |||
23 | BBCLASSEXTEND = "native" | ||