summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-core_1.30.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-core_1.30.0.bb b/meta-python/recipes-devtools/python/python3-google-api-core_1.30.0.bb
new file mode 100644
index 0000000000..08cc35d064
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-core_1.30.0.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
3AUTHOR = "Google LLC"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7inherit pypi setuptools3
8
9SRC_URI[sha256sum] = "0724d354d394b3d763bc10dfee05807813c5210f0bd9b8e2ddf6b6925603411c"
10
11RDEPENDS_${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-logging \
15 ${PYTHON_PN}-math \
16"
17
18RDEPENDS_${PN} += "\
19 ${PYTHON_PN}-googleapis-common-protos \
20 ${PYTHON_PN}-google-auth \
21 ${PYTHON_PN}-grpcio \
22 ${PYTHON_PN}-protobuf \
23 ${PYTHON_PN}-pytz \
24 ${PYTHON_PN}-requests \
25 ${PYTHON_PN}-six \
26"