summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch12
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch62
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.4.bb (renamed from meta-oe/recipes-connectivity/iwd/iwd_1.0.bb)7
3 files changed, 72 insertions, 9 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch b/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch
index 93ef007f86..80126a870d 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch
+++ b/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch
@@ -1,4 +1,4 @@
1From f2a2b9f445ab1e31fbb27a74744e9a2ededfce17 Mon Sep 17 00:00:00 2001 1From 46fc0e197598579dc05e42f137e84f86a9b926e9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 4 Nov 2019 16:38:04 -0800 3Date: Mon, 4 Nov 2019 16:38:04 -0800
4Subject: [PATCH] Makefile.am: Avoid redirection of input and output files 4Subject: [PATCH] Makefile.am: Avoid redirection of input and output files
@@ -15,26 +15,24 @@ make[1]: *** [Makefile:3544: monitor/iwmon.1] Error 1
15Upstream-Status: Pending 15Upstream-Status: Pending
16 16
17Signed-off-by: Khem Raj <raj.khem@gmail.com> 17Signed-off-by: Khem Raj <raj.khem@gmail.com>
18
18--- 19---
19 Makefile.am | 5 +++-- 20 Makefile.am | 5 +++--
20 1 file changed, 3 insertions(+), 2 deletions(-) 21 1 file changed, 3 insertions(+), 2 deletions(-)
21 22
22diff --git a/Makefile.am b/Makefile.am 23diff --git a/Makefile.am b/Makefile.am
23index 823b7d02..1bd0005c 100644 24index 8c69d9f4..35a25fc0 100644
24--- a/Makefile.am 25--- a/Makefile.am
25+++ b/Makefile.am 26+++ b/Makefile.am
26@@ -626,8 +626,9 @@ SED_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \ 27@@ -629,8 +629,9 @@ SED_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
27 < $< > $@ 28 < $< > $@
28 29
29 if RUN_RST2MAN 30 if RUN_RST2MAN
30-RST2MAN_PROCESS = $(AM_V_GEN)$(RST2MAN) --strict --no-raw --no-generator \ 31-RST2MAN_PROCESS = $(AM_V_GEN)$(RST2MAN) --strict --no-raw --no-generator \
31- --no-datestamp < $< > $@ 32- --no-datestamp $< $@
32+RST2MAN_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && \ 33+RST2MAN_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && \
33+ $(AM_V_GEN)$(RST2MAN) --strict --no-raw \ 34+ $(AM_V_GEN)$(RST2MAN) --strict --no-raw \
34+ --no-generator --no-datestamp $< $@ 35+ --no-generator --no-datestamp $< $@
35 else 36 else
36 RST2MAN_PROCESS = $(AM_V_GEN)test -f $@ || \ 37 RST2MAN_PROCESS = $(AM_V_GEN)test -f $@ || \
37 { echo "Generated manual page $@ does not exist"; false; } 38 { echo "Generated manual page $@ does not exist"; false; }
38--
392.24.0
40
diff --git a/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch b/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch
new file mode 100644
index 0000000000..733f5fea1b
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch
@@ -0,0 +1,62 @@
1From fcdddf2b726439e049992878f90da607414a1a47 Mon Sep 17 00:00:00 2001
2From: Denis Kenzior <denkenz@gmail.com>
3Date: Mon, 3 Feb 2020 11:54:28 -0600
4Subject: [PATCH] build: Support missing rawmemchr
5
6rawmemchr is a GNU extension in glibc that does not exist in musl.
7
8Upstream-status: Backport of https://git.kernel.org/pub/scm/network/wireless/iwd.git/commit/?id=fcdddf2b726439e049992878f90da607414a1a47
9
10Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org>
11
12---
13 configure.ac | 1 +
14 src/missing.h | 10 ++++++++++
15 src/wiphy.c | 1 +
16 3 files changed, 12 insertions(+)
17
18diff --git a/configure.ac b/configure.ac
19index 5ae1401cae17..2d373a47ba68 100644
20--- a/configure.ac
21+++ b/configure.ac
22@@ -128,6 +128,7 @@ AC_DEFINE_UNQUOTED(WIRED_STORAGEDIR, "${wired_storagedir}",
23 [Directory for Ethernet daemon storage files])
24
25 AC_CHECK_FUNCS(explicit_bzero)
26+AC_CHECK_FUNCS(rawmemchr)
27
28 AC_CHECK_HEADERS(linux/types.h linux/if_alg.h)
29
30diff --git a/src/missing.h b/src/missing.h
31index 2bb210ae3c81..2cc80aee5d38 100644
32--- a/src/missing.h
33+++ b/src/missing.h
34@@ -27,3 +27,13 @@ static inline void explicit_bzero(void *s, size_t n)
35 __asm__ __volatile__ ("" : : "r"(s) : "memory");
36 }
37 #endif
38+
39+#ifndef HAVE_RAWMEMCHR
40+static inline void *rawmemchr(const void *s, int c)
41+{
42+_Pragma("GCC diagnostic push")
43+_Pragma("GCC diagnostic ignored \"-Wstringop-overflow=\"")
44+ return memchr(s, c, (size_t) -1);
45+_Pragma("GCC diagnostic pop")
46+}
47+#endif
48diff --git a/src/wiphy.c b/src/wiphy.c
49index 1da479db2dab..511bb27f52b8 100644
50--- a/src/wiphy.c
51+++ b/src/wiphy.c
52@@ -37,6 +37,7 @@
53
54 #include "linux/nl80211.h"
55
56+#include "src/missing.h"
57 #include "src/iwd.h"
58 #include "src/module.h"
59 #include "src/ie.h"
60--
612.21.0
62
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.0.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
index cc34ca2215..ed8f21ac1b 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.0.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
@@ -4,12 +4,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
4 4
5inherit autotools pkgconfig systemd python3native 5inherit autotools pkgconfig systemd python3native
6 6
7DEPENDS = "ell readline dbus python3-docutils-native" 7DEPENDS = "ell readline python3-docutils-native"
8 8
9SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \ 9SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
10 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \ 10 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
11 file://0001-build-Support-missing-rawmemchr.patch \
11 " 12 "
12SRCREV = "971e1d2038a203ad43bd2278a811a9e5ec8d52db" 13SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261"
13S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
14 15
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 16PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
@@ -32,6 +33,8 @@ FILES_${PN} += "${datadir}/dbus-1 ${nonarch_libdir}/modules-load.d ${systemd_uni
32 33
33SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}" 34SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}"
34 35
36RDEPENDS_${PN} = "dbus"
37
35RRECOMMENDS_${PN} = "\ 38RRECOMMENDS_${PN} = "\
36 kernel-module-pkcs7-message \ 39 kernel-module-pkcs7-message \
37 kernel-module-pkcs8-key-parser \ 40 kernel-module-pkcs8-key-parser \